 <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
     "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta http-equiv="Cache-control" content="public" />
<meta name="apple-itunes-app" content="app-id=1054144526" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=0.6, user-scalable=yes" />
<meta property="og:image" content="https://static.gurufocus.com/photos/gurus/guru_logo_square.jpg" />
<script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
              (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
              m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
              })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
                                ga('create', 'UA-21017515-1', 'auto');
                  //Google Optimize
                  ga('require', 'GTM-5KZM8WM');
                  //Tag Manager
                  //ga('require', 'GTM-K799DP4');
                  ga('send', 'pageview');
                                         </script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','dataLayer','GTM-K799DP4');</script>

<meta name="description" content="Fortinet Expands Engage Partner Program Benefits to Further Enable Channel Business Growth, Stocks: FTNT, release date:Mar 10, 2021" /><title>Fortinet Expands Engage Partner Program Benefits to Further Enable Channel Business Growth  - GuruFocus.com</title> <script type="text/javascript">
             this.top.location !== this.location && (this.top.location = this.location);
         </script>
<link href="//apis.gurufocus.com/css/main.css?5.9.37.1234" rel="stylesheet" type="text/css" />

<link rel="stylesheet" type="text/css" href="/apis/css/combined/header.min.css?0909" />
<link rel="stylesheet" type="text/css" href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.css" />
<link href="//www.gurufocus.com/rss.php" rel="alternate" title="GuruFocus New Articles" type="application/rss+xml" />
<link href="//www.gurufocus.com/feed/guru_portfolio_feed.php" rel="alternate" title="Guru Portfolio Updates" type="application/rss+xml" />
<link href="//www.gurufocus.com/rssInsider.php" rel="alternate" title="Insider Trade Updates" type="application/rss+xml" />
<link rel="icon" type="image/ico" href="https://static.gurufocus.com/favicon.ico" />

<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/jquery/1.11.1/jquery.min.js"></script>
<script type="text/javascript" src="//code.jquery.com/jquery-migrate-1.2.1.js"></script>
<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/jqueryui/1.10.3/jquery-ui.min.js"></script>
 <script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/highstock/2.0.0/highstock.js"></script>

<script>
             $.ajaxSetup({
                 cache: true
             });
             
             $(function(){
                if($.fn.tooltip.noConflict) {
                  $.fn.tlp = $.fn.tooltip.noConflict();
                }
             });

            (function(H) {
                H.seriesTypes.line.prototype.requireSorting = false;
            })(Highcharts)
            
         </script>

<script async src="https://www.googletagmanager.com/gtag/js?id=AW-1005049228"></script> <script> window.dataLayer = window.dataLayer || []; function gtag(){dataLayer.push(arguments);} gtag('js', new Date()); gtag('config', 'AW-1005049228');
         </script>
<script data-ad-client="ca-pub-4020868656364652" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <style>
              html {
                background-color: white;
              }

              .darkmode-text {
                font-size: 14px;display: inline-block;color: white;
              }
             html.dark-mode {
                filter: invert(100%);
              }

              html.dark-mode img {
                filter: invert(100%);
              }

              html.dark-mode .embed-video {
                filter: invert(100%);
              }

              html.dark-mode #topMenuSubButton{
                filter: invert(100%);
              }

        /*      html.dark-mode .ratingblock{
                filter: invert(100%);
              }*/

              html.dark-mode .big_bar_box{
                filter: invert(100%);
              }

              html.dark-mode iframe{
                filter: invert(100%);
              }

       /*       html.dark-mode .current-rating{
                filter: invert(100%);
              }*/

              html.dark-mode .ranked-color{
                filter: invert(100%);
              }

              html.dark-mode #menu_container {
                background: white;
              }

              html.dark-mode #footer {
                background: white;
              }

              html.dark-mode .footergrid {
                background: white;
              }

              html.dark-mode .footerli a {
                color: black;
              }

              html.dark-mode #menu li a {
                color: black;
              }

              html.dark-mode .darkmode-text {
                color: black;
              }

              .switch {
                position: relative;
                display: inline-block;
                width: 36px;
                height: 24px;
                vertical-align: top;
              }

              .switch input {
                opacity: 0;
                width: 0;
                height: 0;
              }

              .d-slider {
                position: absolute;
                cursor: pointer;
                top: 0;
                left: 0;
                right: 0;
                bottom: 0;
                background-color: #ccc;
                -webkit-transition: .4s;
                transition: .4s;
              }

              .d-slider:before {
                position: absolute;
                content: "";
                height: 16px;
                width: 16px;
                left: 2px;
                bottom: 4px;
                background-color: white;
                -webkit-transition: .6s;
                transition: .6s;
              }

              input:checked+.d-slider {
                background-color: black;
              }

              input:focus+.d-slider {
                box-shadow: 0 0 1px black;
              }

              input:checked+.d-slider:before {
                -webkit-transform: translateX(16px);
                -ms-transform: translateX(16px);
                transform: translateX(16px);
              }

              /* Rounded sliders */
              .d-slider.round {
                border-radius: 24px;
              }

              .d-slider.round:before {
                border-radius: 50%;
              }

              #clockdiv{
                color: #fff;
                display: inline-block;
                font-weight: 100;
                text-align: center;
                font-size: 30px;
                margin-bottom: 8px;
              }

              #clockdiv > div{
                padding: 8px;
                border-radius: 3px;
                background: #03a6f3;
                display: inline-block;
              }

              #clockdiv div > span{
                padding: 13px;
                border-radius: 3px;
                background: #0272a7;
                display: inline-block;
              }

              .smalltext{
                padding-top: 5px;
                font-size: 16px;
              }

            </style>
<script>
          // document.documentElement.classList.toggle('dark-mode')
          // Dark mode related changes
            function setCookie(name,value,days) {
                var expires = "";
                if (days) {
                    var date = new Date();
                    date.setTime(date.getTime() + (days*24*60*60*1000));
                    expires = "; expires=" + date.toUTCString();
                }
                console.log('Set dark mode')
                console.log(name + "=" + (value || "")  + expires + ";path=/")
                document.cookie = name + "=" + (value || "")  + expires + ";path=/";
            }

            function getCookie(name) {
                var nameEQ = name + "=";
                var ca = document.cookie.split(';');
                for(var i=0;i < ca.length;i++) {
                    var c = ca[i];
                    console.log('c', c)
                    while (c.charAt(0)==' ') c = c.substring(1,c.length);
                    if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length);
                }
                return null;
            }

            function darkMode() {
                let darkmode = getCookie('darkmodes')
                console.log('toggle')
                console.log(darkmode)
                if (!darkmode) {
                    setCookie("darkmodes","1",10*365)
                } else {
                    console.log('delete cookie')
                    document.cookie = "darkmodes" + '=; expires=Thu, 01-Jan-70 00:00:01 GMT;path=/;';
                    document.cookie = "darkmodes" + '=; expires=Thu, 01-Jan-70 00:00:01 GMT;path=/financials;';
                }
                document.documentElement.classList.toggle('dark-mode')
            }

            let darkmode = getCookie('darkmodes')
            console.log('##### darkmode')
            console.log(darkmode)
            if (darkmode && darkmode == 1) {
              document.documentElement.classList.toggle('dark-mode')
            }

        </script>
<link href='https://fonts.googleapis.com/css?family=Roboto:900&subset=latin,greek' rel='stylesheet' type='text/css'>
<style>
	.myCustomClass {
		border: solid 2px #000;
		background-color: #FFF;
		max-width: 300px; /* Change this? */
		min-width: 200px; /* ...and this! */
	}
	.ui-dialog {
		position: fixed;
		padding: .2em;
		width: 320px;
		overflow: hidden;
	}
	.myCustomClass_guru {
		border: solid 2px #000;
		background-color: #FFF;
		max-width: 350px; /* Change this? */
		min-width: 300px; /* ...and this! */     
	}
</style>
<style>
        .newcontent {
            font-family: Monserrat, 'Helvetica Neue', Helvetica, Arial, sans-serif !important;
        }

        #newcontent h1 {
            font: 900 34px/40px 'Roboto', sans-serif;;
            color: #333 !important;
            margin-top: 10px;
            margin-bottom: 10px;
        }

        #newcontent h2 {
            color: #666;
            font: 400 18px/24px Monserrat, 'Helvetica Neue', Helvetica, Arial, sans-serif;
        }

        #articlebody_new {
            font: 400 18px/24px Monserrat, 'Helvetica Neue', Helvetica, Arial, sans-serif;
        }

        .author_avatar {
            float: left;
        }

        .author_avatar_img {
            width: 80px;
        }

        .author_name {
            font-size: 14px;
            font-weight: bold;
            color: #333;
        }

        #author_area {
            float: left;
            margin-bottom: 10px;
            padding-bottom: 10px;
            border-bottom: 1px solid #000;
            width: 100%;
        }

        .header_inner_new {
            border-bottom: none !important;
        }

        .article_page_links {
            color: #333;
        }

        .hr_sec {
            display: block;
            height: 1px;
            border: 0;
            border-top: 1px solid #ccc;
            margin: 1em 0;
            padding: 0;
        }

        .ui-dialog {
            top: 40% !important;
        }

        .firstcharacter {
            float: left;
            color: #333;
            font-size: 55px;
            line-height: 40px;
            padding-top: 4px;
            padding-right: 8px;
            padding-left: 3px;
            font-family: Georgia;
        }

        #ap_container{
            font-size: 0.8em;
            width: 100%;
            max-height:300px;
            overflow: auto;
        }

        table.R10{
            font-size: 9px;
        }

    </style>
<link rel="stylesheet" href="https://static.gurufocus.com/js/share/selection-sharer.css" />
<META name="Description" content="Fortinet Expands Engage Partner Program Benefits to Further Enable Channel Business Growth, Stocks: FTNT, release date:Mar 10, 2021" /><title>Fortinet Expands Engage Partner Program Benefits to Further Enable Channel Business Growth  - GuruFocus.com</title></head><body>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-K799DP4"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="header">
<div id="menu_container">



<div id="menu_container_inner" style="width: 1300px;min-width: 1200px !important;max-width: 1400px !important;">
<div id="logo" class="left">
<a href="/">
<img src="https://static.gurufocus.com/images/logo_small_new.png" id="logo_header" />
</a>
</div>
<ul id="menu">
<div id="dark" class="right" style="margin-top: 8px;height: 30px;line-height: 30px;">
<label class="switch">
<input type="checkbox" onclick="darkMode()">
<span class="d-slider round"></span>
</label>
</div>
<li class="drop ">
<a href="/" class=''>Home</a>
<div class="dropdown_1column ">
<div class="col_1">
 <ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/"> Homepage</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/membership.php"> Membership Levels</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/stock_list.php"> Complete Stock List</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="https://www.gurufocus.com/conference/index.php"> Value Conference</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/ads/books/"> The Book</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/podcast"> Podcast</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/news/281207"> Membership Data Coverage</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/letter.php"> Founder's Message</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="https://www.gurufocus.com/membership/upgrade.php?ref=menu" class="menu_highlight"> FREE Trial</a>
</li>
</ul>
</div>
</div>
</li>
<li class="drop ">
<a href="/screener/" class=''>Screeners</a>
<div class="dropdown_4columns " style='width: 900px'>
<div class="col_1" style="width: 270px">
<h3>
<a class="sub-menu-header" href="/screener">GuruFocus Screeners</a> </h3>
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener"> <div style='color: red; font-weight: bold; word-break: none; width: 230px'>All-In-One Screener</div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Ben+Graham+Lost+Formula&id=70"> <div style='word-break: none; width: 280px'>Ben Graham Lost Formula <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>4 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Canadian+Faster+Growers&id=73"> <div style='word-break: none; width: 280px'>Canadian Faster Growers</div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=CEO+Buys&id=74"> <div style='word-break: none; width: 280px'>CEO Buys <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>2 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=CEO+Buys+after+Price+Drop+%3E+20%25&id=75"> <div style='word-break: none; width: 280px'>CEO Buys after Price Drop > 20% <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>1 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Dividend+Growth+Portfolio&id=77"> <div style='word-break: none; width: 280px'>Dividend Growth Portfolio</div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Dividend+Income+Portfolio&id=78"> <div style='word-break: none; width: 280px'>Dividend Income Portfolio</div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Fast+Growers&id=79"> <div style='word-break: none; width: 280px'>Fast Growers</div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Hedge+Fund+Guru+Top+10+Aggregated&id=80"> <div style='word-break: none; width: 280px'>Hedge Fund Guru Top 10 Aggregated <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>2 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=High+Quality&id=81"> <div style='word-break: none; width: 280px'>High Quality</div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=High+Quality+Low+Capex+w+ROE+ROC+min&id=84"> <div style='word-break: none; width: 280px'>High Quality Low Capex w ROE ROC min</div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=High+Quality+%26+Low+Capex&id=87"> <div style='word-break: none; width: 280px'>High Quality & Low Capex <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>2 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=High+Yield+Insider+Buys&id=88"> <div style='word-break: none; width: 280px'>High Yield Insider Buys</div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Historical+High+Dividend+Yields&id=89"> <div style='word-break: none; width: 280px'>Historical High Dividend Yields <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>2 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=International+Gurus%27+Top+Holdings&id=90"> <div style='word-break: none; width: 280px'>International Gurus' Top Holdings <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>7 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=James+Montier+Short+Screen&id=91"> <div style='word-break: none; width: 280px'>James Montier Short Screen <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>12 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Margin+Decliners&id=92"> <div style='word-break: none; width: 280px'>Margin Decliners <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>4 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Mega+Caps&id=93"> <div style='word-break: none; width: 280px'>Mega Caps <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>2 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Peter+Lynch+%26+Warren+Buffett&id=94"> <div style='word-break: none; width: 280px'>Peter Lynch & Warren Buffett <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>9 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Peter+Lynch+Growth+w+Lower+Valuation&id=95"> <div style='word-break: none; width: 280px'>Peter Lynch Growth w Lower Valuation <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>3 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Peter+Lynch+S%26L+Traded+Below+Book&id=96"> <div style='word-break: none; width: 280px'>Peter Lynch S&L Traded Below Book <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>1 New</div></div></a>
</li>
 <li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=PFCF+Screener&id=97"> <div style='word-break: none; width: 280px'>PFCF Screener <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>20 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Piotroski+Score+Screener&id=98"> <div style='word-break: none; width: 280px'>Piotroski Score Screener <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>7 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Predictable+Companies&id=99"> <div style='word-break: none; width: 280px'>Predictable Companies <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>5 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Profitable+predictable+margin+expanders&id=100"> <div style='word-break: none; width: 280px'>Profitable predictable margin expanders <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>3 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Stocks+Sold+w+less+Cash&id=102"> <div style='word-break: none; width: 280px'>Stocks Sold w less Cash</div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Good+Companies&id=103"> <div style='word-break: none; width: 280px'>Good Companies <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>1 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=The+Stalwarts&id=104"> <div style='word-break: none; width: 280px'>The Stalwarts <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>1 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Walter+Schloss%27s+Screen&id=105"> <div style='word-break: none; width: 280px'>Walter Schloss's Screen <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>1 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener?name=Full+Stock+List&id=42619"> <div style='word-break: none; width: 280px'>Full Stock List</div></a>
</li>
</ul>
</div>
<div class="col_1" style="width: 200px">
<h3>
<a class="sub-menu-header" href="/screener">My Screeners</a> </h3>
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener"> Create My Screener</a>
</li>
</ul>
</div>
<div class="col_1" style="width: 230px">
<h3>
<a class="sub-menu-header" href="/screener/buffett-munger">Value Screens <img src="https://www.gurufocus.com/images/P_12.jpg" alt="Premium"></a> </h3>
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/"> <b>All-In-One Screener</b></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/buffett-munger" class="menu_highlight"> <div style='word-break: none; width: 220px'>Buffett-Munger Screener <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>1 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/industry_overview.php"> Industry Overview</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/model_portfolio.php?mp=smallcap"> Undervalued Predictable</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/grahamncav"> <div style='word-break: none; width: 220px'>Ben Graham Net-Net <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>1 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/52weeklow"> <div style='word-break: none; width: 220px'>52-Week/3Y/5Y Lows <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>5 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/52weekhigh"> <div style='word-break: none; width: 220px'>52-Week/3Y/5Y Highs <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>19 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/magic-formula"> <div style='word-break: none; width: 220px'>Magic Formula (Greenblatt) <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>11 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
 <a href="/screener/dividend-stocks"> <div style='word-break: none; width: 220px'>Dividend Stocks <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>6 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/peter-lynch-stocks"> <div style='word-break: none; width: 220px'>Peter Lynch Screen <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>1 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/guru-sp-grid"> <div style='word-break: none; width: 220px'>S&P 500 Grid <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>19 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/predictable"> <div style='word-break: none; width: 220px'>Predictable Companies <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>6 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/spinoff"> Spin Off List</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/lowpb"> <div style='word-break: none; width: 220px'>Historical Low P/B List <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>6 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/lowps"> <div style='word-break: none; width: 220px'>Historical Low P/S List <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>2 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/short-stocks"> <div style='word-break: none; width: 220px'>High Short Interest <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>9 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/screener/upcoming-special-dividends"> <div style='word-break: none; width: 220px'>Upcoming Special Dividends <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>19 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<h3>
<a href="/model_portfolio.php"> Model Portfolios</a>
</h3>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/model_portfolio.php"> Performances</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/model_portfolio.php?mp=midcap"> Buffett-Munger</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/model_portfolio.php?mp=cap40"> Low P/S</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/model_portfolio.php?mp=lowpb"> Low P/B</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/model_portfolio.php?mp=cap20"> 52w Low Predictable</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/model_portfolio.php?mp=largecap"> Broadest Owned</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/model_portfolio.php?mp=hr_largecap"> Most Weighted</a>
</li>
</ul>
</div>
<div class="col_1">
<h3>
<a class="sub-menu-header" href="/fair_value_dcf.php">Tools</a> </h3>
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/download_financials_batch.php"> Download Financial Data</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/excel_Add_in.php"> <img src="https://static.gurufocus.com/images/icons/gray/jpg/XLS_16x16.jpg" alt="Excel Add-In"> Excel Add-In GURUF</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/api.php"> <img src="https://static.gurufocus.com/images/premium/P-Plus_12.jpg" alt="Premium Plus"> API</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/download_stockmanual.php"> Manual of Stocks&trade;</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/filingwiz"> FilingWiz</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="https://static.gurufocus.com/download/FilingWiz_User_Manual_202003.pdf"> FilingWiz User Manual</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/dcf/AAPL"> DCF/Reverse DCF Calculator</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/gurutrac/down_to_excel.php"> Download Guru Portfolios</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/InsiderBuy.php?position=excel"> Download Insider Data</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/app.php"> Mobile App</a>
</li>
</ul>
</div>
</div>
</li>
<li class="drop ">
<a href="/guru/latest-picks" class=''>Gurus</a>
<div class="dropdown_2columns ">
<div class="col_1">
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/latest-picks"> Latest Guru Picks</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/list"> List of Gurus (Personalize)</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/realtime-picks"> Real Time Picks</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/top-holdings"> Top 10 Holdings View</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/bargains"> Guru Bargains</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
 <a href="/guru/hot-picks"> Hot Picks</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/aggregated-portfolio"> Aggregated Portfolio</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/consensus-picks"> Consensus Picks</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/etfs"> ETFs</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/scoreboard"> Scoreboard</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/sector-picks"> Sector Picks</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/international-picks"> International Picks</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/industry-trends"> Industry Trends</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/geographic-trends"> Geographic Trend</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/option-holdings"> Options</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/european-shortings"> European Shorting</a>
</li>
</ul>
</div>
<div class="col_1">
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/warren+buffett/stock-picks"> Warren Buffett</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
 <a href="/guru/bill+gates/stock-picks"> Bill Gates</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/mohnish+pabrai/stock-picks"> Mohnish Pabrai</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/carl+icahn/stock-picks"> <div style='word-break: none;'>Carl Icahn <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>2 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/george+soros/stock-picks"> <div style='word-break: none;'>George Soros <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>38 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/david+tepper/stock-picks"> <div style='word-break: none;'>David Tepper <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>16 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/seth+klarman/stock-picks"> <div style='word-break: none;'>Seth Klarman <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>13 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/bill+ackman/stock-picks"> Bill Ackman</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/joel+greenblatt/stock-picks"> <div style='word-break: none;'>Joel Greenblatt <div style='display: inline-block; background: rgba(103, 194, 58, 0.1) !important; color: rgb(103, 194, 58) !important; font-weight: 700; padding: 1px 5px;'>129 New</div></div></a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/guru/charlie+munger/stock-picks"> Charlie Munger</a>
</li>
</ul>
</div>
</div>
</li>
<li class="drop ">
<a href="/insider/summary" class=''>Insiders</a>
<div class="dropdown_1column ">
<div class="col_1">
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/insider/summary"> All Insiders</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
 <a href="/insider/ceo"> CEO Buys/Sales</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/insider/trend"> Insider Trends</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/insider/cluster"> Insider Cluster</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/insider/cfo"> CFO Buys/Sales</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/insider/double"> Guru+Insider Double Buys</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/insider/triple"> Triple Buys/Sales</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/insider/canadian"> Canadian Insider</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/insider/dutch"> Dutch Insider</a>
</li>
</ul>
</div>
</div>
</li>
<li class="drop ">
<a href="/stock-market-valuations.php" class=''>Market</a>
<div class="dropdown_3columns " style='width: 570px'>
<div class="col_1">
<h3>
<a class="sub-menu-header" href="/stock-market-valuations.php">Market Valuation</a> </h3>
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/stock-market-valuations.php"> Buffett Indicator</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/industry_overview.php"> Industry Overview</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/yield_curve.php"> U.S. Treasury Yield Curve</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
 <a href="/shiller-PE.php"> Shiller P/E</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/global-market-valuation.php"> Global Market Valuation</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/economic_indicators/58/sp-500-earnings"> Economic Data</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/sector_shiller_pe.php"> Shiller P/E By Sectors</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/buffett_assets_allocations.php"> Buffett Assets Allocation</a>
</li>
</ul>
</div>
<div class="col_1" style="width: 220px">
<h3>
<a class="sub-menu-header" href="/economic_indicators/58/sp-500-earnings">Economic Indicators</a> </h3>
<ul class="simple">
<li style="line-height: 15px !important;
                                                                                                            width: 220px;
                                                    ">
<a href="/economic_indicators/229/the-dow-jones-industrial-average-djia"> The Dow Jones Industrial Average (DJIA)</a>
</li>
<li style="line-height: 15px !important;
                                                                                                            width: 220px;
                                                    ">
<a href="/economic_indicators/63/sp-500-index"> SP 500 Index</a>
</li>
<li style="line-height: 15px !important;
                                                                                                            width: 220px;
                                                    ">
<a href="/economic_indicators/232/nasdaq-composite-index"> Nasdaq Composite Index</a>
</li>
<li style="line-height: 15px !important;
                                                                                                            width: 220px;
                                                    ">
<a href="/economic_indicators/20/gross-domestic-product-gdp"> Gross Domestic Product (GDP)</a>
</li>
<li style="line-height: 15px !important;
                                                                                                            width: 220px;
                                                    ">
<a href="/economic_indicators/56/shiller-pe"> Shiller PE</a>
</li>
<li style="line-height: 15px !important;
                                                                                                            width: 220px;
                                                    ">
 <a href="/economic_indicators/60/ratio-of-wilshire-5000-over-gnp"> Ratio of Wilshire 5000 over GNP</a>
</li>
<li style="line-height: 15px !important;
                                                                                                            width: 220px;
                                                    ">
<a href="/economic_indicators/10/civilian-unemployment-rate"> Civilian Unemployment Rate</a>
</li>
<li style="line-height: 15px !important;
                                                                                                            width: 220px;
                                                    ">
<a href="/economic_indicators/231/russell-2000-small-cap-price-index"> Russell 2000 Small Cap Price Index</a>
</li>
<li style="line-height: 15px !important;
                                                                                                            width: 220px;
                                                    ">
<a href="/economic_indicators/234/cboe-volatility-index-the-vix"> CBOE Volatility Index (VIX)</a>
</li>
<li style="line-height: 15px !important;
                                                                                                            width: 220px;
                                                    ">
<a href="/economic_indicators/14/total-nonfarm-payrolls-all-employees"> Total Nonfarm Payrolls: All Employees</a>
</li>
<li style="line-height: 15px !important;
                                                                                                            width: 220px;
                                                    ">
<a href="/economic_indicators/58/sp-500-earnings"> More...</a>
</li>
</ul>
</div>
<div class="col_1">
<h3>
<a class="sub-menu-header" href="/global-market-valuation.php">By Country</a> </h3>
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/stock-market-valuations.php"> USA</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/global-market-valuation.php?country=IND"> India</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/global-market-valuation.php?country=CHN"> China</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/global-market-valuation.php"> More...</a>
</li>
</ul>
</div>
</div>
</li>
<li class="drop  menu_select">
<a href="/news.php?cat=column" class='' style='color: #161616;'>Articles</a>
 <div class="dropdown_2columns ">
<div class="col_1">
<h3>
<a class="sub-menu-header" href="/news.php?cat=column">Articles</a> </h3>
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/news.php?cat=timeless"> Editor's Picks</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/news.php?cat=rank"> Top Ranked</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/news.php?cat=value"> Value Ideas</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/news.php?cat=contest"> Value Idea Contest</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/news.php?cat=20"> GuruFocus Research</a>
</li>
</ul>
</div>
<div class="col_1">
<h3>
<a class="sub-menu-header" href="/forum/post.php?4">Submit Articles</a> </h3>
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/ic/space.php?do=article&view=me"> My Articles</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/forum/post.php?4" class="menu_highlight"> Submit Articles Online</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/news/70028"> Writers Wanted</a>
</li>
</ul>
</div>
</div>
</li>
<li class="drop menu_right">
<a href="/tutorials.php" class=''>Tutorials</a>
<div class="dropdown_1column align_right">
<div class="col_1">
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/tutorials.php"> Tutorials & Webinars</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
 <a href="/faq.php"> FAQ</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/changelog"> Change Log</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/ticket/open.php"> Contact Us</a>
</li>
</ul>
</div>
</div>
</li>
<li class="drop menu_right">
<a href="" class=''>Support</a>
<div class="dropdown_1column align_right">
<div class="col_1">
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="#" onclick="openSupport()">Chat Support</a> <li style="line-height: 15px !important;
                                                    ">
<a href="/ticket/open.php"> Create a ticket</a>
</li>
</ul>
</div>
</div>
</li>
<li class="drop menu_right">
<a href="/forum/login.php?0" class=''>Log In</a>
<div class="dropdown_1column align_right">
<div class="col_1">
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="/forum/register.php"> Free Sign-up</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/forum/login.php?0"> Log In</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="https://www.gurufocus.com/membership/upgrade.php?ref=menu" class="menu_highlight"> 7-Day Free Trial <img src="https://www.gurufocus.com/images/P_12.jpg" alt="Premium"></a>
</li>
</ul>
</div>
</div>
</li>
<li class="drop menu_right">
<a href="https://www.gurufocus.com/membership/upgrade.php?ref=direct_signup" class=''>Subscribe</a>
<div class="dropdown_1column align_right">
<div class="col_1">
<ul class="simple">
<li style="line-height: 15px !important;
                                                    ">
<a href="https://www.gurufocus.com/membership/upgrade.php?ref=direct_signup"> Free Trial ($449/Year)</a>
</li>
<li style="line-height: 15px !important;
                                                    ">
<a href="/user_referrals.php"> Refer a Friend & Earn $50</a>
</li>
</ul>
</div>
</div>
</li>
</ul>
</div>
</div>
<div id="searchbar">
<div id="searchbarInner" style="vertical-align:middle;">
<form style="float:left;margin-top:0px;margin-bottom: 0px;" action="/menu_search.php" id="searchform">
<div class="search">
<div class="left" id="search_type_box">
<select id="search_type_header">
<option value="Search">Search</option>
<option value="Compare">Compare</option>
</select>
<label id="search_type_label">Search ▾</label>
</div>
<input type="text" id="search_header" onfocus="if (this.value == 'Enter Ticker, Guru, Company, etc.') {
                                this.value = '';
                            }" onblur="if (this.value == '') {
                                        this.value = 'Enter Ticker, Guru, Company, etc.'
                                    }" value="Enter Ticker, Guru, Company, etc." onKeyPress="return checkSubmit(event)" class="box" name="keyword" />
<input type="text" id="compare_header" onfocus="if (this.value == 'Enter Symbols (e.g. WMT, TGT, COST)') {
                                this.value = '';
                            }" onblur="if (this.value == '') {
                                        this.value = 'Enter Symbols (e.g. WMT, TGT, COST)'
                                    }" value="Enter Symbols (e.g. WMT, TGT, COST)" class="box" name="compare" style="display: none;" />
<input type="hidden" name="symbol1" id="company_hidden" />
<input type="hidden" name="stype" id="stype_hidden" value="search" />
<input type="hidden" name="searchKeyWords" id="searchKeyWords_hidden" />
<input id="search_submit" type="submit" value="Go" class="btn" style="margin-left: -1px;height:24px;" />
</div>
</form>
<div style="margin-top:-5px;" id="my_nav" class="right ">
<div class="control_links right" style="margin-left: 10px;">
<a href="https://www.gurufocus.com/membership/new/index.html#/?ref=stock-name-summary&sel=premium&utm_source=webApp&utm_medium=userClick&utm_campaign=old_website_topMenuButton" class="bs_btn bs_btn-warning" id="topMenuSubButton" style="color:white;font-size: 14px;">Get 7-Day Free Trial</a>
</div>
<ul>
<li class="control_links">
<a href="/ic/space.php?do=portfolio&view=me"><img src="https://static.gurufocus.com/images/icons/gray/png/notepad_icon&16.png" alt="My Portfolio" />My Portfolios</a>▾
<ul class="my_nav_sub">
<li class="control_links"><a href="/ic/space.php?do=portfolio&view=me"><img src="https://static.gurufocus.com/images/icons/gray/png/notepad_icon&16.png" alt="My Portfolio" />Portfolios Overview</a></li>
<li class="control_links"><a href="/ic/space.php?do=portfolio&create=new"><img src="https://static.gurufocus.com/images/icons/gray/png/sq_plus_icon&16.png" alt="Create New Portfolio" />Create New Portfolio</a></li>
<li class="control_links"><a href="/portfolio_contest.php"><img src="https://www.gurufocus.com/ic/image/icon/5.gif" alt="Portfolio Contest" />Portfolio Contest</a></li>
</ul>
</li>
<li class="control_links"><a id="btn_header_selectguru" href="javascript:;" onclick="h_guru_browse()"><img src="https://static.gurufocus.com/images/icons/gray/png/user_icon&16.png" alt="Gurus" />My Gurus</a>▾
<ul class="my_nav_sub">
<li class="control_links"><a href="javascript:;" onclick="h_guru_browse()"><img src="https://static.gurufocus.com/images/icons/gray/png/user_icon&16.png" alt="Gurus" />Quick Browse</a></li>
<li class="control_links"><a href="/membership/upgrade.php?ref=myguru" title="Personalize My Guru List"><img src="https://static.gurufocus.com/images/icons/gray/png/cog_icon&amp;16.png" alt="Personalize">Personalize</a></li>
<hr>
<li class="control_links"><a href="/ListGuru.php"><img src="https://static.gurufocus.com/images/icons/gray/png/folder_icon&16.png" alt="Gurus" />My Gurus</a></li>
<hr>
<li class="control_links"><a href="/ListGuru.php?group=all"><img src="https://static.gurufocus.com/images/icons/gray/png/folder_icon&16.png" alt="Gurus" />Premium Gurus <img src="https://static.gurufocus.com/images/P_12.jpg" alt="Premium Gurus"></a></li>
<li class="control_links"><a href="/ListGuru.php?group=plus"><img src="https://static.gurufocus.com/images/icons/gray/png/folder_icon&16.png" alt="Gurus" />Premium Plus Investors <img src="https://static.gurufocus.com/images/premium/P-Plus_12.jpg" alt="Premium Plus Investors"></a></li>
</ul>
</li>
</ul>
</div>
<div id="header_popup_dialog" class="dialog_div" style="display: none;">
<div id="header_popup_content" style="font-size: 12px;">
<div style="text-align: center; margin-top: 50px;">
<img src="https://static.gurufocus.com/images/horizontal_loading.gif" alt="Loading...">
</div>
</div>
</div>
</div>
</div>
</div>
<div>

<script>
  function resizeIframe(obj) {

    obj.style.height = obj.contentWindow.document.body.scrollHeight + 'px';
    console.log(obj.style.height);
  }
</script>
<script>
jQuery( "#m_menu_accordion" ).accordion({
  active: 999,
  collapsible: true,
  heightStyle: "content",
  activate: function( event, ui ) {
      if(jQuery(body).scrollTop()>jQuery(ui.newHeader).offset().top){
        jQuery(body).scrollTop(jQuery(ui.newHeader).offset().top);
    }
  }
});
jQuery("#m_menu_link, #m_close_menu").click(function(){
    jQuery( "#m_menu_accordion" ).slideToggle();
});

$("#nav_button, #navigator").click(function() {
        $("#navigator").is(":visible")?$("#navigator").hide():$("#navigator").show();
});

</script>
<style type="text/css">
    .sub-menu-header {
        font-size: 14px !important;
        font-weight: bold !important;
    }
</style>>
<script>
    let support = null 
    function openSupport() {
        let init = 0
        if (!support) {
            const sh = document.createElement('script')
            sh['type'] = 'text/javascript'
            sh['async'] = true
            sh['data-cfasync'] = false
            sh['src'] = 'https://www.gurufocus.com/phplive/js/phplive_v2.js.php?v=0%7C1570480208%7C0%7C&r=' + encodeURIComponent(window.location.href)

            const head = document.getElementsByTagName('head')[0]
            if (head) {
                head.appendChild(sh)
            }

            support = sh

            if (0&& window) {
                window.phplive_v = {
                    name: '',
                    id: '' ,
                    status: 0 ,
                    email: ''
                }
            }
            init = 1
        }   
        if (init === 1) {
            setTimeout(() => {
                lauchChat()
            }, 500)
        } else {
            lauchChat()
        }
    }
    function lauchChat () {
        if (window && window.phplive_launch_chat_0) {
            window.phplive_launch_chat_0()
        }
    }
</script><div class="newcontent" style="background-color: #EEE; ">
<div id="topnews" style="text-align:center"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-4020868656364652" data-ad-slot="6219170923"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>
<div class="newcontent" id="newcontent">
<div id='author_area'><div style="width:400px;border: 0;margin-top:2px;margin-left:10px;margin-bottom:0px;padding:4px; float:right"><ol>
<li> <a target="_blank" href="/tutorials.php">How to use GuruFocus - Tutorials</a></li>
<li> <a href="/membership.php">What Is in the GuruFocus Premium Membership?</a></li>
<li style="margin-left:0px;"><a href="/Invest_guide_guru.php">A DIY Guide on How to Invest Using Guru Strategies</a>
</li>
</ol></div> <a class="author_avatar" href="/ic/space.php?do=article&uid=234994&author=Marketwired"><img src="https://avatar.gurufocus.com/234994_big.png" class="author_avatar_img stock_avatar" alt="Marketwired"></a><div style="float:left;margin-left:20px;position:relative;"><div><a class="author_name" href="/ic/space.php?do=article&uid=234994&author=Marketwired">Marketwired</a></div><div style="margin-top:10px;height:31px;"><a href="/ic/space.php?do=article&uid=234994&author=Marketwired">Articles</a>&nbsp;</div><div style="margin-top:0px;height:31px;margin-top:6px;"><div class="social_network_button control_links" style="position: relative; top: -5px;">
<a href="#" onclick="javascript:;" id="fake_link_add_bookmark"><img alt="Bookmark" src="https://static.gurufocus.com/images/icons/gray/png/bookmark_2_icon&16.png">Bookmark</a></div>
<div class="social_network_button control_links" style="position: relative; top: -5px;">
<a href="#" id="print_article"><img alt="Print" src="https://static.gurufocus.com/images/icons/gray/png/print_icon&16.png">Print</a>
</div>
<div class="social_network_button" style="width: 80px;">
<a href="https://twitter.com/share" class="twitter-share-button">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</div>
<div class="social_network_button" style="position: relative; width: 80px;">
<div class="fb-like" data-send="false" data-layout="button_count" data-width="30" data-show-faces="true"></div>
</div>
<div class="social_network_button" style="position: relative;">
<script type="IN/Share" data-counter="right"></script>
</div>
<div class="social_network_button" style="width: 65px;">
<div class="g-plusone" data-size="medium"></div>
</div>
<div class="hidden">
<div id="dialog-bookmark" title="Add Bookmark">
<form id="form-bookmark" action="/modules/uch/bookmark.php?act=add" method="post">
<ul>
<li><label for="sn_bm_title">Bookmark Name:</label>
<input type="text" id="sn_bm_title" name="title" class="text ui-widget-content ui-corner-all" size="40" /></li>
<li style="display: none;">
<input type="text" id="sn_bm_url" name="url" class="text ui-widget-content ui-corner-all" size="40" /></li>
</ul>
</form>
</div>
<div id="dialog-message1" title="Bookmark">
<p>
<img src="https://static.gurufocus.com/images/icons/gray/png/checkmark_icon&16.png">
This page was added to your <a href="/ic/space.php?do=bookmark">Bookmark</a>.
</p>
</div>
<div id="dialog-message2" title="Members Only">
<div class="warning">
<p>Members Only. Please <a href="/forum/register.php?0">Sign Up</a> or <a href="/forum/login.php?0">Log In</a> first.</p>
</div>
</div>
<div id="dialog-message3" title="Bookmark">
<p>
Bookmark of this page has been deleted.
</p>
</div>
</div>
<script src="https://cdnjs.cloudflare.com/ajax/libs/printThis/1.12.2/printThis.min.js"></script>
<script>
$(function(){

    $( "#dialog-message1, #dialog-message2, #dialog-message3" ).dialog({
            modal: true,
            autoOpen: false,
            width: 420,
            height: 180,
            buttons: {
                    Ok: function() {
                            $( this ).dialog( "close" );
                    }
            }
    });


    $( "#dialog-bookmark" ).dialog({
            autoOpen: false,
            height: 160,
            width: 420,
            resizable: false,
            modal: true,
            buttons: {
                    "Save Bookmark": function() {
                            $("#form-bookmark").ajaxSubmit({
                                    success: function(){
                                            $( "#dialog-bookmark" ).dialog( "close" );
                                            $( "#dialog-message1" ).dialog( "open" );
                                            $('#bookmark_done').show();
                                            $('#link_add_bookmark').hide();
                                    }
                            });
                    }
            }
    });

    $("#link_add_bookmark").click(function(){
            $('#dialog-bookmark').dialog('open');
            $('#sn_bm_title').val(document.title);
            $('#sn_bm_url').val(location.href);

            return false;
    });


    $('#fake_link_add_bookmark').click(function(){
            $( "#dialog-message2" ).dialog( "open" );
            return false;
    });
    $('#bookmark_done').click(function(){
            delete_bookmark();
            return false;
    });

    $("#print_article").click(function(){
	$('.newcontent').printThis();
    });

});

function add_bookmark(){
	var title = document.title;
	var url = location.href.replace('#/g', '');

	$.post('/modules/uch/bookmark.php?act=add', {'title':title,'url':url}, function(){
		$( "#dialog-message1" ).dialog( "open" );
		$('#bookmark_done').show();
		$('#link_add_bookmark').hide();
	});
}
function delete_bookmark(){
	var url = location.href.replace('#/g', '');

	$.post('/modules/uch/bookmark.php?act=delete', {'url':url}, function(){
		$( "#dialog-message3" ).dialog( "open" );
		$('#bookmark_done').hide();
		$('#link_add_bookmark').show();
	});
}

</script>
</div></div></div><h1 style="clear:both;">Fortinet Expands Engage Partner Program Benefits to Further Enable Channel Business Growth </h1><div class="news_article left" id="content1" style="width: 630px;"><div id="article"><div class="header_new"><div class="header_inner_new"><span class="date">March 10, 2021</span> | <span class="date"> About: </span>
<a class='post-tag stocks_tp' target="_blank" href="/stock/FTNT">FTNT <span class='tkg'> +1.63%</span></a></div><div class="control_links hide_for_print">
</div></div>
<div id="container_new" style="margin-top:10px;">
<div id="articlebody_new"><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><h2>
Engage 2.0 Partner Program Introduces New Consumption Models, Specializations and Updates for Cloud Partners to Help Create More Profitability Pathways
</h2>
<div class="mw_release"><p align="left">SUNNYVALE, Calif., March 10, 2021 (GLOBE NEWSWIRE) -- </p> <p><strong>John Maddison, EVP of Products and CMO at Fortinet</strong><br>&ldquo;Fortinet has been successful in enabling our channel partners to grow their business and services leveraging the Fortinet Security Fabric. Our partnerships go beyond the technologies that enable service offerings that drive growth and profitability. We&rsquo;ve received outstanding feedback about the partner program to date and want to continue enhancing it to meet customers&rsquo; evolving needs as well as digital innovations. Today we are announcing updates that will help our partners to further reap benefits from the Engage Partner Program and to set themselves apart with customers.&rdquo;</p> <p class="center" style="display: block !important"><img src="https://s3.amazonaws.com/gurufocus_avatar/234994_big.png" class="newsimg" /></p><p><strong>News Summary </strong><br><a href="https://www.globenewswire.com/Tracker?data=lmz_Q9mby7Bnor7XMz3L_EyZxUlEYkDoDJK-tMZ3CqPeArbd8wQNbtZc0sCORRYaQpkcnr3AKABe9vCc-mS6heqKQzxgUh9kPYRsaQEhvKbnoCFRxU9ZKsFn9BsDeZFVmYZhiWa3hqFiNzVrYX_F_g==" rel="nofollow" target="_blank">Fortinet</a>&reg; ( FTNT), a global leader in broad, integrated and automated cybersecurity solutions, today announced updates to the <a href="https://www.globenewswire.com/Tracker?data=lmz_Q9mby7Bnor7XMz3L_I2ITisYMjIfildyt69mIR958-Dd2ubUxpmiLkAoczF9NPpYJ8PirTVuVytDX98tVOZl_ZhLRlPz8woMAiJFYZJsGSDQTfz-z3W20SACmbSBMx_aGFuD3XbJEIG4Pph5Q0KuZnxAW5P6MRx2tYRJn3xYzD3nIcBugbPoH_fMZifLSjmfmS5iUVWBEv5-4kVMj3su8Smo9mcHsGNY1tB8iYBlc1hzmmWD8XMFUkrvesu9" rel="nofollow" target="_blank">Fortinet Engage Partner Program</a>, enabling additional flexibility and revenue growth for partners. Fortinet is adding new consumption models for a range of products including FortiSIEM and FortiEDR, enhancing benefits for cloud partners and introducing new Specializations focused on growing markets.</p> <ul style="width:50%;float:left;margin-right:20px;">
<li><a href="http://www.gurufocus.com/financials/FTNT" target="_blank">FTNT 30-Year Financial Data</a></li><li><a href="/analysis/FTNT&subtab=val" target="_blank">The intrinsic value of FTNT</a></li><li><a href="http://www.gurufocus.com/chart/FTNT#&serie=,,id:price,s:FTNT,,id:custompe,s:FTNT&log=0&per=0" target="_blank">Peter Lynch Chart of FTNT</a></li></ul><p><strong>Engage 2.0 Partner Program</strong> <strong>Expands Benefits</strong><br>With hybrid workforces, highly distributed network infrastructures and new digital innovations, organizations find that securing all their environments is becoming increasingly complex if they don&rsquo;t have the right technology and trusted advisors to lean on. To further enable channel partners to address these customer needs, the Engage 2.0 Partner Program will now include:</p> <ul type="disc"><li><strong>New Consumption Models</strong>: Fortinet is continuing to enable MSSP and SP partners to build services and grow their business leveraging the Fortinet Security Fabric with new consumption models for <a href="https://www.fortinet.com/products/siem/fortisiem.html?utm_source=pr&amp;utm_campaign=2019-q3-fortisiem" rel="nofollow" target="_blank">FortiSIEM</a>, <a href="https://www.fortinet.com/products/endpoint-security/fortiedr.html?utm_source=pr&amp;utm_campaign=2020-q1-fortiedr" rel="nofollow" target="_blank">FortiEDR</a>, <a href="https://www.fortinet.com/products/endpoint-security/forticlient.html?utm_source=pr&amp;utm_campaign=2019-q3-forticlient" rel="nofollow" target="_blank">FortiClient</a>, <a href="https://www.fortinet.com/products/fortisoar.html?utm_source=pr&amp;utm_campaign=2020-q1-fortisoar" rel="nofollow" target="_blank">FortiSOAR</a>, <a href="https://www.fortinet.com/products/fortiai?utm_source=pr&amp;utm_campaign=2020-q4-products-fortiai" rel="nofollow" target="_blank">FortiAI</a> and <a href="https://www.fortinet.com/products/fortideceptor.html?utm_source=blog&amp;utm_campaign=2019-q4-deception" rel="nofollow" target="_blank">FortiDeceptor</a>. According to <a href="https://blogs.gartner.com/pete-shoard/the-managed-security-services-landscape-is-changing/" rel="nofollow" target="_blank">Gartner</a>, by 2024, more than 90% of buyers looking to outsource to security services providers will focus on threat detection and response services. Fortinet has seen an uptake of our consumption offerings, which continues to grow significantly as partners take advantage of tapping into this market demand for threat detection security outcomes. With more and more customers looking for flexible consumption models, the introduction of new ways to consume Fortinet&rsquo;s end point solutions enable MSSPs and SPs to offer their customers new security services that can be quickly deployed and at lower costs.<br><br></li><li><strong>Enhanced Cloud Partner Benefits: </strong>The Engage Partner Program allows partners to engage as an integrator, MSSP or cloud partner. For cloud partners, Fortinet is adding additional ways they can take advantage of the various routes to market leveraging Fortinet&rsquo;s <a href="https://www.fortinet.com/solutions/enterprise-midsize-business/cloud-security.html?utm_source=pr&amp;utm_campaign=2019-q3-cloud-security" rel="nofollow" target="_blank">Adaptive Cloud Security</a> offerings. Managed cloud service provider partners are now immediately eligible for the Engage Select Cloud Business Model. Participants in this business model are eligible for additional discounts on Fortinet&rsquo;s flexible licensing models, including BYOL and pay-as-you-go, and gain access to <a href="https://www.fortinet.com/products/public-cloud-security/cloud-security-posture-management.html?utm_source=pr&amp;utm_campaign=2019-q3-forticwp" rel="nofollow" target="_blank">FortiCWP</a> and FNDN. These new benefits result in cost savings as partners expand their cloud security services powered by Fortinet. <br><br></li><li><strong>Additional Specializations</strong>: Fortinet is introducing new <a href="https://www.fortinet.com/partners/partner-program/become-a-fortinet-partner?utm_source=pr&amp;utm_campaign=2021-q1-become-a-fortinet-partner" rel="nofollow" target="_blank">Specializations</a> focused on high growth areas with additions including: Zero Trust Access, Operational Technology and Security Operations. Specializations help partners further distinguish their expertise among current and potential customers as trusted partners who have the knowledge, services and technologies to fulfill customer business needs. Fortinet&rsquo;s existing Specializations have included Secure SD-WAN, Data Center, Adaptive Cloud Security, and LAN Edge and SD-Branch.<br><br></li><li><strong>Updated NSE Courses to Meet Compliance Requirements</strong>: Fortinet&rsquo;s <a href="https://training.fortinet.com/?utm_source=pr&amp;utm_campaign=2019-q3-nse-institute" rel="nofollow" target="_blank">NSE training courses</a> and eight-level <a href="https://training.fortinet.com/local/staticpage/view.php?page=certifications&amp;utm_source=pr&amp;utm_campaign=2020-q2-nse" rel="nofollow" target="_blank">Certification Program</a>, which are free to all Fortinet partners, have been updated allowing partners to meet more compliance requirements. <br></li></ul> <p><strong>Becoming a Fortinet Partner</strong><br>The Fortinet Engage 2.0 Partner Program allows partners to develop the expertise needed to deliver on the promise of digital transformation through a customizable program with market-leading profitability and the programs and infrastructure in place to accelerate their growth. Partners also are provided flexibility to engage on three business levels: Integrator, MSSP or Cloud providing multiple opportunities to grow different segments of their business, as well as multiple ways to differentiate their offerings with Specializations. For more information on how to join the Fortinet Engage Partner Program, <a href="https://www.globenewswire.com/Tracker?data=qQTPqPHBuw87cpk5x_rCmYi6rROGiP_xWXLFkuJLe48bGmaIU4YtHYMEzIIrUYO-ap9P7az0n3HPvx7xi9X0kLDoKWGgoDfLDIG6u3sFAT7pl8g4W4MAu7qJ2P6sRq_BBLf_-RQPdKuzFuCCnUC7Og==" rel="nofollow" target="_blank">visit here</a>.</p> <p><strong>Supporting Quotes</strong></p> <p>&ldquo;Our partnership with Fortinet has always been strong. Our great depth of technical expertise combined with the strength of Fortinet&rsquo;s technology portfolio, specifically in Secure SD-WAN, means we have been able to help our customers deliver against their digital transformation strategies while tackling a constantly evolving cybersecurity landscape. In 2020, our commitment to the Fortinet Engage Partner Program, and in particular Fortinet&rsquo;s training certification, contributed massively to our substantial sales growth which reached 225% and subsequently saw us promoted to Expert partner status.&rdquo;<br><em>-</em> <em>Paul Toms, Sales Director at 365IT Koris</em></p> <p>&ldquo;The nature of cyber security challenges over the past year have been something that we as a collective have never experienced before. The global COVID pandemic brought with it significant increases in the volume, speed and diversity of cyber-attacks. The opportunities for digital transformation and transition to the cloud have been thrust into the spotlight as a result, driving organizations to adapt quickly to new ways of operating. Fortinet's Engage Partner Program has enabled us to take full advantage of expert support and innovative solutions such as Secure SD-WAN and the FortiNAC zero trust access solution, allowing us to respond to changing customers&rsquo; needs and to expand our business.&rdquo;<br><em>- Mark Oakton, Director &amp; Consulting CISO at Infosec Partners</em></p> <p>&ldquo;As a newer Fortinet partner, the Engage Partner Program enables us to further develop the pco portfolio. We are constantly adding new solutions, getting Specializations and expanding our MSSP program to be well positioned for the future.&rdquo;<br>- <em>Julius H&ouml;ltje, Sales Specialist Information Security at pco GmbH &amp; Co. KG</em></p> <p><strong>Additional Resources</strong></p> <ul type="disc"><li>Learn more about the Engage Partner Program updates in <a href="https://www.fortinet.com/blog/partners/engage-2-0-partner-program-brings-more-benefits-to-channel" rel="nofollow" target="_blank">this blog</a>.</li><li>Find out how the <a href="https://www.fortinet.com/solutions/enterprise-midsize-business/security-fabric.html?utm_source=pr&amp;utm_campaign=2019-q3-security-fabric" rel="nofollow" target="_blank">Fortinet Security Fabric</a> platform delivers broad, integrated, and automated protection across an organization&rsquo;s entire digital infrastructure.</li><li>Learn more about <a href="https://www.fortinet.com/fortiguard/labs?utm_source=pr&amp;utm_campaign=FortiGuardLabs" rel="nofollow" target="_blank">FortiGuard Labs</a> threat intelligence and research and the <a href="https://www.fortinet.com/support-and-training/support-services/fortiguard-security-subscriptions.html?utm_source=pr&amp;utm_campaign=2019-q3-security-services" rel="nofollow" target="_blank">FortiGuard Security Subscriptions and Services</a> portfolio.</li><li>Learn more about Fortinet&rsquo;s <a href="https://training.fortinet.com/?utm_source=pr&amp;utm_campaign=2019-q3-nse-institute" rel="nofollow" target="_blank">Network Security Expert (NSE) Training Institute</a>, including its <a href="https://www.fortinet.com/blog/business-and-technology/why-cybersecurity-training-is-more-important-than-ever.html" rel="nofollow" target="_blank">free cybersecurity training initiative</a>, the <a href="https://training.fortinet.com/local/staticpage/view.php?page=certifications&amp;utm_source=pr&amp;utm_campaign=2020-q2-nse" rel="nofollow" target="_blank">NSE Certification Program</a>, <a href="https://training.fortinet.com/local/staticpage/view.php?page=fnsa&amp;utm_source=pr&amp;utm_campaign=2019-q3-fnsa" rel="nofollow" target="_blank">Security Academy Program</a> and <a href="https://www.fortinet.com/corporate/careers/vets.html?utm_source=pr&amp;utm_campaign=2019-q3-fortivet" rel="nofollow" target="_blank">Veterans Program</a>.</li><li>Read more about how <a href="https://www.fortinet.com/customers.html?utm_source=pr&amp;utm_campaign=2019-q3-telecommunications" rel="nofollow" target="_blank">Fortinet customers</a> are securing their organizations.</li><li>Engage in the <a href="https://fusecommunity.fortinet.com/home?utm_source=pr&amp;utm_campaign=2020-q3-fuse-community" rel="nofollow" target="_blank">Fortinet User Community (Fuse)</a>. Share ideas and feedback, learn more about our products and technology, and connect with peers.</li><li>Follow Fortinet on <a href="https://twitter.com/Fortinet" rel="nofollow" target="_blank"><u>Twitter</u></a>, <a href="https://www.linkedin.com/company/fortinet" rel="nofollow" target="_blank"><u>LinkedIn</u></a>, <a href="https://www.facebook.com/fortinet/" rel="nofollow" target="_blank"><u>Facebook</u></a>, <a href="https://www.youtube.com/fortinet" rel="nofollow" target="_blank"><u>YouTube</u></a>, and <a href="https://www.instagram.com/behindthefirewall/" rel="nofollow" target="_blank">Instagram</a>. <br></li></ul> <p><strong>About Fortinet</strong><br>Fortinet ( FTNT) secures the largest enterprise, service provider, and government organizations around the world. Fortinet empowers our customers with complete visibility and control across the expanding attack surface and the power to take on ever-increasing performance requirements today and into the future. Only the Fortinet Security Fabric platform can address the most critical security challenges and protect data across the entire digital infrastructure, whether in networked, application, multi-cloud or edge environments. Fortinet ranks #1 in the most security appliances shipped worldwide and more than 500,000 customers trust Fortinet to protect their businesses. Both a technology company and a learning organization, the <a href="https://www.globenewswire.com/Tracker?data=lmz_Q9mby7Bnor7XMz3L_OZGWevM2mAYxNsj_OxINKuwUSUoGUVtVZ9CkuYfWAj291PwfgBg9WnkBTc6nIfQ9-o9ebmfwLesG3ptbSWZDeUalY7IXyLocI8fY-8RU8Ndxl3UvKeawGF1SFwdXeA3fBHF8UsS8oZ2mjGRPmmXhuAeusW60WZYZiWZqdnga57m" rel="nofollow" target="_blank">Fortinet Network Security Expert (NSE)</a> Training Institute has one of the largest and broadest cybersecurity training programs in the industry. Learn more at <a href="https://www.globenewswire.com/Tracker?data=ooA2Bf0uGE0ovwMpD8Ov-hX_0W5RjgxvRT-KGNFf0vPPXKGGAvsW-udS9RkBH-L8BJ1XHvwUkjC4nFDQczOFhdeWU3pSk3URfSg6XqgY4Ag=" rel="nofollow" target="_blank"><u>http://www.fortinet.com</u></a>, the <a href="https://www.globenewswire.com/Tracker?data=lmz_Q9mby7Bnor7XMz3L_IVlDLbHCnz8TKVicNP7IQKc8_Momd8siVvQV_3AzY9cKC26-ILXpmDl_s5x46jeAA==" rel="nofollow" target="_blank">Fortinet Blog</a>, or <a href="https://www.globenewswire.com/Tracker?data=qFy2DhO0qxQmldmG83zhvpxLVkIMp-QKYor8eR0Iz5Wxj8mpU3H7PeDwx1iDJXOQzqNpIWQ2xpY5a9oN7zYweVNYHgUsGNdhUxT2TuI8svlGm0UilujnTfb6MH9fHKm7ct86qb4vnKkgwtf5Gx8feJORbZdUcEuxD7JcGRtUTFs=" rel="nofollow" target="_blank">FortiGuard Labs</a>. </p> <p><strong><em>FTNT-O</em></strong></p> <p><em>Copyright &copy; 2021 Fortinet, Inc. All rights reserved. The symbols &reg; and &trade; denote respectively federally registered trademarks and common law trademarks of Fortinet, Inc., its subsidiaries and affiliates. Fortinet&rsquo;s trademarks include, but are not limited to, the following: Fortinet, the Fortinet logo, FortiGate, FortiOS, FortiGuard, FortiCare, FortiAnalyzer, FortiManager, FortiASIC, FortiClient, FortiCloud, FortiCore, FortiMail, FortiSandbox, FortiADC, FortiAI, FortiAP, FortiAppEngine, FortiAppMonitor, FortiAuthenticator, FortiBalancer, FortiBIOS, FortiBridge, FortiCache, FortiCam, FortiCamera, FortiCarrier, FortiCASB, FortiCenter, FortiCentral,FortiConnect, FortiController, FortiConverter, FortiCWP, FortiDB, FortiDDoS, FortiDeceptor, FortiDirector, FortiDNS, FortiEDR, FortiExplorer, FortiExtender, FortiFone, FortiHypervisor, FortiInsight, FortiIsolator, FortiLocator, FortiLog, FortiMeter, FortiMoM, FortiMonitor, FortiNAC, FortiPartner, FortiPortal, FortiPresence , FortiProtect, FortiProxy, FortiRecorder, FortiReporter, FortiScan, FortiSDNConnector, FortiSIEM, FortiSDWAN, FortiSMS, FortiSOAR, FortiSwitch, FortiTester, FortiToken, FortiTrust, FortiVoice, FortiVoIP, FortiWAN, FortiWeb, FortiWiFi, FortiWLC, FortiWLCOS and FortiWLM. </em></p> <p>Other trademarks belong to their respective owners. Fortinet has not independently verified statements or certifications herein attributed to third parties and Fortinet does not independently endorse such statements. Notwithstanding anything to the contrary herein, nothing herein constitutes a warranty, guarantee, contract, binding specification or other binding commitment by Fortinet or any indication of intent related to a binding commitment, and performance and other specification information herein may be unique to certain environments. This news release may contain forward-looking statements that involve uncertainties and assumptions, such as statements regarding technology releases among others. Changes of circumstances, product release delays, or other risks as stated in our filings with the Securities and Exchange Commission, located at <a href="https://www.globenewswire.com/Tracker?data=s9vPe957jQHkntgViYhrB9AMZfWJJJ8auw1IPHD_ONKXLmSXsVRsQ_1KMnfN3aRxP5m407zTnE6pULgz_eyg4Q==" rel="nofollow" target="_blank">www.sec.gov</a>, may cause results to differ materially from those expressed or implied in this press release. If the uncertainties materialize or the assumptions prove incorrect, results may differ materially from those expressed or implied by such forward-looking statements and assumptions. All statements other than statements of historical fact are statements that could be deemed forward-looking statements. Fortinet assumes no obligation to update any forward-looking statements, and expressly disclaims any obligation to update these forward-looking statements.</p> <table><tr><td><strong>Media Contact:</strong></td><td><strong>Investor Contact:</strong></td><td><strong>Analyst Contact:</strong></td></tr><tr><td> </td><td> </td><td> </td></tr><tr><td>Stephanie Lira</td><td>Peter Salkowski</td><td>Ron Davis</td></tr><tr><td>Fortinet, Inc.</td><td>Fortinet, Inc.</td><td>Fortinet, Inc.</td></tr><tr><td>408-235-7700</td><td>408-331-4595</td><td>415-806-9892</td></tr><tr><td><a href="/cdn-cgi/l/email-protection#d6a6a496b0b9a4a2bfb8b3a2f8b5b9bb" target="_blank"><span class="__cf_email__" data-cfemail="9eeeecdef8f1eceaf7f0fbeab0fdf1f3">[email&#160;protected]</span></a></td><td><a href="/cdn-cgi/l/email-protection#04747765686f6b73776f6d44626b76706d6a61702a676b69" target="_blank"><span class="__cf_email__" data-cfemail="29595a484542465e5a4240694f465b5d40474c5d074a4644">[email&#160;protected]</span></a></td><td><a href="/cdn-cgi/l/email-protection#67150306110e1427010815130e0902134904080a" target="_blank"><span class="__cf_email__" data-cfemail="2153454057485261474e5355484f44550f424e4c">[email&#160;protected]</span></a></td></tr></table><img class="__GNW8366DE3E__IMG" src="https://www.globenewswire.com/newsroom/ti?nf=ODE4NzQ1OCM0MDU2NzY5IzIwMDY3MTU=" width="1" height="1" alt="ti?nf=ODE4NzQ1OCM0MDU2NzY5IzIwMDY3MTU="> <br><img class="__GNW8366DE3E__IMG" src="https://ml.globenewswire.com/release/track/741997fd-d655-4afe-b5ed-ee00d3335fe5" width="1" height="1" alt="741997fd-d655-4afe-b5ed-ee00d3335fe5"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script></body></html>
</div><br />
<h4></h4>
<script async type="text/javascript" language="javascript" src="https://apis.gurufocus.com/ajaxstarrater/js/behavior.js"></script>
<script async type="text/javascript" language="javascript" src="https://apis.gurufocus.com/ajaxstarrater/js/rating.js"></script>

<script src='https://www.google.com/recaptcha/api.js'></script>
<div>
<table width="100%"><tr><td valign="top"><div class="ratingblock"><div id="unit_long1382833"> <ul id="unit_ul1382833" class="unit-rating" style="width:150px;list-style:none outside none;"> <li class="current-rating" style="width:0px;">Currently 0.00/5</li><li><a href="javascript:;" onclick="popup_login();" title="Please login to vote" class="r1-unit">1</a></li><li><a href="javascript:;" onclick="popup_login();" title="Please login to vote" class="r2-unit">2</a></li><li><a href="javascript:;" onclick="popup_login();" title="Please login to vote" class="r3-unit">3</a></li><li><a href="javascript:;" onclick="popup_login();" title="Please login to vote" class="r4-unit">4</a></li><li><a href="javascript:;" onclick="popup_login();" title="Please login to vote" class="r5-unit">5</a></li> </ul> <p class="voted">Rating: <strong> 0.0</strong>/5 (0 votes) </p></div></div></td><td width="74%" valign="top"></td></tr></table>
</div>
<div class="control_links hide_for_print" style="border-top: solid 2px #DDD;clear:both;">
<a href="http://feedburner.google.com/fb/a/mailverify?uri=GurufocusArticles&amp;loc=en_US" target="_blank"><img src="https://static.gurufocus.com/images/icons/gray/png/mail_icon&16.png" alt="Email Feeds" />Subscribe
via Email</a>
<a href="/rss.php"><img src="https://static.gurufocus.com/images/icons/gray/png/rss_icon&16.png" alt="RSS Feeds" />Subscribe RSS</a>
<div class="clear"></div>
</div>
</div>
</div>
<a name="comment" id="comment"></a>
<h3>Comments</h3>
<div></div>
<div class="clear"></div><a name="addc"></a>
<div class="softcell_new hide_for_print"><h4>Please leave your comment:</h4><link media="screen" rel="stylesheet" href="https://apis.gurufocus.com/css/colorbox.css" />
<textarea class="accessboxbig" rows="4" id="body_login"></textarea>
<input type="button" class="PhorumSubmit" id="fake_submit" value="Post Comment" />
<script language="javascript" src="https://apis.gurufocus.com/js/jquery.colorbox.js" type="text/javascript"></script>
<script>
$(document).ready(function(){
	$('#body_login, #watch, #follow, #fake_submit').click(function(){
		popup_login();
	});
});
</script></div>
<br>
<div class="hide_for_print">
<h3>More GuruFocus Links</h3>
<table width="100%" cellspacing="0" cellpadding="0" style="text-align:left;" id="keyfeatures">
<tbody>
<tr>
<td><a href="/guru/latest-picks" title="Latest Guru Picks">Latest Guru Picks</a></td>
<td><a href="/stock_ideas.php">Value Strategies</a></td>
</tr>
<tr>
<td><a href="/guru/warren+buffett/stock-picks">Warren Buffett Portfolio</a></td>
<td><a href="/screener/grahamncav">Ben Graham Net-Net</a></td>
</tr>
<tr>
<td><a href="/guru/realtime-picks" title="Real Time Picks">Real Time Picks</a></td>
<td><a href="/screener/buffett-munger" title="Buffett-Munger Screener">Buffett-Munger Screener</a></td>
</tr>
<tr>
<td><a href="/guru/aggregated-portfolio">Aggregated Portfolio</a><a href="/gurutrac/real_time_picks.php" alt="Real Time Picks" title="Real Time Picks"></a></td>
<td><a href="/screener/valuedcf" alt="Undervalued Predictable" title="Undervalued Predictable">Undervalued Predictable</a></td>
</tr>
<tr>
<td><a href="/guru/etfs">ETFs</a>, <a href="/options.php">Options</a></td>
<td><a href="/screener/lowps" alt="Low P/S Companies" title="Low P/S Companies">Low P/S Companies</a></td>
</tr>
<tr>
<td><a href="/insider/trend">Insider Trends</a></td>
<td><a href="/financials.php?symbol=WMT">10-Year Financials</a><a href="/newsletters.php"></a></td>
</tr>
<tr>
<td><a href="/screener/52weeklow">52-Week Lows</a></td>
<td><a href="/chart.php">Interactive Charts</a></td>
</tr>
<tr>
<td><a href="/model_portfolio.php" title="Model Portfolios">Model Portfolios</a></td>
<td><a href="/fair_value_dcf.php">DCF Calculator</a></td>
</tr>
<tr>
<td><a href="/rss.php" title="RSS Feed">RSS Feed</a><a href="/rss.php" alt="RSS Feed" title="RSS Feed"> <img src="https://static.gurufocus.com/images/rss_large.gif"></a></td>
<td><a href="/gurutrac/holding_stat.php"></a><a href="/newsletters.php">Monthly Newsletters</a></td>
</tr>
<tr>
<td><a href="/screener/" title="Screener">The All-In-One Screener</a><a href="/screener/" alt="Screener" title="Screener"></a></td>
<td><a href="/ic/space.php?do=portfolio&view=me"></a><a href="/ic/space.php?do=portfolio&view=me">Portfolio Tracking Tool</a></td>
</tr>
</tbody>
</table>
</div>
<div class="clear"></div>
</div>
<div class="news_sidebar right" style="width: 335px;margin-top:0px;">
<div class="bootstrap-iso" style="text-align:center">
<a class="form-control btn btn-primary btn-sm" href="/news.php?id=70028" style="width: 150px;font-size:14px">Write for GuruFocus</a>
<a class="form-control btn btn-primary btn-sm" href="/forum/post.php?4" style="width: 150px;font-size:14px">Submit an article</a>
</div>
<br>
<div class="bootstrap-iso">
<div class="row" style="background-color:red;padding:20px;">
<div style="padding:8px;line-height: 28px;font-weight:bold;color:white;">
<a href="/stock/FTNT/summary" style="color:white;font-size:20px;text-decoration: none;">
GuruFocus has detected 3 Warning Signs with Fortinet Inc FTNT. </a>
</div>
<div style="text-align:center">
<a href="/stock/FTNT/summary" style="color:white;font-size: 22px;text-decoration: underline;font-weight: bold;">Check it out</a>
</div>
</div>
</div>
<div id="flarum_loader" class="bootstrap-iso"></div>
<a id="port_link" class="article_page_links" target="_blank" href="#"><h3><span style="float:right;">→</span>Performances of the stocks mentioned by Marketwired</h3></a>
<hr class="hr_sec" style="margin-bottom:0px;">
<div id="ap_container" style="">
</div>
<script type="text/javascript">

                $( document ).ready(function() {

                    var get_pid_url = "https://www.gurufocus.com/classes/screener/portfolio/article_port/performance/1382833";
                    $.get(get_pid_url,function(data){
                        if (data == 'No record') {
                            let portLink = document.getElementById("port_link");
                            portLink.remove();

                        } else {
                            var get_port_url = "https://www.gurufocus.com/classes/screener/home?url=user_portfolio_data&id="+data+"&cache=clear";
                            $("#port_link").attr("href","/ic/space.php?do=portfolio&id="+data);
                            $.get(get_port_url,function(response){
                                console.log(get_port_url);
                                $("#ap_container").html(response);
                                CreateToolTips($("#homepage_portfolio_overview"));
                            }).fail(function(error){
                                        console.log(error);
                                        $("#ap_container").html("No Records");
                                    })
                            }
                    }).fail(function(error){
                            console.log(error);
                            $("#ap_container").html("No Records");
                        })
                });


            </script>
<a class="article_page_links" target="_blank" href="/screener/"><h3><span style="float:right;">→</span>User
Generated Screeners</h3></a>
<hr class="hr_sec" style="margin-bottom:0px;">
<table cellpadding="4" style="font-size:12px;text-align:left;"><tr><th><a href="/ic/space.php?uid=103089&user_screener">pjmason14</a></th><td><a href="http://www.gurufocus.com/screener/#&minProfitYearNum=8&recentInsiderBuyingDuration=20150801.20150831&minPriceChange24SP=100&minPercentAbove200DaySMA=5&minPriceChange24=100&minPercentAbove50DaySMA=5&includeOTC=0&minInterestCoverage=5&minMarketCap=500&screenPrivate=undefined&screen_id=0&screenName=Momentum&isCustomized2106=on&tab=9&page=1&sort=&dir=&stab=-&user_screener" target="_blank">Momentum</a></td></tr><tr><th><a href="/ic/space.php?uid=485410&user_screener">wigbert</a></th><td><a href="http://www.gurufocus.com/screener/#&screenName=High FCF-M2&screen_id=0&screenPrivate=undefined&minMarketCap=1000&minRevenue=1000&minFCFMargin=106&homeExchange=1&industry=-10211024-10211025-10218038-10319042-10320043-10320044-10320045-10320046-10320047-10320048-10320049-10320050-10320051-10320052-10323057-10324058-10325059-10326060-10326061-10427062-10427063-10428064-10428065-10428066-10428067-10428068-10428069-10428070-30946101-30947102-30948103-30949104-30950105-30951106-0&region=-DEU-FRA-SWE-ITA-LUX-CHE-BEL-NOR-ESP-DNK-NLD-FIN-AUT-PRT&recentInsiderBuyingDuration=20190201.20190231&tab=9&page=1&sort=&dir=&stab=-&user_screener" target="_blank">High FCF-M2</a></td></tr><tr><th><a href="/ic/space.php?uid=529270&user_screener">kosalmmuse</a></th><td><a href="http://www.gurufocus.com/screener/#&screenName=6&screen_id=0&screenPrivate=undefined&maxMarketCap=1000&minFinancialStrength=60&maxDebtToEquity=4&minPredictability=10&maxPredictability=50&industry=10208014-10208015-10214030-20532078-20637087-20638088-20638089-31054109-31055110-31057113-31061118-31165131-31165132-31165133-31165134-31166135-31167136-31167137-31167140-31168144-0&region=-_Oceania-AUS&recentInsiderBuyingDuration=20190201.20190231&tab=9&page=1&sort=&dir=&stab=-&user_screener" target="_blank">6</a></td></tr><tr><th><a href="/ic/space.php?uid=529270&user_screener">kosalmmuse</a></th><td><a href="http://www.gurufocus.com/screener/#&screenName=Best one1&screen_id=0&screenPrivate=undefined&maxMarketCap=1000&minFinancialStrength=10&maxDebtToEquity=4&minPredictability=10&maxPredictability=50&industry=10208014-10208015-10214030-20532078-20637087-20638088-20638089-31054109-31055110-31057113-31061118-31165131-31165132-31165133-31165134-31166135-31167136-31167137-31167140-31168144-0&region=-_Oceania-AUS&recentInsiderBuyingDuration=20190201.20190231&tab=9&page=1&sort=&dir=&stab=-&user_screener" target="_blank">Best one1</a></td></tr><tr><th><a href="/ic/space.php?uid=24724&user_screener">DBrizan</a></th><td><a href="http://www.gurufocus.com/screener/#&screenName=all 2019Feb26&screen_id=0&screenPrivate=undefined&InSP=1&optionableStock=1&includeOTC=0&minDividendYear=1&industry=-10319042-10320043-10320044-10320045-10320046-10320047-10320048-10320049-10320050-10320051-10320052-10321053-10321054-10321055-10322056-10323057-10324058-10325059-10326060-10326061-0&country=USA-CAN-BMU-AIA-ATG-ABW-BHS-BRB-BLZ-CYM-CRI-CUB-DMA-DOM-SLV-GRD-GDL-GTM-HTI-HND-JMC-MRT-MEX-MSR-ATN-NCG-PNR-BAR-SCN-LCA-VCT-TRD-TCA-VRG-VIR-ARG-BOL-BRA-CHL-COL-EQA-GUF-GUY-PRG-PER-SPO-SUR-URG-VEN-PR-ALB-AND-AUT-BLR-BEL-BIH-BGR-HRV-CZE-DNK-EST-FIN-FRA-DEU-GRC-HUN-ISL-IRL-ITA-LVA-LIE-LTU-LUX-MKD-MLT-MDA-MCO-NLD-NOR-POL-PRT-ROM-RUS-SMR-SVK-SVN-ESP-SWE-CHE-UKR-CVA-GBR-DZA-AGO-BEN-BWA-BFA-BDI-CME-CPV-CAF-TCD-COG-COD-DJI-EGY-GNE-ERI-ETH-GAB-GMB-GHA-GLO-GUI-GNB-CTI-JDN-KEN-LSO-LBR-LBY-MDG-MWI-MLI-MTN-MAU-MYT-MAR-MOZ-NMB-NGR-NIG-REU-RRW-STP-SEN-SEY-SRL-SOM-ZAF-SDN-SWZ-TZA-TGO-TRO-TUN-UGA-AOE-ZMB-ZWE-TT-HKG-AFG-ARM-AZE-BHR-BGD-BTN-BRN-KHM-CHN-CYP-GEO-IND-IDN-IRN-IRQ-ISR-JPN-JOR-KAZ-KOR-KWT-KGZ-LAO-LBN-MYS-MLD-MNG-NPL-OMA-PAK-PHL-QAT-SAU-SGP-CLN-SYR-TJK-TWN-THA-TMP-TUR-TKM-ARE-UZB-VNM-YEM-AUS-NZL-0&recentInsiderBuyingDuration=20180801.20180831&minCustomized2983=1.7&minCustomized12271=39&minCustomized12265=1.81&maxCustomized12266=-2.22&minCustomized12267=4&minCustomized11760=15&maxCustomized12207=15&minCustomized11968=-999&minCustomized12206=0&minCustomized9371=0&minCustomized2970=0.1&maxCustomized2970=1.2&minCustomized11437=0&minCustomized2960=15&minCustomized3632=50&minCustomized11192=0&minCustomized11193=0&minCustomized13891=5&minCustomized13876=2.75&tab=9&page=1&sort=&dir=&stab=-&user_screener" target="_blank">all 2019Feb26</a></td></tr><tr><th><a href="/ic/space.php?uid=529270&user_screener">kosalmmuse</a></th><td><a href="http://www.gurufocus.com/screener/#&screenName=Best one&screen_id=0&screenPrivate=undefined&maxMarketCap=1000&minFinancialStrength=60&maxDebtToEquity=4&minPredictability=10&maxPredictability=50&industry=10208014-10208015-10214030-20532078-20637087-20638088-20638089-31054109-31055110-31057113-31061118-31165131-31165132-31165133-31165134-31166135-31167136-31167137-31167140-31168144-0&region=-_Oceania-AUS&recentInsiderBuyingDuration=20190201.20190231&tab=9&page=1&sort=&dir=&stab=-&user_screener" target="_blank">Best one</a></td></tr><tr><th><a href="/ic/space.php?uid=24724&user_screener">DBrizan</a></th><td><a href="http://www.gurufocus.com/screener/#&screenName=all 2019Feb25&screen_id=0&screenPrivate=undefined&InSP=1&optionableStock=1&includeOTC=0&minDividendYear=1&industry=-10319042-10320043-10320044-10320045-10320046-10320047-10320048-10320049-10320050-10320051-10320052-10321053-10321054-10321055-10322056-10323057-10324058-10325059-10326060-10326061-0&country=USA-CAN-BMU-AIA-ATG-ABW-BHS-BRB-BLZ-CYM-CRI-CUB-DMA-DOM-SLV-GRD-GDL-GTM-HTI-HND-JMC-MRT-MEX-MSR-ATN-NCG-PNR-BAR-SCN-LCA-VCT-TRD-TCA-VRG-VIR-ARG-BOL-BRA-CHL-COL-EQA-GUF-GUY-PRG-PER-SPO-SUR-URG-VEN-PR-ALB-AND-AUT-BLR-BEL-BIH-BGR-HRV-CZE-DNK-EST-FIN-FRA-DEU-GRC-HUN-ISL-IRL-ITA-LVA-LIE-LTU-LUX-MKD-MLT-MDA-MCO-NLD-NOR-POL-PRT-ROM-RUS-SMR-SVK-SVN-ESP-SWE-CHE-UKR-CVA-GBR-DZA-AGO-BEN-BWA-BFA-BDI-CME-CPV-CAF-TCD-COG-COD-DJI-EGY-GNE-ERI-ETH-GAB-GMB-GHA-GLO-GUI-GNB-CTI-JDN-KEN-LSO-LBR-LBY-MDG-MWI-MLI-MTN-MAU-MYT-MAR-MOZ-NMB-NGR-NIG-REU-RRW-STP-SEN-SEY-SRL-SOM-ZAF-SDN-SWZ-TZA-TGO-TRO-TUN-UGA-AOE-ZMB-ZWE-TT-HKG-AFG-ARM-AZE-BHR-BGD-BTN-BRN-KHM-CHN-CYP-GEO-IND-IDN-IRN-IRQ-ISR-JPN-JOR-KAZ-KOR-KWT-KGZ-LAO-LBN-MYS-MLD-MNG-NPL-OMA-PAK-PHL-QAT-SAU-SGP-CLN-SYR-TJK-TWN-THA-TMP-TUR-TKM-ARE-UZB-VNM-YEM-AUS-NZL-0&recentInsiderBuyingDuration=20180801.20180831&minCustomized2983=1.7&minCustomized12271=39&minCustomized12265=1.81&maxCustomized12266=-2.22&minCustomized12267=4&minCustomized11760=15&maxCustomized12207=15&minCustomized11968=-999&minCustomized12206=0&minCustomized9371=0&minCustomized2970=0.1&maxCustomized2970=1.2&minCustomized11437=0&minCustomized2960=15&minCustomized3632=50&minCustomized11192=0&minCustomized11193=0&minCustomized13891=5&minCustomized13876=2.75&tab=9&page=1&sort=&dir=&stab=-&user_screener" target="_blank">all 2019Feb25</a></td></tr><tr><th><a href="/ic/space.php?uid=529270&user_screener">kosalmmuse</a></th><td><a href="http://www.gurufocus.com/screener/#&screenName=Nice&screen_id=0&screenPrivate=undefined&minMarketCap=5&maxMarketCap=500&minFinancialStrength=70&maxFinancialStrength=100&maxDebtToEquity=4&minPredictability=10&maxPredictability=50&industry=10101001-10102002-10103003-10103004-10104005-10105006-10105007-10106008-10106009-10106010-10106011-10106012-10107013-10208014-10208015-10209016-10209017-10209018-10209019-10209020-10212026-10212027-10212028-10213029-10214030-10215031-10216032-10217033-10217034-10217035-10217036-10217037-20530073-20531074-20531075-20531077-20532078-20533079-20533080-20533081-20533082-20635084-20636085-20636086-20637087-20638088-20638089-20639090-20640091-20641092-20642093-20743094-20744095-20744096-20744097-20744098-30845099-30845100-30946101-30947102-30948103-30949104-30950105-30951106-31053108-31054109-31055110-31056111-31056112-31057113-31058114-31058115-31059116-31060117-31061118-31061119-31061120-31061121-31061122-31062123-31062124-31062125-31062126-31062127-31063128-31064129-31165130-31165131-31165132-31165133-31165134-31166135-31167136-31167137-31167138-31167139-31167140-31167141-31167142-31167143-31168144-31169145-31169146-31169147-31169148-0&region=-_Oceania-AUS&recentInsiderBuyingDuration=20190201.20190231&tab=9&page=1&sort=&dir=&stab=-&user_screener" target="_blank">Nice</a></td></tr><tr><th><a href="/ic/space.php?uid=529270&user_screener">kosalmmuse</a></th><td><a href="http://www.gurufocus.com/screener/#&screenName=han&screen_id=0&screenPrivate=undefined&minMarketCap=5&maxMarketCap=1000&minFinancialStrength=70&maxFinancialStrength=100&maxDebtToEquity=4&minPredictability=10&maxPredictability=50&maxPEG=r500&region=-_Oceania-AUS&recentInsiderBuyingDuration=20190201.20190231&tab=9&page=1&sort=&dir=&stab=-&user_screener" target="_blank">han</a></td></tr><tr><th><a href="/ic/space.php?uid=519710&user_screener">MsDale</a></th><td><a href="http://www.gurufocus.com/screener/#&recentInsiderBuyingDuration=20190201.20190231&country=USA-0&industry=-10320048-0&maxPercentAbove52WeekLow=10&maxPriceChangeToday=105&screenNote=*52-Week Low&screen_id=37778&screenPrivate=undefined&minMarketCap=200&minInterestCoverage=2&minBuyback3y=99&minBuyback1y=99&maxPFCF=26&minPrice=1&screenName=*52-Week Low&tab=9&page=1&sort=&dir=&stab=-&user_screener" target="_blank">*52-Week Low</a></td></tr></table>
<div id="related">
<div style="margin-bottom:30px;"><h3 style="margin-top:0px;"><a class="article_page_links" style="float:right;" href="/chart/FTNT">→</a>FTNT Price Chart</h3><hr class="hr_sec" style="margin-bottom:0px;"><div class="clear"></div></div><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-4020868656364652" data-ad-slot="7301743729"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
<div style='margin-bottom:30px;'><h3><a class='article_page_links' style="float:right;" href='/news.php?cat=column#allnews'>→</a>Guru News</h3><hr class="hr_sec" style="margin-bottom:0px;"><ul><li class='ll_bullet'><a href="/news/1381818/tech-stocks-lead-a-market-rebound-tuesday" class="smalllink">Tech Stocks Lead a Market Rebound Tuesday</a><font class='date'> by <a href="/news.php?author=Julie Young">Julie Young</a></font></li><li class='ll_bullet'><a href="/news/1381798/3-new-magic-formula-stocks-to-consider" class="smalllink">3 New 'Magic Formula' Stocks to Consider</a><font class='date'> by <a href="/news.php?author=Margaret Moran">Margaret Moran</a></font></li><li class='ll_bullet'><a href="/news/1381788/royce-investment-partners-commentary-finding-growth-at-reasonable-prices" class="smalllink">Royce Investment Partners Commentary: Finding Growth at Reasonable Prices</a><font class='date'> by <a href="/news.php?author=Sydnee Gatewood">Sydnee Gatewood</a></font></li><li class='ll_bullet'><a href="/news/1381786/causeway-capital-commentary-global-value-technology-stocks-are-proving-resilient-amid-selloff" class="smalllink">Causeway Capital Commentary: Global Value Technology Stocks Are Proving Resilient Amid Sell-Off</a><font class='date'> by <a href="/news.php?author=Sydnee Gatewood">Sydnee Gatewood</a></font></li></ul></div><div style='margin-bottom:30px;'><h3><a class='article_page_links' style="float:right;" href='/news.php?cat=column#valueideas'>→</a>Value Ideas</h3><hr class="hr_sec" style="margin-bottom:0px;"><ul><li class='ll_bullet'><a href="/news/1382159/securitas-presents-new-global-brand-identity" class="smalllink">Securitas presents new global brand identity</a><font class='date'> by <a href="/news.php?author=PRNewswire">PRNewswire</a></font></li><li class='ll_bullet'><a href="/news/1382158/shareholder-alert-pomerantz-law-firm-investigates-claims-on-behalf-of-investors-of-xl-fleet-corporation--xl" class="smalllink">SHAREHOLDER ALERT: Pomerantz Law Firm Investigates Claims On Behalf of Investors of XL Fleet Corporation - XL</a><font class='date'> by <a href="/news.php?author=PRNewswire">PRNewswire</a></font></li><li class='ll_bullet'><a href="/news/1382157/amorepacific-becomes-the-first-korean-beauty-company-to-join-re100" class="smalllink">Amorepacific becomes the first Korean beauty company to join RE100</a><font class='date'> by <a href="/news.php?author=PRNewswire">PRNewswire</a></font></li><li class='ll_bullet'><a href="/news/1382156/shareholder-alert-pomerantz-law-firm-investigates-claims-on-behalf-of-investors-of-credit-suisse-group-ag--cs" class="smalllink">SHAREHOLDER ALERT: Pomerantz Law Firm Investigates Claims On Behalf of Investors of Credit Suisse Group AG - CS</a><font class='date'> by <a href="/news.php?author=PRNewswire">PRNewswire</a></font></li></ul></div><div style='margin-bottom:30px;'><h3><a class='article_page_links' style="float:right;" href='/news.php?cat=column#qa'>→</a>Guru Interviews</h3><hr class="hr_sec" style="margin-bottom:0px;"><ul><li class='ll_bullet'><a href="/news/1376128/march-members-engagement-meeting" class="smalllink">March Members Engagement Meeting</a><font class='date'> by <a href="/news.php?author=Graham Griffin">Graham Griffin</a></font></li><li class='ll_bullet'><a href="/news/1369105/value-investing-live-recap-david-marcus" class="smalllink">Value Investing Live Recap: David Marcus</a><font class='date'> by <a href="/news.php?author=Graham Griffin">Graham Griffin</a></font></li><li class='ll_bullet'><a href="/news/1362542/value-investing-live-recap-patrick-brennan" class="smalllink">Value Investing Live Recap: Patrick Brennan</a><font class='date'> by <a href="/news.php?author=Graham Griffin">Graham Griffin</a></font></li><li class='ll_bullet'><a href="/news/1348986/february-members-engagement-meeting-recap" class="smalllink">February Members Engagement Meeting Recap</a><font class='date'> by <a href="/news.php?author=Graham Griffin">Graham Griffin</a></font></li></ul></div><div style='margin-bottom:30px;'><h3><a class='article_page_links' style="float:right;" href='/news.php?cat=rank'>→</a>Top Ranked Articles</h3><hr class="hr_sec" style="margin-bottom:0px;"><ul><li class='ll_bullet'><a href="/news/1365302/how-the-fear-of-missing-out-can-harm-your-profits" class="smalllink">How the 'Fear of Missing Out' Can Harm Your Profits</a><font class='date'> by <a href="/news.php?author=Nicola Guida">Nicola Guida</a></font></li><li class='ll_bullet'><a href="/news/1369888/charlie-mungers-thoughts-from-the-daily-journal-annual-meeting" class="smalllink">Charlie Munger's Thoughts From the Daily Journal Annual Meeting</a><font class='date'> by <a href="/news.php?author=Rupert Hargreaves">Rupert Hargreaves</a></font></li><li class='ll_bullet'><a href="/news/1372353/5-key-takeaways-from-warren-buffetts-2021-letter" class="smalllink">5 Key Takeaways From Warren Buffett's 2021 Letter</a><font class='date'> by <a href="/news.php?author=Panos Mourdoukoutas">Panos Mourdoukoutas</a></font></li><li class='ll_bullet'><a href="/news/1377540/the-most-popular-guru-buys-of-the-4th-quarter" class="smalllink">The Most Popular Guru Buys of the 4th Quarter</a><font class='date'> by <a href="/news.php?author=Margaret Moran">Margaret Moran</a></font></li></ul></div><div id="scrolWrapper">
<div id="scrol"><div style='margin-bottom:30px;'><h3><a class='article_page_links' style='float:right;' href='/news.php?cat=column'>→</a>You May Also Like</h3><hr class="hr_sec" style="margin-bottom:0px;"><ul><li class='ll_bullet'><a href="/news/1382793/fortinets-rapidly-growing-open-fabric-ecosystem-helps-customers-achieve-integrated-security" class="smalllink">Fortinet's Rapidly Growing Open Fabric Ecosystem Helps Customers Achieve Integrated Security</a></li><li class='ll_bullet'><a href="/news/1370880/fortinet-inc-ftnt-cfo--chief-accounting-officer-keith-jensen-sold-28-million-of-shares" class="smalllink">Fortinet Inc (FTNT) CFO & Chief Accounting Officer Keith Jensen Sold $2.8 million of Shares</a></li><li class='ll_bullet'><a href="/news/1369223/fortinet-announces-pricing-of-10-billion-senior-notes-offering" class="smalllink">Fortinet Announces Pricing of $1.0 Billion Senior Notes Offering</a></li><li class='ll_bullet'><a href="/news/1368795/fortiguard-labs-reports-disruptive-shift-of-cyber-threats" class="smalllink">FortiGuard Labs Reports Disruptive Shift of Cyber Threats</a></li><li class='ll_bullet'><a href="/news/1367494/fortinet-named-a-gartner-peer-insights-customers-choice-for-wan-edge-infrastructure-for-second-year-in-a-row" class="smalllink">Fortinet Named a Gartner Peer Insights Customers' Choice for WAN Edge Infrastructure for Second Year in a Row</a></li></ul></div></div></div> </div>
<div class="clear" id="t1"></div>
</div><div class="clear"></div></div>
<script src="https://apis.gurufocus.com/js/ckeditor_new/ckeditor.js"></script>
<script type="text/javascript" src="https://apis.gurufocus.com/modules/js/get_forum_input_plain.js"></script>
<script type="text/javascript" src="https://apis.gurufocus.com/js/news.js?1.9.6"></script>
<link rel="stylesheet" type="text/css" href="https://www.gurufocus.com/ajaxstarrater/css/rating.css?1" />
<script src="https://static.gurufocus.com/js/share/selection-sharer.js"></script>
<script>
        $('p').selectionSharer();
    </script>
<script src="https://apis.gurufocus.com/js/spam_control/spam_control.js"></script>
<script>
        function reportSPAM($id) {
            SpamControl.reportSPAM($id, null);
        }
    </script>
<div class="hidden">
<div id="watchlist-form" title="Add to portfolio">
<form id="watchlistform">
<p>Select portfolio(s):</p>
<ul>
<div style="width:auto;max-height:400px;overflow-x:hidden;overflow-y:auto;" id="userportfoliodiv">
<div align="left" id='stock_port_p'>
<li><img src='https://static.gurufocus.com/images/horizontal_loading.gif' alt='Loading...' /></li>
</div>
</div>
<li>
<label for="portid_0"><INPUT TYPE="checkbox" NAME="selectportfolio" id="portid_0" VALUE="0" />
Create a new portfolio</label>
<input type="text" name="newportfolioname" id="newportfolioname" size="20" />
</li>
</ul>
<p>Why you are interested?</p>
<textarea rows="2" cols="45" class="text ui-widget-content ui-corner-all" id="watchlistnotes"></textarea>
</form>
<p class="validateTips" align="left" style="font-size:10px;">
Your selection and notes will be stored in your <a href="/ic/space.php?do=portfolio&view=me">portfolio</a>.
</p>
</div>
<div id="watch_area">
<div style='float:left; border: 1px solid #a0e47e; padding: 3px;background-color: #eeeeee'><a class='nav' href='/login_signup.php'>Login to add portfolio</a></div>
</div>
<div id="guru-dialog-message1" title="Guru added"></div>
</div>
<script type="text/javascript" language="javascript" src="//cdn.jsdelivr.net/qtip2/2.2.1/jquery.qtip.min.js"></script>
<script>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</script>
<script>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</script>
<script>
// Add to portfolio


    function updateTips(t) {
        tips.text(t).addClass("ui-state-highlight");
        setTimeout(function() {
            tips.removeClass("ui-state-highlight", 1500);
        }, 500);
    }

    function checkSelect(o, n) {
        //alert(o);
        //
        if ( o.length==0) {
            updateTips("You must select a " + n);
            return false;
        } else {
            return true;
        }
    }

//

	$("#watch_area").dialog({
        autoOpen : false,
        resizable : false,
        height : 'auto',
        width : 400,
        modal : true,
     });
     
    $("#watchlist-form").dialog({
        autoOpen : false,
        resizable : false,
        height : 'auto',
        width : 400,
        modal : true,
        buttons : {
            "Submit" : function() {
                var bValid = true;

                // Get which radio is selected
                var port = [];
                $('input[name=selectportfolio]:checked').each(function(){
                	port.push($(this).val()+'');
                });

                if(port.length>0){
                    port=port.join("|");
                }

                bValid = bValid && checkSelect(port, "portfolio");

                // If user input is valid, submit stock notes to server.
                if (bValid) {

                    var new_port_name = $('#newportfolioname').val();

                    // Get Stock Notes
                    var notes = jQuery.trim($('#watchlistnotes').val());
                    
                    var WatchSymbol = $(this).data('sym');

                    // Add notes
                    // Get thread_id
                    var message_id = '';
                    if (notes != '') {
                        var sublength = notes.length;
                        if (sublength > 20) {
                            var subject = notes.substr(0, 20);
                        } else {
                            var subject = notes;
                        }
                        var time1 = new Date().getTime();

                        $.post("/modules/post/handle_forum_posts.php", "id_out=1&body=<a href=\"http://www.gurufocus.com/stock/" + WatchSymbol + "\">$" + WatchSymbol + "</a>: " + notes + "&subject=" + subject + "&lasttime=" + time1 + "&parent_id=0&thread=0&forum_id=9&Submit=Submit&stocks=" + WatchSymbol, function(theResponse) {
                            message_id = theResponse;

                            // Add symbol to portfolio
                            //alert(message_id);
                            $.post("/modules/post/watch_new.php", "symbol=" + escape(WatchSymbol) + "&port_id=" + port + "&new_port_name=" + new_port_name + "&notes=" + message_id, function(theResponse) {
                                $("#watch_area").html(theResponse);
                            });
                        });
                    } else {
                        // If no notes
                        $.post("/modules/post/watch_new.php", "symbol=" + escape(WatchSymbol) + "&port_id=" + port + "&new_port_name=" + new_port_name, function(theResponse) {
                            $("#watch_area").html(theResponse);
                        });

                    }

                    // Close the dialog
                    $(this).dialog("close");
                }

            },
            Cancel : function() {
                $(this).dialog("close");
            }
        },
        close : function() {
            //allFields.val( "" ).removeClass( "ui-state-error" );
            //$("#watch_area").html("<a href='javascript:;' id='watch' style='addtoport'><img src='https://static.gurufocus.com/images/icons/gray/png/sq_plus_icon&16.png' />Add to Portfolio</a>");
        }
    });

    
  
$(document.body).on('click', '.add_p' ,function(){
	
	var UserId = "";
	//Hide all tooltips
	$(".stocks_tp").qtip('hide');
	
	 if (UserId > 0) {//load Ajax javascript only if logged in.
            // put user's portfolio in stock_port_p
            $.get('/modules/stock/get_port.php?user_id='+UserId, function(data) {
                $('#stock_port_p').html(data);
            });
            // open dialog
            $("#watchlist-form").data('sym', $(this).attr('id')).dialog("open");
            $( "#watchlist-form" ).dialog({position:{my:"center center",at:"center top", of:"#newcontent"}});
            

        } else {
            $("#watch_area").dialog("open");
            $( "#watch_area" ).dialog({position:{my:"center center",at:"center top+300", of:"#newcontent"}});
        }
});

</script>
<div>
<div style="text-align:center">

<div id="io_603f974c6e3a2" class="io_970"></div>
<script>var iO = ["io_603f974c6e3a2","1500","970","90"];</script>
<script src="//ioadserve.com/siteAds.js" type="text/javascript"></script>

</div> <div id="content3" style="background-color: #FFF9E6;padding:3px;">
<div style="border:0px;padding:5px;margin:0 5px;text-align:center;">
<a href="/membership/AffiliateProgramFAQ.php#wp">Get WordPress Plugins</a> for easy affiliate links on Stock Tickers and Guru Names
| <a href="/news/220422/earn-affiliate-commissions-by-embedding-gurufocus-charts">Earn affiliate commissions by embedding GuruFocus Charts</a><br />
GuruFocus Affiliate Program: Earn up to $400 per referral. ( <a class="moremore" href="https://www.gurufocus.com/membership/AffiliateProgramFAQ.php" style="float: none;color:#CC6600;">Learn More</a>) <br />
</div>
</div>
<div id="premium_membership" style="margin-top: 60px;">
<div style="margin:0 auto;width:887px;margin-top:20px;">
<a href="https://www.gurufocus.com/membership/upgrade.php?ref=bottom"><img style="" src="https://static.gurufocus.com/images/new/guru_premium_mem.jpg"></a>
</div>
</div>
<div class="clear"></div>
<div id="content3" style="background-color: #F5F8FD;padding:3px;">

<div class="clear"></div>
</div>

</div>
<div id="footer">
<div class="footergrid">
<ul class="footerul">
<li class="footerli">
<a href="/">Home</a>&nbsp;&nbsp;<a href="/about.php">About</a>&nbsp;&nbsp; <a href="/jobs.php">Jobs</a>&nbsp;&nbsp; <a href="/sponsor.php">Advertise</a>&nbsp;&nbsp;&nbsp; <a href="/sitemap.php">Site Map</a>&nbsp;&nbsp;&nbsp; <a href="/Terms_of_use.php" target="_blank">Term of Use</a>&nbsp;&nbsp;&nbsp; <a href="/Privacy_policy.htm" target="_blank">Privacy Policy</a>&nbsp;&nbsp;&nbsp; <a href="/rss.php" target="_blank">&nbsp;RSS</a>&nbsp;&nbsp;&nbsp; <a href="/app.php" target="_blank">Mobile App</a> &nbsp;&nbsp;&nbsp; <a href="/subscribe.php">Email Alerts</a>&nbsp;&nbsp;&nbsp; <a href="/user_referrals.php">Referral Program</a>&nbsp;&nbsp;&nbsp; <a href="/membership/AffiliateProgramFAQ.php">Affiliate Program</a>&nbsp;&nbsp;&nbsp; <a href="/faq.php">FAQ</a>&nbsp;&nbsp;&nbsp; <a href="/ticket/open.php" target="_blank">Contact Us</a>
&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; <a href="https://www.gurufocus.cn/" target="_blank">中文</a> </li>
<li class="footerli">
&copy; 2004-2021 GuruFocus.com, LLC. All Rights Reserved.
</li>
<li class="footerli">
<p>
Disclaimers: GuruFocus.com is not operated by a broker, a dealer, or a registered investment adviser. Under no circumstances does any information posted on GuruFocus.com represent a recommendation to buy or sell a security. The information on this site, and in its related newsletters, is not intended to be, nor does it constitute, investment advice or recommendations. The gurus may buy and sell securities before and after any particular article and report and information herein is published, with respect to the securities discussed in any article and report posted herein. In no event shall GuruFocus.com be liable to any member, guest or third party for any damages of any kind arising out of the use of any content or other material published or available on GuruFocus.com, or relating to the use of, or inability to use, GuruFocus.com or any content, including, without limitation, any investment losses, lost profits, lost opportunity, special, incidental, indirect, consequential or punitive damages. Past performance is a poor indicator of future performance. The information on this site, and in its related newsletters, is not intended to be, nor does it constitute, investment advice or recommendations. The information on this site is in no way guaranteed for completeness, accuracy or in any other way. The gurus listed in this website are not affiliated with GuruFocus.com, LLC.
Stock quotes provided by InterActive Data. Fundamental company data provided by Morningstar, updated daily.</p>
</li>
</ul>
</div>
</div>
</div>
<div id="fb-root"></div>
<div id="g_id_onload" data-client_id="476916250870-vd0h3qms55eo8gp4sn454t2treesle3d.apps.googleusercontent.com" data-login_uri="https://your.domain/your_login_endpoint" data-your_own_param_1_to_login="any_value" data-your_own_param_2_to_login="any_value">
</div>
<link media="screen" rel="stylesheet" href="//apis.gurufocus.com/css/colorbox.css" />
<script async language="javascript" src="//apis.gurufocus.com/js/jquery.colorbox.js" type="text/javascript"></script>
<script async type="text/javascript" src="//apis.gurufocus.com/js/jquery.form.js"></script>
<script async type="text/javascript" src="//apis.gurufocus.com/js/guru_common.js?2020.10.12"></script>
<script src="https://accounts.google.com/gsi/client" async defer></script>
<script>

$(document).ready(function(){
	//console.log(document.referrer);

});
	</script>
<script>
jQuery(function(){
var timer = setTimeout(function(){
jQuery.colorbox({innerWidth:"600px", innerHeight:"500px", iframe:false,href:"/modules/pop_register.php?s=FTNT"});
}, 1);

});

$(document).bind("cbox_complete", function(){
    var href = $.colorbox.element().attr("href");
    if (href) {
        _gaq.push(["_trackPageview", href]);
    }
});

</script>
<script type="text/javascript" async="true">
    (function(d, s, id) {
        var js, fjs = d.getElementsByTagName(s)[0];
        if (d.getElementById(id))
            return;
        js = d.createElement(s);
        js.id = id;
        js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
        fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));
</script>
<script async type="text/javascript" src="//platform.linkedin.com/in.js" async="true">

        api_key: 61zs5c03pdk4
        authorize: true

</script>

<style>
    .addthis-smartlayers{
        z-index: 0 !important;
        position: fixed !important;
    }
</style>
<script>
    
    // var def_body_width = $(".defBody").css('width').replace("px", "");
    // var window_width = $("#body").css('width').replace("px", "");
    // if ((window_width - def_body_width)/2 > 40) {
    //     (function() {
    //         var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    //         po.src = '//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56007a16c06ae30a';
    //         var s = document.getElementsByTagName('script')[0]; 
    //         s.parentNode.insertBefore(po, s);
    //       })();
    // } 

</script>
</body>
</html>
