<!doctype html>
<html data-n-head-ssr data-n-head="">
<head data-n-head="">
<title data-n-head="true">Wake Forest Bancshares, Inc. A - GuruFocus.com</title><meta data-n-head="true" charset="utf-8"><meta data-n-head="true" name="viewport" content="width=device-width, initial-scale=1"><meta data-n-head="true" data-hid="description" name="description" content="GuruFocus Article or News written by GuruFocusNews and the topic is about: "><meta data-n-head="true" data-hid="keywords" name="keywords" content="GuruFocus, Article, News, GuruFocusNews, WAKE"><meta data-n-head="true" name="twitter:card" content="summary_large_image"><meta data-n-head="true" name="twitter:site" content="@gurufocus"><meta data-n-head="true" name="twitter:creator" content="@gurufocus"><meta data-n-head="true" name="twitter:title" content="Wake Forest Bancshares, Inc. Announces Fiscal Year End Results"><meta data-n-head="true" name="twitter:description" content=""><meta data-n-head="true" name="twitter:image" content=""><meta data-n-head="true" name="og:image" content=""><link data-n-head="true" rel="icon" type="image/x-icon" href="/favicon.ico"><script data-n-head="true" src="https://www.googletagmanager.com/gtag/js?id=AW-1005049228" async="true"></script><script data-n-head="true" src="//www.googletagmanager.com/gtm.js?id=GTM-K799DP4&amp;l=dataLayer" async="true"></script><noscript data-n-head="true" data-hid="gtm-noscript" pbody="true"><iframe src="//www.googletagmanager.com/ns.html?id=GTM-K799DP4&l=dataLayer" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><link rel="stylesheet" href="/_nuxt/906ddf98eb6b183d6622.1639757565105.css"><link rel="stylesheet" href="/_nuxt/b750fcea57e4d582ae5c.1639757565105.css">
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body data-n-head="">
<div data-server-rendered="true" id="__nuxt"><div id="__layout"><div class="app-wrapper purge-css-ignore"><div class="main-container"><section class="el-container notification-bar notification-bar" data-v-5aa838bd><div role="alert" class="el-alert alert-item el-alert--error is-center is-dark" data-v-5aa838bd><div class="el-alert__content"><span class="el-alert__title"><div class="content-section" data-v-5aa838bd><span class="title-section title-section-xl" data-v-5aa838bd>Get Your 7-Day Free Trial!</span> <span class="link-section" data-v-5aa838bd><a href="https://www.gurufocus.com/membership/new/index.html#/?sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=notificaton_bar" target="_top" data-v-5aa838bd><button type="button" class="el-button el-button--info el-button--small is-round link-button link-button-xl" data-v-5aa838bd><span>
Start Now!
</span></button></a></span></div></span><i class="el-alert__closebtn el-icon-close" style="display:none;"></i></div></div></section> <div class="navbar"><div class="navbar-brand"><a href="https://www.gurufocus.com"><img src="//static.gurufocus.com/images/logo_small_new.png" alt="Logo"></a> <button type="button" class="el-button navbar-collapse-button square el-button--default el-button--mini"><span><i class="gf-icon-bars"></i></span></button></div> <div class="navbar-item navbar-right-item hidden-md-and-down"><label class="switch"><input type="checkbox"> <span class="d-slider round"></span></label></div> <div class="navbar-item">
Home
<div class="navbar-dropdown"><a target="_blank" href="https://www.gurufocus.com" class="navbar-link">
Homepage
</a><a target="_blank" href="https://www.gurufocus.com/membership.php" class="navbar-link">
Membership Levels
</a><a target="_blank" href="https://www.gurufocus.com/flarum/t/general-discussion" class="navbar-link">
General Discussion
</a><a target="_blank" href="https://www.gurufocus.com/stock_list.php" class="navbar-link">
Complete Stock List
</a><a target="_blank" href="https://www.gurufocus.com/ads/books/" class="navbar-link">
The book
</a><a href="/podcast" class="navbar-link">
Podcast
</a><a target="_blank" href="https://www.gurufocus.com/news/281207/data-coverage-of-gurufocus-premium-membership-" class="navbar-link">
Membership Data Coverage
</a><a target="_blank" href="https://www.gurufocus.com/letter.php" class="navbar-link">
Founder's Message
</a><a target="_blank" href="https://www.gurufocus.com/membership/new/index.html#/?ref=topMenu&amp;sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=topMenu" class="navbar-link">
Free Trial
</a></div></div><div class="navbar-item">
Screeners
<div class="navbar-dropdown"><div class="navbar-sub"><div class="navbar-sub-title"><a href="/screener" class="color-primary">
GuruFocus Screeners
</a></div> <a href="/screener" class="navbar-link" style="color:red;font-weight:bold;">
All-In-One Screener
   </a><a href="/screener?name=Dividend%20Income%20Portfolio&amp;id=3829" class="navbar-link">
Dividend Income Portfolio
   </a><a href="/screener?name=Ben%20Graham%20Lost%20Formula&amp;id=70" class="navbar-link">
Ben Graham Lost Formula
   </a><a href="/screener?name=Canadian%20Faster%20Growers&amp;id=73" class="navbar-link">
Canadian Faster Growers
   </a><a href="/screener?name=CEO%20Buys&amp;id=74" class="navbar-link">
CEO Buys
   </a><a href="/screener?name=CEO%20Buys%20after%20Price%20Drop%20%3E%2020%25&amp;id=75" class="navbar-link">
CEO Buys after Price Drop &gt; 20%
   </a><a href="/screener?name=Dividend%20Growth%20Portfolio&amp;id=77" class="navbar-link">
Dividend Growth Portfolio
   </a><a href="/screener?name=Dividend%20Income%20Portfolio&amp;id=78" class="navbar-link">
Dividend Income Portfolio
   </a><a href="/screener?name=Fast%20Growers&amp;id=79" class="navbar-link">
Fast Growers
   </a><a href="/screener?name=Hedge%20Fund%20Guru%20Top%2010%20Aggregated&amp;id=80" class="navbar-link">
Hedge Fund Guru Top 10 Aggregated
   </a><a href="/screener?name=High%20Quality&amp;id=81" class="navbar-link">
High Quality
   </a><a href="/screener?name=High%20Quality%20Low%20Capex%20w%20ROE%20ROC%20min&amp;id=84" class="navbar-link">
High Quality Low Capex w ROE ROC min
   </a><a href="/screener?name=High%20Quality%20&amp;%20Low%20Capex&amp;id=87" class="navbar-link">
High Quality &amp; Low Capex
   </a><a href="/screener?name=High%20Yield%20Insider%20Buys&amp;id=88" class="navbar-link">
High Yield Insider Buys
   </a><a href="/screener?name=Historical%20High%20Dividend%20Yields&amp;id=89" class="navbar-link">
Historical High Dividend Yields
   </a><a href="/screener?name=International%20Gurus%27%20Top%20Holdings&amp;id=90" class="navbar-link">
International Gurus' Top Holdings
   </a><a href="/screener?name=James%20Montier%20Short%20Screen&amp;id=91" class="navbar-link">
James Montier Short Screen
   </a><a href="/screener?name=Margin%20Decliners&amp;id=92" class="navbar-link">
Margin Decliners
   </a><a href="/screener?name=Mega%20Caps&amp;id=93" class="navbar-link">
Mega Caps
   </a><a href="/screener?name=Peter%20Lynch%20&amp;%20Warren%20Buffett&amp;id=94" class="navbar-link">
Peter Lynch &amp; Warren Buffett
   </a><a href="/screener?name=Peter%20Lynch%20Growth%20w%20Lower%20Valuation&amp;id=95" class="navbar-link">
Peter Lynch Growth w Lower Valuation
   </a><a href="/screener?name=Peter%20Lynch%20S&amp;L%20Traded%20Below%20Book&amp;id=96" class="navbar-link">
Peter Lynch S&amp;L Traded Below Book
   </a><a href="/screener?name=PFCF%20Screener&amp;id=97" class="navbar-link">
PFCF Screener
   </a><a href="/screener?name=Piotroski%20Score%20Screener&amp;id=98" class="navbar-link">
Piotroski Score Screener
   </a><a href="/screener?name=Predictable%20Companies&amp;id=99" class="navbar-link">
Predictable Growth Companies
   </a><a href="/screener?name=Profitable%20predictable%20margin%20expanders&amp;id=100" class="navbar-link">
Profitable predictable margin expanders
   </a><a href="/screener?name=Stocks%20Sold%20w%20less%20Cash&amp;id=102" class="navbar-link">
Stocks Sold w less Cash
   </a><a href="/screener?name=Good%20Companies&amp;id=103" class="navbar-link">
Good Companies
   </a><a href="/screener?name=The%20Stalwarts&amp;id=104" class="navbar-link">
The Stalwarts
   </a></div><div class="navbar-sub"><div class="navbar-sub-title"><a href="/screener?manage=screen" class="color-primary">
My Screeners
</a></div> <a href="/screener" class="navbar-link">
Create My Screener
   </a></div><div class="navbar-sub"><div class="navbar-sub-title"><a href="/screener/buffett-munger" class="color-primary">
Value Screens
</a></div> <a href="/screener" class="navbar-link" style="color:red;font-weight:bold;">
All-In-One Screener
   </a><a href="/screener?view=map&amp;show_header=false" class="navbar-link">
S&amp;P 500 Map
   </a><a href="/screener?view=bubble&amp;show_header=false" class="navbar-link">
S&amp;P 500 Bubble
   </a><a href="/screener?view=aggregate&amp;show_header=false" class="navbar-link">
S&amp;P 500 Aggregate
   </a><a href="/screener/buffett-munger" class="navbar-link">
Buffett-Munger Screener
   </a><a target="_blank" href="https://www.gurufocus.com/industry_overview.php?region=USA" class="navbar-link">
Industry Overview
</a><a href="/screener/valuedcf" class="navbar-link">
Undervalued Predictable
   </a><a href="/screener/grahamncav" class="navbar-link">
Benjamin Graham Net-Net
   </a><a href="/screener/52weeklow" class="navbar-link">
52-week/3Y/5Y Lows
   </a><a href="/screener/52weekhigh" class="navbar-link">
52-week/3Y/5Y Highs
   </a><a href="/screener/magic-formula" class="navbar-link">
Magic Formula(Greenblatt)
   </a><a href="/screener/dividend-stocks" class="navbar-link">
Dividend Stocks
   </a><a href="/screener/peter-lynch-stocks" class="navbar-link">
Peter Lynch Screen
   </a><a href="/screener/guru-sp-grid" class="navbar-link">
S&amp;P500 Grid
   </a><a href="/screener/predictable" class="navbar-link">
Predictable Companies
   </a><a href="/screener/spinoff" class="navbar-link">
Spin Off List
   </a><a href="/screener/lowpb" class="navbar-link">
Historical Low P/B List
   </a><a href="/screener/lowps" class="navbar-link">
Historical Low P/S List
   </a><a href="/screener/short-stocks" class="navbar-link">
High Short Interest
   </a><a href="/screener/upcoming-special-dividends" class="navbar-link">
Upcoming Special Dividends
   </a><a href="/screener/delisted" class="navbar-link">
Delisted Stocks
   </a><div class="navbar-sub-title">
Model Portfolios
</div><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php" class="navbar-link">
Performances
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=smallcap" class="navbar-link">
Undervalued Predictable
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=midcap" class="navbar-link">
Buffett-Munger
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=cap40" class="navbar-link">
Low P/S
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=lowpb" class="navbar-link">
Low P/B
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=cap20" class="navbar-link">
52w Low Predictable
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=largecap" class="navbar-link">
Broadest Owned
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=hr_largecap" class="navbar-link">
Most Weighted
</a></div></div></div><div class="navbar-item">
Gurus
<div class="navbar-dropdown"><div class="navbar-sub"> <a href="/guru/latest-picks" class="navbar-link">
Latest Guru Picks
   </a><a href="/guru/list" class="navbar-link">
List of Gurus
   </a><a href="/guru/realtime-picks" class="navbar-link">
Real Time Picks
   </a><a href="/guru/portfolio" class="navbar-link">
Guru Portfolio
   </a><a href="/guru/top-holdings" class="navbar-link">
Top 10 Holdings View
   </a><a href="/guru/bargains" class="navbar-link">
Guru Bargains
   </a><a href="/guru/hot-picks" class="navbar-link">
Hot Picks
   </a><a href="/guru/aggregated-portfolio" class="navbar-link">
Aggregated Portfolio
   </a><a href="/guru/consensus-picks" class="navbar-link">
Consensus Picks
   </a><a href="/guru/etfs" class="navbar-link">
ETFS
   </a><a href="/guru/scoreboard" class="navbar-link">
Score Board
   </a><a href="/guru/sector-picks" class="navbar-link">
Sector Picks
   </a><a href="/guru/international-picks" class="navbar-link">
International Picks
   </a><a href="/guru/industry-trends" class="navbar-link">
Industry Trends
   </a><a href="/guru/geographic-trends" class="navbar-link">
Geographic Trend
   </a><a href="/guru/option-holdings" class="navbar-link">
Options
   </a><a href="/guru/european-shortings" class="navbar-link">
European Shorting
   </a></div><div class="navbar-sub"> <a href="/guru/warren+buffett/summary" class="navbar-link">
Warren Buffett
   </a><a href="/guru/bill+gates/summary" class="navbar-link">
Bill Gates
   </a><a href="/guru/mohnish+pabrai/summary" class="navbar-link">
Mohnish Pabrai
   </a><a href="/guru/carl+icahn/summary" class="navbar-link">
Carl Icahn
   </a><a href="/guru/george+soros/summary" class="navbar-link">
George Soros
   </a><a href="/guru/david+tepper/summary" class="navbar-link">
David Tepper
   </a><a href="/guru/seth+klarman/summary" class="navbar-link">
Seth Klarman
   </a><a href="/guru/bill+ackman/summary" class="navbar-link">
Bill Ackman
   </a><a href="/guru/joel+greenblatt/summary" class="navbar-link">
Joel Greenblatt
   </a><a href="/guru/charlie+munger/summary" class="navbar-link">
Charlie Munger
   </a></div></div></div><div class="navbar-item">
Insiders
<div class="navbar-dropdown"><a href="/insider/summary" class="navbar-link">
All Insiders
</a><a href="/insider/ceo" class="navbar-link">
CEO Buys/Sells
</a><a href="/insider/trend" class="navbar-link">
Insider Trends
</a><a href="/insider/cluster" class="navbar-link">
Insider Cluster
</a><a href="/insider/cfo" class="navbar-link">
CFO Buys/Sells
</a><a href="/insider/double" class="navbar-link">
Guru + Insider Double Buys
</a><a href="/insider/triple" class="navbar-link">
Triple buys/Sells
</a><a href="/insider/canadian" class="navbar-link">
Canadian Insider
</a><a href="/insider/dutch" class="navbar-link">
Dutch Insider
</a></div></div><div class="navbar-item">
Market
<div class="navbar-dropdown"><div class="navbar-sub"><div class="navbar-sub-title"><a href="/stock-market-valuations.php" class="color-primary">
Market Valuation
</a></div> <a target="_blank" href="https://www.gurufocus.com/stock-market-valuations.php" class="navbar-link">
Buffett Indicator
</a><a target="_blank" href="https://www.gurufocus.com/industry_overview.php?region=USA" class="navbar-link">
Industry Overview
</a><a target="_blank" href="https://www.gurufocus.com/yield_curve.php" class="navbar-link">
U.S. Treasury Yield Curve
</a><a target="_blank" href="https://www.gurufocus.com/shiller-PE.php" class="navbar-link">
Shiller P/E
</a><a target="_blank" href="https://www.gurufocus.com/global-market-valuation.php" class="navbar-link">
Global Market Valuations
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/58/sp-500-earnings" class="navbar-link">
Economic Data
</a><a target="_blank" href="https://www.gurufocus.com/sector_shiller_pe.php" class="navbar-link">
Shiller P/E by Sectors
</a><a target="_blank" href="https://www.gurufocus.com/buffett_assets_allocations.php" class="navbar-link">
Buffett Assets Allocation
</a><a href="/market/sp500-gf-value" class="navbar-link">
GF Value for SP500 Index
   </a></div><div class="navbar-sub"><div class="navbar-sub-title"><a href="/economic_indicators/58/sp-500-earnings" class="color-primary">
Economic Indicators
</a></div> <a target="_blank" href="https://www.gurufocus.com/economic_indicators/229/the-dow-jones-industrial-average-djia" class="navbar-link">
The Dow Jones Industrial Average (DJIA)
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/63/sp-500-index" class="navbar-link">
SP 500 Index
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/232/nasdaq-composite-index" class="navbar-link">
Nasdaq Composite Index
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/20/gross-domestic-product-gdp" class="navbar-link">
Gross Domestic Product (GDP)
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/56/shiller-pe" class="navbar-link">
Shiller PE
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/60/ratio-of-wilshire-5000-over-gnp" class="navbar-link">
Ratio of Wilshire 5000 over GNP
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/10/civilian-unemployment-rate" class="navbar-link">
Civilian Unemployment Rate
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/231/russell-2000-small-cap-price-index" class="navbar-link">
Russell 2000 Small Cap Price Index
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/234/cboe-volatility-index-the-vix" class="navbar-link">
CBOE Volatility Index (VIX)
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/14/total-nonfarm-payrolls-all-employees" class="navbar-link">
Total Nonfarm Payrolls: All Employees
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/58/sp-500-earnings" class="navbar-link">
More...
</a></div><div class="navbar-sub"><div class="navbar-sub-title"><a href="/global-market-valuation.php" class="color-primary">
By Country
</a></div> <a target="_blank" href="https://www.gurufocus.com/stock-market-valuations.php" class="navbar-link">
USA
</a><a target="_blank" href="https://www.gurufocus.com/global-market-valuation.php?country=IND" class="navbar-link">
India
</a><a target="_blank" href="https://www.gurufocus.com/global-market-valuation.php?country=CHN" class="navbar-link">
China
</a><a target="_blank" href="https://www.gurufocus.com/global-market-valuation.php" class="navbar-link">
More
</a></div></div></div><div class="navbar-item">
Articles
<div class="navbar-dropdown"><div class="navbar-sub"><div class="navbar-sub-title"><a href="/news" class="color-primary">
Articles
</a></div> <a href="/news?cat=timeless" class="navbar-link">
Editors' Picks
   </a><a href="/news?cat=qa" class="navbar-link">
Q&amp;A with Gurus
   </a><a href="/news?cat=rank" class="navbar-link">
Top Ranked
   </a><a href="/news?cat=guru" class="navbar-link">
News
   </a><a href="/news?cat=contest" class="navbar-link">
 Value Idea Contest
   </a></div><div class="navbar-sub"><div class="navbar-sub-title"><a href="/news/post" class="color-primary">
Submit Articles
</a></div> <a href="/news/post" class="navbar-link">
Submit Article Online
   </a><a target="_blank" href="https://www.gurufocus.com/news/70028" class="navbar-link">
Writers Wanted
</a></div></div></div><div class="navbar-item">
Tools
<div class="navbar-dropdown"><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php" class="navbar-link">
Model Portfolios
</a><a href="/screener" class="navbar-link">
All-In-One Screener
</a><a target="_blank" href="https://www.gurufocus.com/download_financials_batch.php" class="navbar-link">
Data Batch Download
</a><a href="/guru/download-guru-portfolio" class="navbar-link">
Guru Portfolio Download
</a><a href="/insider/data-export" class="navbar-link">
Insider Data Download
</a><a target="_blank" href="https://www.gurufocus.com/excel_Add_in.php" class="navbar-link">
Excel Add-In
</a><a target="_blank" href="https://www.gurufocus.com/api.php" class="navbar-link">
API
</a><a target="_blank" href="https://www.gurufocus.com/download_stockmanual.php" class="navbar-link">
Manual of Stocks
</a><a href="/stock/AAPL/dcf" class="navbar-link">
DCF Calculator
</a><a href="/stock/AAPL/chart" class="navbar-link">
Interactive Chart
</a><a href="/screener?view=map&amp;show_header=false" class="navbar-link">
Maps
</a><a href="/fund-letters" class="navbar-link">
Fund Letters Archive
</a><a href="/compare-table?tab=current-analysis" class="navbar-link">
Stock Comparison Table
</a><a target="_blank" href="https://www.gurufocus.com/app.php" class="navbar-link">
Mobile App
</a><a href="/discussion" class="navbar-link">
Discussion Board
</a></div></div><div class="navbar-item navbar-right-item">
Tutorials
<div class="navbar-dropdown"><a target="_blank" href="https://www.gurufocus.com/tutorials.php" class="navbar-link">
Tutorials &amp; Webinars
</a><a target="_blank" href="https://www.gurufocus.com/faq.php" class="navbar-link">
FAQ
</a><a href="/changelog" class="navbar-link">
Change Log
</a><a target="_blank" href="https://www.gurufocus.com/ticket/open.php" class="navbar-link">
Contact Us
</a></div></div><div class="navbar-item navbar-right-item">
Support
<div class="navbar-dropdown"><span data-name="Support" slot="reference"><span class="navbar-link nuxt-link-exact-active nuxt-link-active"> Chat Support</span> <div id="phplive_btn_1570480208"></div></span><a target="_blank" href="https://www.gurufocus.com/ticket/open.php" class="navbar-link">
Create a ticket
</a></div></div> <div class="navbar-item navbar-right-item"><a href="/login?ref=%2Fnews%2F1599007%2Fwake-forest-bancshares-inc-announces-fiscal-year-end-results">
Login
</a></div> <div class="navbar-item navbar-right-item" data-v-13ff247e><a href="https://www.gurufocus.com/membership/new/index.html#/?sel=premium&utm_source=webApp&utm_medium=userClick&utm_campaign=new_navbar_free_trial" data-v-13ff247e><span class="basic-navbar-title" data-v-13ff247e>
Get 7-Day Free Trial
</span></a> <div class="navbar-dropdown" data-v-13ff247e><a href="https://www.gurufocus.com/membership/new/index.html#/?sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=new_navbar_free_trial_item" class="navbar-link" data-v-13ff247e>
Free Trial ($449/year)
</a><a href="https://www.gurufocus.com/user_referrals.php" class="navbar-link" data-v-13ff247e>
Refer a Friend and Earn $50
</a></div></div> </div> <div style="height:34px;" data-v-21ff3b94></div> <section class="el-container"><main id="components-root" class="el-main auto-height-on-print capture-areaz" style="height:calc(100vh - 76px - 0px);"><section class="el-container is-vertical" data-v-9bf8d8a8><main class="el-main center" data-v-9bf8d8a8><div frame="frame-xl" class="center" style="padding-bottom:40px;" data-v-a48afad4 data-v-9bf8d8a8><div class="ad-image-container" data-v-e996ce08 data-v-a48afad4><img src="https://static.gurufocus.com/ads/horizontal_ads.jpeg" alt="Get Premium to unlock powerful stock data" data-v-e996ce08></div> <div class="el-row" style="margin-left:-20px;margin-right:-20px;" data-v-a48afad4><div id="article-main-section-1599007" class="el-col el-col-16" style="padding-left:20px;padding-right:20px;" data-v-a48afad4><h1 class="fc-primary fw-bolder subject" data-v-a48afad4> Wake Forest Bancshares, Inc. Announces Fiscal Year End Results
  </h1>   <div class="author-item row-padding" data-v-757b447a data-v-a48afad4><div class="el-row" style="margin-left:-10px;margin-right:-10px;" data-v-757b447a><div class="el-col el-col-12" style="padding-left:10px;padding-right:10px;" data-v-757b447a><a href="/user/undefined" class="link left avatar" style="padding-right:10px;" data-v-757b447a><img alt="Author's Avatar" height="50px" width="50px" src="https://ui-avatars.com/api/?length=2&amp;background=random&amp;name=User" style="vertical-align:middle;border-radius:10px;object-fit:scale-down;" data-v-757b447a></a> <div class="left" style="margin-top:-3px;" data-v-757b447a><a href="/user/undefined" class="link" style="padding-right:20px;" data-v-757b447a><span data-v-757b447a> GuruFocusNews </span></a> <button type="button" class="el-button el-button--success el-button--mini  follow-button" data-v-757b447a><span>Follow</span></button> <div class="date" style="padding-top:5px;" data-v-757b447a><span data-v-757b447a> 2 minutes ago </span> <span style="padding-left:20px;font-size:20px;" data-v-757b447a><span data-v-3e8f237c data-v-757b447a><i class="el-icon-collection" style="cursor: pointer;" data-v-3e8f237c></i> <div class="el-dialog__wrapper" style="display:none;" data-v-3e8f237c><div role="dialog" aria-modal="true" aria-label="Bookmark" class="el-dialog" style="margin-top:15vh;"><div class="el-dialog__header"><span class="el-dialog__title">Bookmark</span><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><div class="el-dialog__footer"><span class="dialog-footer" data-v-3e8f237c><button type="button" class="el-button el-button--default el-button--mini" data-v-3e8f237c><span>Cancel</span></button> <button type="button" class="el-button el-button--primary el-button--mini" data-v-3e8f237c><span>Confirm</span></button></span></div></div></div></span> <span class="share-button" data-v-2a4e46c8 data-v-757b447a><div role="tooltip" id="el-popover-6781" aria-hidden="true" class="el-popover el-popper aio-popover no-padding" style="width:undefinedpx;display:none;"></div><span data-name="" class="  " data-v-2a4e46c8><i class="gf-icon-share hover-pointer" data-v-2a4e46c8></i></span></span> <i class="gf-icon-printer cursor-pointer" style="margin-left:10px;" data-v-757b447a></i></span></div></div></div> <div class="el-col el-col-12" style="padding-left:10px;padding-right:10px;" data-v-757b447a><div class="stock-competitor row-padding" data-v-8abc14ca data-v-757b447a> <span class="aio-popover no-padding" data-v-8abc14ca><div role="tooltip" id="el-popover-3053" aria-hidden="true" class="el-popover el-popper" style="width:undefinedpx;display:none;"></div></span></div></div></div></div>  <img alt="Article's Main Image" width="100%" src="" style="max-height:600px;display:block;margin:auto;padding-bottom:10px;object-fit:contain;" data-v-a48afad4> <div id="article-body-1599007" class="main-body" data-v-a48afad4><div class="mw_release"><p>WAKE FOREST, N.C., Dec. 17, 2021 (GLOBE NEWSWIRE) -- Wake Forest Bancshares, Inc., ( WAKE) parent company of Wake Forest Federal Savings and Loan Association, announced today that the Company reported earnings of $1,235,550 or $1.13 per share for its fiscal year ended September 30, 2021. The Company’s earnings for the prior fiscal year were $1,170,850 or $1.06 per share. Earnings for the current quarter were reported at $325,400 or $0.30 per share versus $268,550 or $0.24 per share for the quarter ended September 30, 2020.<br></p> <p>Renee H. Shaw, President and Chief Executive Officer, stated that the Company’s earnings were reflective of improving conditions associated with the re-opening of our economies from COVID 19 pandemic restrictions. The Company’s fiscal year results exceeded expectations and budgetary amounts established at the beginning of its fiscal year, particularly in light of the Federal Reserve Board’s policies that have maintained short term interest rates at historically low levels, a decision initiated in March of 2020 at the start of the Pandemic. As a result, the Company’s overall interest rate margin was 3.06% for its current fiscal year, down from its 3.23% margin during the height of the Pandemic a year earlier and significantly less than the 3.69% margin in 2019 prior to the Fed’s actions to significantly lower interest rates to support the weakened economy caused by COVID 19.</p> <p>While economic conditions continue to show steady if slowing improvement, residential home sales in our local markets have remained robust throughout the Pandemic. Our lending environment benefits because we are a part of the Research Triangle area which is generally recognized as one of the top regions in the country for innovation, growth, economic activity and quality of life factors. Our real estate markets have remained strong during the past year not only due to historically low mortgage rates, but also because of housing demand coupled with sizable gains in home prices and extremely tight residential inventories.</p> <p>The Company’s loan portfolio has grown slightly from the level outstanding a year ago. The Company has been pleased with its lending performance during the Pandemic, particularly since the size of the Company’s loan portfolio was never distorted by any short term PPP loans. In addition, the credit quality of our loan portfolio has been resilient, perhaps because widespread financial assistance in the form of stimulus payments, low interest government supported loans, and enhanced unemployment insurance payments have concealed the potential longer term effects of the Pandemic. During the spring of 2020 the Company provided loan modifications to certain borrowers adversely and directly impacted by the Pandemic but all of these modified loans returned to scheduled payment status in September 2020, and as of September 30, 2021 no additional modifications have been granted. The Company was delighted that it had no reportable problem assets or loan charge-offs during the current year. As a result, no additional loan loss provisions were considered necessary because of the healthy level of our existing loss allowances. The Company’s loan loss allowance amounted to approximately 2.07% of total loans outstanding at September 30, 2021. The Company will continue to evaluate whether any lingering effects from the Pandemic impact our credit quality and consider future adjustments to its loss allowances as necessary.</p> <p>Total assets of the Company amounted to $110,479,350 at September 30, 2021. Total loans receivable and deposits outstanding at September 30, 2021 amounted to $69,672,000 and $82,733,550, respectively. Wake Forest Bancshares Inc.’s tier 1 capital leverage ratio was 24.00% at September 30, 2021. Wake Forest Bancshares, Inc. has 1,070,046 shares of common stock outstanding. Based in Wake Forest, North Carolina since 1922, the Company conducts business as Wake Forest Federal from its office in Wake Forest, (Wake County), North Carolina.</p> <p><strong>Contact: Renee H. Shaw, CEO</strong><br><strong>(919) 556-5146</strong></p> <img src="https://www.globenewswire.com/newsroom/ti?nf=ODQxNDIyMiM0NjIwNTgyIzIwMTkwOTY=" alt="ti?nf=ODQxNDIyMiM0NjIwNTgyIzIwMTkwOTY=" class="__GNW8366DE3E__IMG"> <br><img src="https://ml.globenewswire.com/media/Zjk2MGEyNjQtZDBhYi00NDYwLThiNTMtM2UzMmU0ZjliM2EyLTEwMzA2Njk=/tiny/Wake-Forest-Bancshares-Inc-.png" alt="Wake-Forest-Bancshares-Inc-.png"></div></div> <div class="main-body row-padding" data-v-a48afad4>
Not a Premium Member of GuruFocus? Sign up for a <a href="https://www.gurufocus.com/membership/renew.php" class="color-primary-blue" data-v-a48afad4>free 7-day trial here</a>.
</div>  <div style="padding-top:20px;padding-bottom:30px;font-size:18px;" data-v-a48afad4><span data-v-a48afad4><span data-v-a48afad4>Rating: </span> <div role="slider" aria-valuenow="0" aria-valuetext="" aria-valuemin="0" aria-valuemax="5" tabindex="0" class="el-rate my_rating" data-v-a48afad4><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span></div> <span class="fw-bolder" data-v-a48afad4>NaN</span> <span data-v-a48afad4>/ 5 ( votes)</span></span></div> <div id="article-view-1599007" style="height:1px;" data-v-a48afad4></div>  <lazy-component style="min-height:200px;" data-v-a48afad4><div class="el-card article-comment is-never-shadow" data-v-593f497d data-v-34067612 data-v-a48afad4>  <h3 class="gf-regular row-padding-top row-padding" data-v-593f497d data-v-34067612>Please <a href="https://www.gurufocus.com/forum/login.php?0" class="color-primary" data-v-593f497d data-v-34067612>Login</a> to leave a comment</h3>  <div class="row-padding" data-v-593f497d data-v-34067612><div class="row-padding login-input el-textarea el-input--mini" data-v-34067612><textarea autocomplete="off" id="login-input" placeholder="Please Login to Leave a Comment" rows="4" class="el-textarea__inner"></textarea></div> <div class="row-padding-top" data-v-593f497d data-v-34067612>  </div></div></div></lazy-component> <lazy-component style="min-height:200px;" data-v-a48afad4><div style="padding-top:30px;" data-v-cb5fc40e data-v-a48afad4><span data-v-cb5fc40e><a href="/user/0" class="link" style="float:left;padding-right:10px;" data-v-cb5fc40e><img alt="Author's Avatar" height="100px" width="100px" src="https://ui-avatars.com/api/?length=2&amp;background=random&amp;name=User" style="vertical-align:middle;border-radius:10px;object-fit:scale-down;" data-v-cb5fc40e></a> <div class="el-row" style="min-height:100px;" data-v-cb5fc40e><div data-v-cb5fc40e><a href="/user/undefined" class="link" data-v-cb5fc40e><h3 class="fc-primary fw-bolder inline row-padding" data-v-cb5fc40e> GuruFocusNews </h3></a> <button type="button" class="el-button el-button--success el-button--mini" data-v-cb5fc40e><span>Follow</span></button></div> <div class="author-desc" data-v-cb5fc40e></div></div> </span> <br data-v-cb5fc40e>  </div></lazy-component></div> <div class="el-col el-col-8" style="padding-left:20px;padding-right:20px;" data-v-a48afad4><div style="margin-top:20px;" data-v-81555b70 data-v-a48afad4 data-v-a48afad4><div class="section-padding el-row" style="margin-left:-2.5px;margin-right:-2.5px;" data-v-81555b70><div class="el-col el-col-12" style="padding-left:2.5px;padding-right:2.5px;" data-v-81555b70><a href="https://www.gurufocus.com/news.php?id=70028" class="el-button el-button--primary" style="width:160px;font-size:14px;" data-v-81555b70>Write for GuruFocus</a></div> <div class="el-col el-col-12" style="padding-left:2.5px;padding-right:2.5px;" data-v-81555b70><a href="/news/post" class="el-button el-button--primary" style="width:160px;font-size:14px;" data-v-81555b70>Submit an article</a></div></div> <a href="https://www.gurufocus.com/tutorials.php" class="link section-padding" data-v-81555b70> How to use GuruFocus - Tutorials </a><a href="https://www.gurufocus.com/membership.php" class="link section-padding" data-v-81555b70> What Is in the GuruFocus Premium Membership? </a><a href="https://www.gurufocus.com/Invest_guide_guru.php" class="link section-padding" data-v-81555b70> A DIY Guide on How to Invest Using Guru Strategies </a><a href="https://www.gurufocus.com/changelog" class="link section-padding" data-v-81555b70> GuruFocus New Features </a> <Adsense data-ad-client="ca-pub-4020868656364652" ins-style="display:inline-block;width:380px;height:300px" data-ad-slot="8601925817" data-v-81555b70></Adsense>        <hr class="solid" data-v-81555b70> <h3 class="fs-large fc-primary fw-bolder inline row-padding" data-v-81555b70>
GuruFocus Screeners
</h3> <div class="screener-part" data-v-81555b70></div> <hr class="solid" data-v-81555b70> <h3 class="fs-large fc-primary fw-bolder inline row-padding" data-v-81555b70>
Related Articles
</h3>  <a href="/news?cat=qa" class="fs-large fc-primary fw-bolder section-padding padding-top" style="display:block;" data-v-81555b70> Q&amp;A with Gurus </a> <div class="section-padding" style="min-height:60px;" data-v-81555b70></div></div></div></div> <hr class="thin" data-v-a48afad4></div>  <div id="article-bottom" class="row-padding" style="height:1px;" data-v-9bf8d8a8></div></main> <div id="myModal" class="modal" data-v-9bf8d8a8><img id="modalImg" class="modal-content" data-v-9bf8d8a8> <div id="modalCaption" data-v-9bf8d8a8></div></div> <footer class="el-footer" style="height:60px;" data-v-9bf8d8a8></footer></section></main> </section> <div closeable="true" class="el-dialog__wrapper" style="display:none;z-index:100000;" data-v-6cb47dd4><div role="dialog" aria-modal="true" aria-label="dialog" class="el-dialog" style="margin-top:10%;width:580px;"><div class="el-dialog__header"><div id="title-empty" style="height:0;padding:0;margin:0;" data-v-6cb47dd4></div><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div></div></div></div>  <div class="el-dialog__wrapper" style="display:none;" data-v-09ddfdbe><div role="dialog" aria-modal="true" aria-label="dialog" class="el-dialog" style="margin-top:15vh;"><div class="el-dialog__header"><div id="title-empty" style="height:0;padding:0;margin:0;" data-v-09ddfdbe></div><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><div class="el-dialog__footer"><div class="footer-section" data-v-09ddfdbe><button type="button" class="el-button button-item el-button--default el-button--mini" data-v-09ddfdbe><span>Cancel</span></button> <button type="button" class="el-button button-item el-button--primary el-button--mini" data-v-09ddfdbe><span>Confirm</span></button></div></div></div></div></div></div></div><script>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</script><script src="/_nuxt/f187784fdccdb251a930.1639757563780.js" defer></script><script src="/_nuxt/4a9d7b887e6364249e87.1639757563780.js" defer></script><script src="/_nuxt/09ecc3c23dfeda23672e.1639757563780.js" defer></script><script src="/_nuxt/381f900da3fd6a19dbd5.1639757563780.js" defer></script><script src="/_nuxt/6749e3ed8e903012b5c4.1639757563780.js" defer></script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'6bf2336ad95e4438',m:'5haER8EyAof2q5SiXkN9nh6OP7Tp5bkrsotCUe9S8cE-1639765598-0-ARByHA3UbJJgC8z2dTkjU+mIhitI6flPvDlfbRMKWE9V73uVEAeviHqibZfn6eKVZ7I465yxnBn7CMB0wkO1CB6aU39RJiRU8gsUEAKbooCwOIk+TGVHz0vI+YuY1zTcaqlCXPk6tXJf4MolbNTNO/ZHLW54dHkXY5K8b4XhuuavYuO6zCmqORGWLiCr0WfslU9CnwfU1obIEMgvHW9rV2w=',s:[0xc12f813811,0x22256e4c62],}})();</script></body>
</html>
