<!doctype html>
<html data-n-head-ssr data-n-head="">
<head data-n-head="">
<title data-n-head="true">Thinking about buying stock in - GuruFocus.com</title><meta data-n-head="true" charset="utf-8"><meta data-n-head="true" name="viewport" content="width=device-width, initial-scale=1"><meta data-n-head="true" data-hid="description" name="description" content="GuruFocus Article or News written by PRNewswire and the topic is about: "><meta data-n-head="true" data-hid="keywords" name="keywords" content="GuruFocus, Article, News, PRNewswire, NAS:CTXR,NAS:ARRY,NAS:BTAI,NAS:CLVS,NAS:GOGO"><meta data-n-head="true" name="twitter:card" content="summary_large_image"><meta data-n-head="true" name="twitter:site" content="@gurufocus"><meta data-n-head="true" name="twitter:creator" content="@gurufocus"><meta data-n-head="true" name="twitter:title" content="Thinking about buying stock in Citius Pharmaceuticals, BioXcel Therapeutics, Array Technologies, Gogo, or Clovis Oncology?"><meta data-n-head="true" name="twitter:description" content=""><meta data-n-head="true" name="twitter:image" content=""><meta data-n-head="true" name="og:image" content=""><link data-n-head="true" rel="icon" type="image/x-icon" href="/favicon.ico"><link data-n-head="true" rel="stylesheet" href="https://static.gurufocus.com/fonts/Eudoxus-Sans.css"><link data-n-head="true" rel="stylesheet" href="https://fonts.cdnfonts.com/css/inter?styles=29139,29137,29128"><link data-n-head="true" rel="canonical" href="https://www.gurufocus.com/news/1679946/thinking-about-buying-stock-in-citius-pharmaceuticals-bioxcel-therapeutics-array-technologies-gogo-or-clovis-oncology"><script data-n-head="true" src="https://www.googletagmanager.com/gtag/js?id=AW-1005049228" async="true"></script><script data-n-head="true" src="//www.googletagmanager.com/gtm.js?id=GTM-K799DP4&amp;l=dataLayer" async="true"></script><noscript data-n-head="true" data-hid="gtm-noscript" pbody="true"><iframe src="//www.googletagmanager.com/ns.html?id=GTM-K799DP4&l=dataLayer" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><link rel="stylesheet" href="/_nuxt/a8a49b24a2f2b85f4ff5.1649197357798.css"><link rel="stylesheet" href="/_nuxt/686879be5a85b3ad86c2.1649197357798.css">
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body data-n-head="">
<div data-server-rendered="true" id="__nuxt"><div id="__layout"><div class="app-wrapper purge-css-ignore"><div class="main-container"><section id="notification-bar" class="el-container notification-bar notification-bar" data-v-7ab86896><div center="" class="alert-item" data-v-7ab86896><a href="https://www.gurufocus.com/membership/new/index.html#/?sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=notificaton_bar" target="_top" data-v-7ab86896><div slot="title" class="content-section" data-v-7ab86896> <span class="fc-white title-section title-section-xl" data-v-7ab86896> Get Your 7-Day Free Trial!</span> <span class="link-section" data-v-7ab86896><a href="https://www.gurufocus.com/membership/new/index.html#/?sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=notificaton_bar" target="_top" class="fc-white-i link-button link-button-xl" data-v-7ab86896>
Start Now!
</a></span>  <span class="cursor-pointer close-class" data-v-7ab86896><i class="gf-icon-close fc-white close-icon" data-v-7ab86896></i></span></div></a></div></section> <div id="navbar" client-width="1200" style="background-color:#195DAA;display:flex;justify-content:center;align-items:center;" data-v-27a12231><div class="navbar" data-v-27a12231><div class="navbar-brand" data-v-27a12231><a href="/" data-v-27a12231><img with="80" src="https://static.gurufocus.com/images/logo_header2.png" alt="Logo" style="margin-top: -6px;" data-v-27a12231></a> <button type="button" class="el-button navbar-collapse-button square el-button--default el-button--mini" data-v-27a12231><span><i class="gf-icon-bars" data-v-27a12231></i></span></button></div> <div class="navbar-item navbar-right-item" style="padding: 12px 8px !important;" data-v-27a12231><a href="/login" data-v-27a12231><button type="button" class="el-button el-button--default el-button--small" style="background:white;color:#195DAA;" data-v-27a12231><span> Login </span></button></a></div> <div class="navbar-item" data-v-27a12231><span style="line-height: 24px;" data-v-27a12231><span data-v-27a12231>Home </span> <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-27a12231></i></span> <div class="navbar-dropdown" data-v-27a12231><a href="/" class="navbar-link" data-v-27a12231>
Homepage
</a><a href="https://www.gurufocus.com/membership.php" class="navbar-link" data-v-27a12231>
Membership Levels
</a><a href="/discussion" class="navbar-link" data-v-27a12231>
General Discussion
</a><a href="https://www.gurufocus.com/stock_list.php" class="navbar-link" data-v-27a12231>
Complete Stock List
</a><a href="https://www.gurufocus.com/ads/books/" class="navbar-link" data-v-27a12231>
The book
</a><a href="https://open.spotify.com/show/7cIRp3PmnEaqEcAXHU3z9u" class="navbar-link" data-v-27a12231>
Podcast
</a><a href="https://www.gurufocus.com/news/281207/data-coverage-of-gurufocus-premium-membership-" class="navbar-link" data-v-27a12231>
Membership Data Coverage
</a><a href="https://www.gurufocus.com/letter.php" class="navbar-link" data-v-27a12231>
Founder's Message
</a><a href="https://www.gurufocus.com/membership/new/index.html#/?ref=topMenu&amp;sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=topMenu" class="navbar-link" data-v-27a12231>
Free Trial
</a></div></div><div class="navbar-item" data-v-27a12231><span style="line-height: 24px;" data-v-27a12231><span data-v-27a12231>Screeners </span> <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-27a12231></i></span> <div class="navbar-dropdown" data-v-27a12231><div class="navbar-sub" data-v-27a12231><div class="navbar-sub-title" data-v-27a12231><a href="/screener" class="color-primary" data-v-27a12231>
GuruFocus Screeners
</a></div> <a href="/screener" class="navbar-link" style="color:red;font-weight:bold;" data-v-27a12231>
All-In-One Screener
   </a><a href="/screener?name=Dividend%20Income%20Portfolio&amp;id=3829" class="navbar-link" data-v-27a12231>
Dividend Income Portfolio
   </a><a href="/screener?name=Ben%20Graham%20Lost%20Formula&amp;id=70" class="navbar-link" data-v-27a12231>
Ben Graham Lost Formula
   </a><a href="/screener?name=Canadian%20Faster%20Growers&amp;id=73" class="navbar-link" data-v-27a12231>
Canadian Faster Growers
   </a><a href="/screener?name=CEO%20Buys&amp;id=74" class="navbar-link" data-v-27a12231>
CEO Buys
   </a><a href="/screener?name=CEO%20Buys%20after%20Price%20Drop%20%3E%2020%25&amp;id=75" class="navbar-link" data-v-27a12231>
CEO Buys after Price Drop &gt; 20%
   </a><a href="/screener?name=Dividend%20Growth%20Portfolio&amp;id=77" class="navbar-link" data-v-27a12231>
Dividend Growth Portfolio
   </a><a href="/screener?name=Dividend%20Income%20Portfolio&amp;id=78" class="navbar-link" data-v-27a12231>
Dividend Income Portfolio
   </a><a href="/screener?name=Fast%20Growers&amp;id=79" class="navbar-link" data-v-27a12231>
Fast Growers
   </a><a href="/screener?name=Hedge%20Fund%20Guru%20Top%2010%20Aggregated&amp;id=80" class="navbar-link" data-v-27a12231>
 Hedge Fund Guru Top 10 Aggregated
   </a><a href="/screener?name=High%20Quality&amp;id=81" class="navbar-link" data-v-27a12231>
High Quality
   </a><a href="/screener?name=High%20Quality%20Low%20Capex%20w%20ROE%20ROC%20min&amp;id=84" class="navbar-link" data-v-27a12231>
High Quality Low Capex w ROE ROC min
   </a><a href="/screener?name=High%20Quality%20&amp;%20Low%20Capex&amp;id=87" class="navbar-link" data-v-27a12231>
High Quality &amp; Low Capex
   </a><a href="/screener?name=High%20Yield%20Insider%20Buys&amp;id=88" class="navbar-link" data-v-27a12231>
High Yield Insider Buys
   </a><a href="/screener?name=Historical%20High%20Dividend%20Yields&amp;id=89" class="navbar-link" data-v-27a12231>
Historical High Dividend Yields
   </a><a href="/screener?name=International%20Gurus%27%20Top%20Holdings&amp;id=90" class="navbar-link" data-v-27a12231>
International Gurus' Top Holdings
   </a><a href="/screener?name=James%20Montier%20Short%20Screen&amp;id=91" class="navbar-link" data-v-27a12231>
James Montier Short Screen
   </a><a href="/screener?name=Margin%20Decliners&amp;id=92" class="navbar-link" data-v-27a12231>
Margin Decliners
   </a><a href="/screener?name=Mega%20Caps&amp;id=93" class="navbar-link" data-v-27a12231>
Mega Caps
   </a><a href="/screener?name=Peter%20Lynch%20&amp;%20Warren%20Buffett&amp;id=94" class="navbar-link" data-v-27a12231>
Peter Lynch &amp; Warren Buffett
   </a><a href="/screener?name=Peter%20Lynch%20Growth%20w%20Lower%20Valuation&amp;id=95" class="navbar-link" data-v-27a12231>
Peter Lynch Growth w Lower Valuation
   </a><a href="/screener?name=Peter%20Lynch%20S&amp;L%20Traded%20Below%20Book&amp;id=96" class="navbar-link" data-v-27a12231>
Peter Lynch S&amp;L Traded Below Book
   </a><a href="/screener?name=PFCF%20Screener&amp;id=97" class="navbar-link" data-v-27a12231>
PFCF Screener
   </a><a href="/screener?name=Piotroski%20Score%20Screener&amp;id=98" class="navbar-link" data-v-27a12231>
Piotroski Score Screener
   </a><a href="/screener?name=Predictable%20Companies&amp;id=99" class="navbar-link" data-v-27a12231>
Predictable Growth Companies
   </a><a href="/screener?name=Profitable%20predictable%20margin%20expanders&amp;id=100" class="navbar-link" data-v-27a12231>
Profitable predictable margin expanders
   </a><a href="/screener?name=Stocks%20Sold%20w%20less%20Cash&amp;id=102" class="navbar-link" data-v-27a12231>
Stocks Sold w less Cash
   </a><a href="/screener?name=Good%20Companies&amp;id=103" class="navbar-link" data-v-27a12231>
Good Companies
   </a><a href="/screener?name=The%20Stalwarts&amp;id=104" class="navbar-link" data-v-27a12231>
The Stalwarts
   </a></div><div class="navbar-sub" data-v-27a12231><div class="navbar-sub-title" data-v-27a12231><a href="/screener?manage=screen" class="color-primary" data-v-27a12231>
My Screeners
</a></div> <a href="/screener" class="navbar-link" data-v-27a12231>
Create My Screener
   </a></div><div class="navbar-sub" data-v-27a12231><div class="navbar-sub-title" data-v-27a12231><a href="/screener/buffett-munger" class="color-primary" data-v-27a12231>
Value Screens
</a></div> <a href="/screener" class="navbar-link" style="color:red;font-weight:bold;" data-v-27a12231>
All-In-One Screener
   </a><a href="/screener?view=map&amp;show_header=false" class="navbar-link" data-v-27a12231>
S&amp;P 500 Map
   </a><a href="/screener?view=bubble&amp;show_header=false" class="navbar-link" data-v-27a12231>
S&amp;P 500 Bubble
   </a><a href="/screener?view=aggregate&amp;show_header=false" class="navbar-link" data-v-27a12231>
S&amp;P 500 Aggregate
   </a><a href="/screener/buffett-munger" class="navbar-link" data-v-27a12231>
Buffett-Munger Screener
   </a><a href="/industry" class="navbar-link" data-v-27a12231>
Industry Overview
   </a><a href="/screener/valuedcf" class="navbar-link" data-v-27a12231>
Undervalued Predictable
   </a><a href="/screener/grahamncav" class="navbar-link" data-v-27a12231>
Benjamin Graham Net-Net
   </a><a href="/screener/52weeklow" class="navbar-link" data-v-27a12231>
52-week/3Y/5Y Lows
   </a><a href="/screener/52weekhigh" class="navbar-link" data-v-27a12231>
52-week/3Y/5Y Highs
   </a><a href="/screener/magic-formula" class="navbar-link" data-v-27a12231>
Magic Formula(Greenblatt)
   </a><a href="/screener/dividend-stocks" class="navbar-link" data-v-27a12231>
Dividend Stocks
   </a><a href="/screener/peter-lynch-stocks" class="navbar-link" data-v-27a12231>
Peter Lynch Screen
   </a><a href="/screener/guru-sp-grid" class="navbar-link" data-v-27a12231>
S&amp;P500 Grid
   </a><a href="/screener/predictable" class="navbar-link" data-v-27a12231>
Predictable Companies
   </a><a href="/screener/spinoff" class="navbar-link" data-v-27a12231>
Spin Off List
   </a><a href="/screener/lowpb" class="navbar-link" data-v-27a12231>
Historical Low P/B List
   </a><a href="/screener/lowps" class="navbar-link" data-v-27a12231>
Historical Low P/S List
   </a><a href="/screener/short-stocks" class="navbar-link" data-v-27a12231>
High Short Interest
   </a><a href="/screener/upcoming-special-dividends" class="navbar-link" data-v-27a12231>
Upcoming Special Dividends
   </a><a href="/screener/delisted" class="navbar-link" data-v-27a12231>
Delisted Stocks
   </a><div class="navbar-sub-title" data-v-27a12231>
Model Portfolios
</div><a href="https://www.gurufocus.com/model_portfolio.php" class="navbar-link" data-v-27a12231>
Performances
</a><a href="https://www.gurufocus.com/model_portfolio.php?mp=smallcap" class="navbar-link" data-v-27a12231>
Undervalued Predictable
 </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=midcap" class="navbar-link" data-v-27a12231>
Buffett-Munger
</a><a href="https://www.gurufocus.com/model_portfolio.php?mp=cap40" class="navbar-link" data-v-27a12231>
Low P/S
</a><a href="https://www.gurufocus.com/model_portfolio.php?mp=lowpb" class="navbar-link" data-v-27a12231>
Low P/B
</a><a href="https://www.gurufocus.com/model_portfolio.php?mp=cap20" class="navbar-link" data-v-27a12231>
52w Low Predictable
</a><a href="https://www.gurufocus.com/model_portfolio.php?mp=largecap" class="navbar-link" data-v-27a12231>
Broadest Owned
</a><a href="https://www.gurufocus.com/model_portfolio.php?mp=hr_largecap" class="navbar-link" data-v-27a12231>
Most Weighted
</a></div></div></div><div class="navbar-item" data-v-27a12231><span style="line-height: 24px;" data-v-27a12231><span data-v-27a12231>Gurus </span> <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-27a12231></i></span> <div class="navbar-dropdown" data-v-27a12231><div class="navbar-sub" data-v-27a12231> <a href="/guru/latest-picks" class="navbar-link" data-v-27a12231>
Latest Guru Picks
   </a><a href="/guru/list" class="navbar-link" data-v-27a12231>
List of Gurus
   </a><a href="/guru/realtime-picks" class="navbar-link" data-v-27a12231>
Real Time Picks
   </a><a href="/guru/portfolio" class="navbar-link" data-v-27a12231>
Guru Portfolio
   </a><a href="/guru/top-holdings" class="navbar-link" data-v-27a12231>
Top 10 Holdings View
   </a><a href="/guru/bargains" class="navbar-link" data-v-27a12231>
Guru Bargains
   </a><a href="/guru/hot-picks" class="navbar-link" data-v-27a12231>
Hot Picks
   </a><a href="/guru/aggregated-portfolio" class="navbar-link" data-v-27a12231>
Aggregated Portfolio
   </a><a href="/guru/consensus-picks" class="navbar-link" data-v-27a12231>
Consensus Picks
   </a><a href="/guru/etfs" class="navbar-link" data-v-27a12231>
ETFS
   </a><a href="/guru/scoreboard" class="navbar-link" data-v-27a12231>
Score Board
   </a><a href="/guru/sector-picks" class="navbar-link" data-v-27a12231>
Sector Picks
   </a><a href="/guru/international-picks" class="navbar-link" data-v-27a12231>
International Picks
   </a><a href="/guru/industry-trends" class="navbar-link" data-v-27a12231>
Industry Trends
   </a><a href="/guru/geographic-trends" class="navbar-link" data-v-27a12231>
Geographic Trend
   </a><a href="/guru/option-holdings" class="navbar-link" data-v-27a12231>
Options
   </a><a href="/guru/european-shortings" class="navbar-link" data-v-27a12231>
European Shorting
   </a></div><div class="navbar-sub" data-v-27a12231> <a href="/guru/warren+buffett/summary" class="navbar-link" data-v-27a12231>
Warren Buffett
   </a><a href="/guru/bill+gates/summary" class="navbar-link" data-v-27a12231>
Bill Gates
   </a><a href="/guru/mohnish+pabrai/summary" class="navbar-link" data-v-27a12231>
Mohnish Pabrai
   </a><a href="/guru/carl+icahn/summary" class="navbar-link" data-v-27a12231>
Carl Icahn
   </a><a href="/guru/george+soros/summary" class="navbar-link" data-v-27a12231>
George Soros
   </a><a href="/guru/david+tepper/summary" class="navbar-link" data-v-27a12231>
David Tepper
   </a><a href="/guru/seth+klarman/summary" class="navbar-link" data-v-27a12231>
Seth Klarman
   </a><a href="/guru/bill+ackman/summary" class="navbar-link" data-v-27a12231>
Bill Ackman
   </a><a href="/guru/joel+greenblatt/summary" class="navbar-link" data-v-27a12231>
Joel Greenblatt
   </a><a href="/guru/charlie+munger/summary" class="navbar-link" data-v-27a12231>
Charlie Munger
   </a></div></div></div><div class="navbar-item" data-v-27a12231><span style="line-height: 24px;" data-v-27a12231><span data-v-27a12231>Insiders </span> <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-27a12231></i></span> <div class="navbar-dropdown" data-v-27a12231><a href="/insider/summary" class="navbar-link" data-v-27a12231>
All Insiders
</a><a href="/insider/ceo" class="navbar-link" data-v-27a12231>
CEO Buys/Sells
</a><a href="/insider/trend" class="navbar-link" data-v-27a12231>
Insider Trends
</a><a href="/insider/cluster" class="navbar-link" data-v-27a12231>
Insider Cluster
</a><a href="/insider/cfo" class="navbar-link" data-v-27a12231>
CFO Buys/Sells
</a><a href="/insider/double" class="navbar-link" data-v-27a12231>
Guru + Insider Double Buys
</a><a href="/insider/triple" class="navbar-link" data-v-27a12231>
Triple buys/Sells
</a><a href="/insider/canadian" class="navbar-link" data-v-27a12231>
Canadian Insider
</a><a href="/insider/dutch" class="navbar-link" data-v-27a12231>
Dutch Insider
</a></div></div><div class="navbar-item" data-v-27a12231><span style="line-height: 24px;" data-v-27a12231><span data-v-27a12231>Market </span> <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-27a12231></i></span> <div class="navbar-dropdown" data-v-27a12231><div class="navbar-sub" data-v-27a12231><div class="navbar-sub-title" data-v-27a12231><a href="/stock-market-valuations.php" class="color-primary" data-v-27a12231>
Market Data
</a></div> <a href="/economic_indicators" class="navbar-link" data-v-27a12231>
Economic Data
   </a><a href="/industry" class="navbar-link" data-v-27a12231>
Industry Overview
   </a><a href="https://www.gurufocus.com/yield_curve.php" class="navbar-link" data-v-27a12231>
U.S. Treasury Yield Curve
</a><a href="https://www.gurufocus.com/stock-market-valuations.php" class="navbar-link" data-v-27a12231>
Buffett Indicator
</a><a href="https://www.gurufocus.com/global-market-valuation.php" class="navbar-link" data-v-27a12231>
Global Market Valuations
</a><a href="https://www.gurufocus.com/shiller-PE.php" class="navbar-link" data-v-27a12231>
Shiller P/E
</a><a href="https://www.gurufocus.com/sector_shiller_pe.php" class="navbar-link" data-v-27a12231>
Shiller P/E by Sectors
</a><a href="/market/sp500-gf-value" class="navbar-link" data-v-27a12231>
GF Value for SP500 Index
   </a><a href="https://www.gurufocus.com/buffett_assets_allocations.php" class="navbar-link" data-v-27a12231>
Buffett Assets Allocation
</a></div><div class="navbar-sub" data-v-27a12231><div class="navbar-sub-title" data-v-27a12231><a href="/economic_indicators" class="color-primary" data-v-27a12231>
Economic Indicators
</a></div> <a href="/economic_indicators/229/the-dow-jones-industrial-average-djia" class="navbar-link" data-v-27a12231>
The Dow Jones Industrial Average (DJIA)
   </a><a href="/economic_indicators/63/sp-500-index" class="navbar-link" data-v-27a12231>
SP 500 Index
   </a><a href="/economic_indicators/232/nasdaq-composite-index" class="navbar-link" data-v-27a12231>
Nasdaq Composite Index
   </a><a href="/economic_indicators/20/gross-domestic-product-gdp" class="navbar-link" data-v-27a12231>
Gross Domestic Product (GDP)
   </a><a href="/economic_indicators/56/shiller-pe" class="navbar-link" data-v-27a12231>
Shiller PE
   </a><a href="/economic_indicators/60/ratio-of-wilshire-5000-over-gnp" class="navbar-link" data-v-27a12231>
Ratio of Wilshire 5000 over GNP
   </a><a href="/economic_indicators/10/civilian-unemployment-rate" class="navbar-link" data-v-27a12231>
Civilian Unemployment Rate
   </a><a href="/economic_indicators/231/russell-2000-small-cap-price-index" class="navbar-link" data-v-27a12231>
Russell 2000 Small Cap Price Index
   </a><a href="/economic_indicators/234/cboe-volatility-index-the-vix" class="navbar-link" data-v-27a12231>
CBOE Volatility Index (VIX)
   </a><a href="/economic_indicators/14/total-nonfarm-payrolls-all-employees" class="navbar-link" data-v-27a12231>
Total Nonfarm Payrolls: All Employees
   </a><a href="/economic_indicators" class="navbar-link" data-v-27a12231>
More...
   </a></div><div class="navbar-sub" data-v-27a12231><div class="navbar-sub-title" data-v-27a12231><a href="/global-market-valuation.php" class="color-primary" data-v-27a12231>
By Country
</a></div> <a href="https://www.gurufocus.com/stock-market-valuations.php" class="navbar-link" data-v-27a12231>
USA
</a><a href="https://www.gurufocus.com/global-market-valuation.php?country=IND" class="navbar-link" data-v-27a12231>
India
</a><a href="https://www.gurufocus.com/global-market-valuation.php?country=CHN" class="navbar-link" data-v-27a12231>
China
</a><a href="https://www.gurufocus.com/global-market-valuation.php" class="navbar-link" data-v-27a12231>
More
</a></div></div></div><div class="navbar-item" data-v-27a12231><span style="line-height: 24px;" data-v-27a12231><span data-v-27a12231>Articles </span> <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-27a12231></i></span> <div class="navbar-dropdown" data-v-27a12231><div class="navbar-sub" data-v-27a12231><div class="navbar-sub-title" data-v-27a12231><a href="/news" class="color-primary" data-v-27a12231>
Articles
</a></div> <a href="/news?cat=timeless" class="navbar-link" data-v-27a12231>
Editors' Picks
   </a><a href="/news?cat=qa" class="navbar-link" data-v-27a12231>
Q&amp;A with Gurus
   </a><a href="/news?cat=rank" class="navbar-link" data-v-27a12231>
Top Ranked
   </a><a href="/news?cat=guru" class="navbar-link" data-v-27a12231>
News
   </a><a href="/news?cat=contest" class="navbar-link" data-v-27a12231>
Value Idea Contest
   </a></div><div class="navbar-sub" data-v-27a12231><div class="navbar-sub-title" data-v-27a12231><a href="/news/post" class="color-primary" data-v-27a12231>
Submit Articles
</a></div> <a href="/news/post" class="navbar-link" data-v-27a12231>
Submit Article Online
   </a><a href="https://www.gurufocus.com/news/70028" class="navbar-link" data-v-27a12231>
Writers Wanted
</a></div></div></div><div class="navbar-item" data-v-27a12231><span style="line-height: 24px;" data-v-27a12231><span data-v-27a12231>Tools </span> <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-27a12231></i></span> <div class="navbar-dropdown" data-v-27a12231><a href="https://www.gurufocus.com/model_portfolio.php" class="navbar-link" data-v-27a12231>
Model Portfolios
</a><a href="/screener" class="navbar-link" data-v-27a12231>
All-In-One Screener
</a><a href="https://www.gurufocus.com/download_financials_batch.php" class="navbar-link" data-v-27a12231>
Data Batch Download
</a><a href="/guru/download-guru-portfolio" class="navbar-link" data-v-27a12231>
Guru Portfolio Download
</a><a href="/insider/data-export" class="navbar-link" data-v-27a12231>
Insider Data Download
</a><a href="https://www.gurufocus.com/excel-add-in" class="navbar-link" data-v-27a12231>
Excel Add-In
</a><a href="https://www.gurufocus.com/api.php" class="navbar-link" data-v-27a12231>
API
</a><a href="https://www.gurufocus.com/download_stockmanual.php" class="navbar-link" data-v-27a12231>
Manual of Stocks
</a><a href="/stock/AAPL/dcf" class="navbar-link" data-v-27a12231>
DCF Calculator
</a><a href="/stock/AAPL/chart" class="navbar-link" data-v-27a12231>
Interactive Chart
</a><a href="/screener?view=map&amp;show_header=false" class="navbar-link" data-v-27a12231>
Maps
</a><a href="/fund-letters" class="navbar-link" data-v-27a12231>
Fund Letters Archive
</a><a href="/compare-table?tab=current-analysis" class="navbar-link" data-v-27a12231>
Stock Comparison Table
</a><a href="https://www.gurufocus.com/mobile-app" class="navbar-link" data-v-27a12231>
Mobile App
</a><a href="/discussion" class="navbar-link" data-v-27a12231>
Discussion Board
</a></div></div><div class="navbar-item" data-v-27a12231><span style="line-height: 24px;" data-v-27a12231><a href="https://gurufocusetf.com/" target="_blank" class="color-white" data-v-27a12231> ETF </a> </span> </div><div class="navbar-item" data-v-27a12231><span style="line-height: 24px;" data-v-27a12231><a href="/plans" class="color-white" data-v-27a12231> Pricing </a> </span> </div><div class="navbar-item navbar-right-item" data-v-27a12231><span style="line-height: 24px;" data-v-27a12231><span data-v-27a12231>Tutorials </span> </span> <div class="navbar-dropdown" data-v-27a12231><a href="https://www.gurufocus.com/tutorials.php" class="navbar-link" data-v-27a12231>
Tutorials &amp; Webinars
</a><a href="https://www.gurufocus.com/faq.php" class="navbar-link" data-v-27a12231>
FAQ
</a><a href="/changelog" class="navbar-link" data-v-27a12231>
Change Log
</a><a href="https://www.gurufocus.com/ticket/open.php" class="navbar-link" data-v-27a12231>
Contact Us
</a></div></div><div class="navbar-item navbar-right-item" data-v-27a12231><span style="line-height: 24px;" data-v-27a12231><span data-v-27a12231>Support </span> </span> <div class="navbar-dropdown" data-v-27a12231><span data-name="Support" slot="reference" data-v-27a12231><span class="navbar-link nuxt-link-exact-active nuxt-link-active"> Chat Support</span> <div id="phplive_btn_1570480208"></div></span><a href="https://www.gurufocus.com/ticket/open.php" class="navbar-link" data-v-27a12231>
Create a ticket
</a><span data-name="Tutorial Session" slot="reference" data-v-27a12231><span class="navbar-link nuxt-link-exact-active nuxt-link-active"> Schedule a Meeting</span></span></div></div> <div class="navbar-item navbar-right-item" data-v-92a12fc8 data-v-27a12231><a href="https://www.gurufocus.com/membership/new/index.html#/?sel=premium&utm_source=webApp&utm_medium=userClick&utm_campaign=new_navbar_free_trial" data-v-92a12fc8><span class="basic-navbar-title" data-v-92a12fc8>
Subscribe
</span></a> <div class="navbar-dropdown" data-v-92a12fc8><a href="https://www.gurufocus.com/membership/new/index.html#/?sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=new_navbar_free_trial_item" class="navbar-link" data-v-92a12fc8>
Free Trial
</a><a href="https://www.gurufocus.com/user_referrals.php" class="navbar-link" data-v-92a12fc8>
Refer a Friend and Earn $50
</a></div></div> </div> <div class="el-dialog__wrapper" style="display:none;" data-v-27a12231><div role="dialog" aria-modal="true" aria-label="Tutorial Session" class="el-dialog" style="margin-top:15vh;width:800px;"><div class="el-dialog__header"><span class="el-dialog__title">Tutorial Session</span><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><div class="el-dialog__footer"><span class="dialog-footer" data-v-27a12231><button type="button" class="el-button el-button--default el-button--mini" data-v-27a12231><span>Cancel</span></button> <button type="button" class="el-button el-button--primary el-button--mini" data-v-27a12231><span>Confirm</span></button></span></div></div></div></div> <div id="tags-view" style="height:32px;margin:8px 0;padding-left:0px;" data-v-6ed125cc></div> <section class="el-container"><main id="components-root" class="el-main auto-height-on-print capture-areaz" style="height:calc(100vh - 73px);"><section class="el-container is-vertical" data-v-0fa0a93c><main class="el-main center" data-v-0fa0a93c><div frame="frame-xl" class="gf center" style="padding-bottom:0px;" data-v-1df69f40 data-v-0fa0a93c><div class="ad-image-container" data-v-7b88c82c data-v-1df69f40><img src="https://static.gurufocus.com/images/icons/i/Banner/CTA%20Large.png" alt="Get Premium to unlock powerful stock data" width="100%" data-v-7b88c82c></div> <div class="el-row" style="margin-left:-20px;margin-right:-20px;" data-v-1df69f40><div id="article-main-section-1679946" class="el-col el-col-16" style="padding-left:20px;padding-right:20px;" data-v-1df69f40><h1 class="t-h1 fc-primary fw-bolder subject" data-v-1df69f40> Thinking about buying stock in Citius Pharmaceuticals, BioXcel Therapeutics, Array Technologies, Gogo, or Clovis Oncology?
  </h1>   <div class="row-padding" data-v-d0ddfec8 data-v-1df69f40><div class="author-item global-flex-container" data-v-d0ddfec8><div style="margin-right: 12px;" data-v-d0ddfec8><a href="/user/guikyhkbru" class="left avatar" data-v-d0ddfec8><img alt="Author's Avatar" height="48px" width="48px" src="https://avatar.gurufocus.com/387281_small.png" style="vertical-align:middle;border-radius:50%;object-fit:scale-down;" data-v-d0ddfec8></a></div> <div data-v-d0ddfec8><div data-v-d0ddfec8><a href="/user/guikyhkbru" class="fc-normal-i body-small fw-bolder" style="margin-right: 12px;" data-v-d0ddfec8><span data-v-d0ddfec8> PRNewswire </span></a> <button type="button" class="el-button gf bg-main-blue-i fc-white-i el-button--default el-button--mini" data-v-d0ddfec8><span>Follow</span></button></div> <div class="body-small fc-light" style="line-height: 24px; margin-top: 2px;" data-v-d0ddfec8><span data-v-d0ddfec8> 4 minutes ago </span></div></div></div> <div class="fc-normal global-flex-container fc-normal" style="float:right;position:relative;top:-34px;font-size:24px;" data-v-d0ddfec8> <div><span style="display:inline-block !important;" data-v-4ba6c776><i class="el-icon-collection" style="cursor: pointer;font-size: 20px;" data-v-4ba6c776></i> <div class="el-dialog__wrapper" style="display:none;" data-v-4ba6c776><div role="dialog" aria-modal="true" aria-label="Bookmark" class="el-dialog" style="margin-top:15vh;"><div class="el-dialog__header"><span class="el-dialog__title">Bookmark</span><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><div class="el-dialog__footer"><span class="dialog-footer" data-v-4ba6c776><button type="button" class="el-button el-button--default el-button--mini" data-v-4ba6c776><span>Cancel</span></button> <button type="button" class="el-button el-button--primary el-button--mini" data-v-4ba6c776><span>Confirm</span></button></span></div></div></div></span> <span class="share-button" style="display:inline-block !important;" data-v-0449eb4e><div role="tooltip" id="el-popover-4855" aria-hidden="true" class="el-popover el-popper aio-popover no-padding" style="width:undefinedpx;display:none;"></div><span class=" " style="background:transparent;" data-v-0449eb4e><i class="gf-icon-share hover-pointer" data-v-0449eb4e></i></span></span> <i class="gf-icon-printer cursor-pointer"></i></div></div></div>  <img alt="Article's Main Image" width="50%" src="" style="padding-top:40px;max-height:600px;display:block;margin:auto;padding-bottom:10px;object-fit:contain;float:left;margin-right:24px;" data-v-1df69f40> <div id="article-body-1679946" class="main-body" style="margin-top:40px;" data-v-1df69f40><div class="xn-newslines"><p class="xn-distributor">PR Newswire</p> <p class="xn-dateline">NEW YORK, April 6, 2022</p><div class="xn-content"><p><span class="legendSpanClass"><span class="xn-location">NEW YORK</span></span>, <span class="legendSpanClass"><span class="xn-chron">April 6, 2022</span></span> /PRNewswire/ -- <a href="https://c212.net/c/link/?t=0&l=en&o=3496454-1&h=398015102&u=https%3A%2F%2Fwww.investorsobserver.com%2Flp%2Fpr-stocks-lp-2%2F%3Fprnumber%3D040620221&a=InvestorsObserver" rel="nofollow" target="_blank">InvestorsObserver</a> issues critical PriceWatch Alerts for CTXR, BTAI, ARRY, GOGO, and CLVS.</p> <div class="PRN_ImbeddedAssetReference"><p><a href="https://mma.prnewswire.com/media/1333368/InvestorsObserver_Logo.html" target="_blank" rel="noreferrer noopener"><img src="https://mma.prnewswire.com/media/1333368/InvestorsObserver_Logo.jpg" alt="InvestorsObserver_Logo.jpg"></a></p></div> <p>To see how InvestorsObserver's proprietary scoring system rates these stocks, view the InvestorsObserver's PriceWatch Alert by selecting the corresponding link.</p> <ul><li>CTXR: <a href="https://c212.net/c/link/?t=0&l=en&o=3496454-1&h=1324082082&u=https%3A%2F%2Fwww.investorsobserver.com%2Flp%2Fpr-stocks-lp-2%2F%3Fsymbol%3DCTXR%26prnumber%3D040620221&a=https%3A%2F%2Fwww.investorsobserver.com%2Flp%2Fpr-stocks-lp-2%2F%3Fsymbol%3DCTXR%26prnumber%3D040620221" rel="nofollow" target="_blank">https://www.investorsobserver.com/lp/pr-stocks-lp-2/?symbol=CTXR&amp;prnumber=040620221</a></li><li>BTAI: <a href="https://c212.net/c/link/?t=0&l=en&o=3496454-1&h=1853177691&u=https%3A%2F%2Fwww.investorsobserver.com%2Flp%2Fpr-stocks-lp-2%2F%3Fsymbol%3DBTAI%26prnumber%3D040620221&a=https%3A%2F%2Fwww.investorsobserver.com%2Flp%2Fpr-stocks-lp-2%2F%3Fsymbol%3DBTAI%26prnumber%3D040620221" rel="nofollow" target="_blank">https://www.investorsobserver.com/lp/pr-stocks-lp-2/?symbol=BTAI&amp;prnumber=040620221</a></li><li>ARRY: <a href="https://c212.net/c/link/?t=0&l=en&o=3496454-1&h=1990268678&u=https%3A%2F%2Fwww.investorsobserver.com%2Flp%2Fpr-stocks-lp-2%2F%3Fsymbol%3DARRY%26prnumber%3D040620221&a=https%3A%2F%2Fwww.investorsobserver.com%2Flp%2Fpr-stocks-lp-2%2F%3Fsymbol%3DARRY%26prnumber%3D040620221" rel="nofollow" target="_blank">https://www.investorsobserver.com/lp/pr-stocks-lp-2/?symbol=ARRY&amp;prnumber=040620221</a></li><li>GOGO: <a href="https://c212.net/c/link/?t=0&l=en&o=3496454-1&h=3613875006&u=https%3A%2F%2Fwww.investorsobserver.com%2Flp%2Fpr-stocks-lp-2%2F%3Fsymbol%3DGOGO%26prnumber%3D040620221&a=https%3A%2F%2Fwww.investorsobserver.com%2Flp%2Fpr-stocks-lp-2%2F%3Fsymbol%3DGOGO%26prnumber%3D040620221" rel="nofollow" target="_blank">https://www.investorsobserver.com/lp/pr-stocks-lp-2/?symbol=GOGO&amp;prnumber=040620221</a></li><li>CLVS: <a href="https://c212.net/c/link/?t=0&l=en&o=3496454-1&h=2361750673&u=https%3A%2F%2Fwww.investorsobserver.com%2Flp%2Fpr-stocks-lp-2%2F%3Fsymbol%3DCLVS%26prnumber%3D040620221&a=https%3A%2F%2Fwww.investorsobserver.com%2Flp%2Fpr-stocks-lp-2%2F%3Fsymbol%3DCLVS%26prnumber%3D040620221" rel="nofollow" target="_blank">https://www.investorsobserver.com/lp/pr-stocks-lp-2/?symbol=CLVS&amp;prnumber=040620221</a></li></ul><p>(Note: You may have to copy this link into your browser then press the [ENTER] key.)</p> <p>InvestorsObserver's PriceWatch Alerts are based on our proprietary scoring methodology. Each stock is evaluated based on short-term technical, long-term technical and fundamental factors. Each of those scores is then combined into an overall score that determines a stock's overall suitability for investment.</p> <p>InvestorsObserver provides patented technology to some of the biggest names on Wall Street and creates world-class investing tools for the self-directed investor on Main Street. We have a wide range of tools to help investors make smarter decisions when investing in stocks or options.</p> <p><img width="12" height="12" src="https://c212.net/c/img/favicon.png?sn=CG16136&sd=2022-04-06" alt="favicon.png?sn=CG16136&sd=2022-04-06"> View original content to download multimedia:<a href="https://www.prnewswire.com/news-releases/thinking-about-buying-stock-in-citius-pharmaceuticals-bioxcel-therapeutics-array-technologies-gogo-or-clovis-oncology-301518893.html" rel="nofollow" target="_blank">https://www.prnewswire.com/news-releases/thinking-about-buying-stock-in-citius-pharmaceuticals-bioxcel-therapeutics-array-technologies-gogo-or-clovis-oncology-301518893.html</a></p> <p>SOURCE InvestorsObserver</p></div><img src="https://rt.prnewswire.com/rt.gif?NewsItemId=CG16136&Transmission_Id=202204060831PR_NEWS_USPR_____CG16136&DateId=20220406" alt="rt.gif?NewsItemId=CG16136&Transmission_Id=202204060831PR_NEWS_USPR_____CG16136&DateId=20220406" style="border:0px;width:1px;height:1px;"></div></div>  <div style="margin-top:20px;margin-bottom:30px;" data-v-1df69f40><span data-v-1df69f40><span class="fs-large fw-bolder" data-v-1df69f40>Rating: </span> <div role="slider" aria-valuenow="0" aria-valuetext="" aria-valuemin="0" aria-valuemax="5" tabindex="0" class="el-rate my_rating" data-v-1df69f40><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span></div> <span class="fs-large fw-bolder" data-v-1df69f40>NaN</span> <span class="fs-large" data-v-1df69f40>/ 5 ( votes)</span></span> <div class="fc-normal global-flex-container fc-normal" style="float:right;position:relative;top:0px;font-size:24px;" data-v-1df69f40> <div><span style="display:inline-block !important;" data-v-4ba6c776><i class="el-icon-collection" style="cursor: pointer;font-size: 20px;" data-v-4ba6c776></i> <div class="el-dialog__wrapper" style="display:none;" data-v-4ba6c776><div role="dialog" aria-modal="true" aria-label="Bookmark" class="el-dialog" style="margin-top:15vh;"><div class="el-dialog__header"><span class="el-dialog__title">Bookmark</span><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><div class="el-dialog__footer"><span class="dialog-footer" data-v-4ba6c776><button type="button" class="el-button el-button--default el-button--mini" data-v-4ba6c776><span>Cancel</span></button> <button type="button" class="el-button el-button--primary el-button--mini" data-v-4ba6c776><span>Confirm</span></button></span></div></div></div></span> <span class="share-button" style="display:inline-block !important;" data-v-0449eb4e><div role="tooltip" id="el-popover-1125" aria-hidden="true" class="el-popover el-popper aio-popover no-padding" style="width:undefinedpx;display:none;"></div><span class=" " style="background:transparent;" data-v-0449eb4e><i class="gf-icon-share hover-pointer" data-v-0449eb4e></i></span></span> <i class="gf-icon-printer cursor-pointer"></i></div></div></div> <div id="article-view-1679946" style="height:1px;" data-v-1df69f40></div> <lazy-component class="author-section" style="min-height:200px;" data-v-1df69f40><div style="padding:40px 0;border-top:1px solid #DFE6EC;border-bottom:1px solid #DFE6EC;" data-v-4cbe4798 data-v-1df69f40><div class="global-flex-container-start" style="position: relative;" data-v-4cbe4798><a href="/user/387281" class="link" style="margin-right:16px;" data-v-4cbe4798><img alt="Author's Avatar" height="64px" width="64px" src="https://avatar.gurufocus.com/387281_big.png" style="vertical-align:middle;border-radius:50%;object-fit:scale-down;" data-v-4cbe4798></a> <div data-v-4cbe4798><div class="fs-large fc-light-grey" data-v-4cbe4798>WRITTEN BY </div> <button type="button" class="el-button bg-main-blue-i fc-white-i right-float el-button--default el-button--medium" style="position:absolute;right:0px;top:0px;" data-v-4cbe4798><span>Follow</span></button> <div data-v-4cbe4798><a href="/user/guikyhkbru" class="link" data-v-4cbe4798><h3 class="fs-20 fw-bolder fc-normal" data-v-4cbe4798> PRNewswire </h3></a></div> <div class="fs-large fc-light-grey" style="margin-top:14px;" data-v-4cbe4798></div></div></div> <br data-v-4cbe4798>  <div class="el-row" style="margin-left:-5px;margin-right:-5px;display:flex;" data-v-4cbe4798></div></div></lazy-component> <lazy-component class="comment-section" style="min-height:2px;" data-v-1df69f40><div class="el-card article-comment is-never-shadow" style="border:none;padding:40px 0;" data-v-593f497d data-v-17452fac data-v-1df69f40>  <div data-v-593f497d data-v-17452fac><a href="https://www.gurufocus.com/forum/login.php?0" class="color-main-blue-i" data-v-593f497d data-v-17452fac> Please Login to Comment </a></div>  <div class="row-padding" style="display:none;" data-v-593f497d data-v-17452fac><editor id="comment-editor-1679946" api-key="xfli4zk8nqwi7onsi4cqfz3e67p26wd3lh3bym9l67xplf9c" init="[object Object]" data-v-593f497d data-v-17452fac></editor> <div class="row-padding-top" data-v-593f497d data-v-17452fac>  </div></div>  </div></lazy-component></div> <div class="el-col el-col-8" style="padding-left:20px;padding-right:20px;border-left:1px solid #EAEFF3;" data-v-1df69f40><div style="margin-top:20px;" data-v-652b7662 data-v-1df69f40 data-v-1df69f40><Adsense data-ad-client="ca-pub-4020868656364652" ins-style="display:inline-block;width:380px;height:300px" data-ad-slot="8601925817" data-v-652b7662></Adsense>       <h3 class="fs-x-large-s fc-normal fw-bolder inline" style="margin-bottom: 12px;" data-v-652b7662>
GuruFocus Screeners
</h3> <div class="screener-part" style="margin-bottom:32px;padding-bottom:32px;border-bottom:1px solid #EAEFF3;" data-v-652b7662></div> <a href="/news?cat=qa" class="fs-x-large-s fc-normal-i fw-bolder underline-on-hover" style="display:block;" data-v-652b7662> Q&amp;A with Gurus </a> <div class="section-padding" style="min-height:60px;" data-v-652b7662></div> <h3 class="fs-x-large-s fc-normal fw-bolder inline row-padding" data-v-652b7662>
Related Articles
</h3> </div></div></div> <hr class="thin" data-v-1df69f40></div>  <div id="article-bottom" class="row-padding" style="height:1px;" data-v-0fa0a93c></div></main> <footer class="el-footer" style="height:60px;" data-v-0fa0a93c></footer></section></main> </section> <div closeable="true" class="el-dialog__wrapper gf" style="display:none;" data-v-b166331e><div role="dialog" aria-modal="true" aria-label="dialog" class="el-dialog" style="margin-top:6%;width:59%;"><div class="el-dialog__header"><span class="el-dialog__title"></span></div></div></div></div>  <div class="el-dialog__wrapper" style="display:none;" data-v-f35d8750><div role="dialog" aria-modal="true" aria-label="dialog" class="el-dialog" style="margin-top:15vh;"><div class="el-dialog__header"><div id="title-empty" style="height:0;padding:0;margin:0;" data-v-f35d8750></div><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><div class="el-dialog__footer"><div class="footer-section" data-v-f35d8750><button type="button" class="el-button button-item el-button--default el-button--mini" data-v-f35d8750><span>Cancel</span></button> <button type="button" class="el-button button-item el-button--primary el-button--mini" data-v-f35d8750><span>Confirm</span></button></div></div></div></div> <div id="myModal" class="modal"><img id="modalImg" class="modal-content"> <div id="modalCaption"></div></div></div></div></div><script>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</script><script src="/_nuxt/63edcda38d696f2708ce.1649197356561.js" defer></script><script src="/_nuxt/5828758f9aea6a897bf1.1649197356561.js" defer></script><script src="/_nuxt/827d20a7ba8c37f9db53.1649197356561.js" defer></script><script src="/_nuxt/d45a965d63882100ae63.1649197356561.js" defer></script><script src="/_nuxt/ebfab3f3ad5bc99e9607.1649197356561.js" defer></script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'6f7b2d1779588f11',m:'Ad1aVY9q73hUCxhb3uJJ2ILcOy5umM.c_RSyl1X0smY-1649254952-0-AZfdVT9AhmmGa8jizYSkeLg41swjd64mjgBOCwG+BYMe+cQUuS8t49e7UH2ctgsEe888ucnKCkKD4zDPe01mUs1iJn3y1bC0P+CcKcrktR9CZUAzuqJN66rWi1OXmeDt9om7HZyqJR4Bb4NTqZJBkoF23YHrPp6pIC30QXNyI9Q2VuJD5y36U63/idMY9HW3BXn+JRJHwrDHam60/YBac2ICqT460H9rSCLq3RFXnVS7OIJdWeLaN1UGybYKphIOYrAoRZo4F8cTmVURP7hRk+aoSXfMi5I1nFu9nGOgxhUk',s:[0xf6ab7fe23a,0xb1559186b1],}})();</script></body>
</html>
