<!doctype html>
<html data-n-head-ssr lang="en" data-n-head="lang">
  <head data-n-head="">
    <title data-n-head="true">SeaStar Medical Completes Busi - GuruFocus.com</title><meta data-n-head="true" charset="utf-8"><meta data-n-head="true" name="viewport" content="width=device-width, initial-scale=1"><meta data-n-head="true" name="viewport" content="initial-scale=1.0, user-scalable=no"><meta data-n-head="true" data-hid="twitter:url" name="twitter:url" content="https://www.gurufocus.com/news/1880400/seastar-medical-completes-business-combination-with-lmf-acquisition-opportunities"><meta data-n-head="true" data-hid="description" name="description" content="GuruFocus Article or News written by Value_Insider and the topic is about: "><meta data-n-head="true" data-hid="keywords" name="keywords" content="GuruFocus, Article, News, Value_Insider, LMAO,LMAO,LMFA"><meta data-n-head="true" name="twitter:card" content="summary_large_image"><meta data-n-head="true" name="twitter:site" content="@gurufocus"><meta data-n-head="true" name="twitter:creator" content="@gurufocus"><meta data-n-head="true" data-hid="twitter:title" name="twitter:title" content="SeaStar Medical Completes Business Combination with LMF Acquisition Opportunities"><meta data-n-head="true" data-hid="twitter:description" name="twitter:description" content=""><meta data-n-head="true" data-hid="twitter:image" name="twitter:image" content="https://static.gurufocus.com/images/logo_global.png"><meta data-n-head="true" data-hid="og:title" property="og:title" content="SeaStar Medical Completes Busi - GuruFocus.com"><meta data-n-head="true" data-hid="og:url" property="og:url" content="https://www.gurufocus.com/news/1880400/seastar-medical-completes-business-combination-with-lmf-acquisition-opportunities"><meta data-n-head="true" data-hid="og:description" property="og:description" content="GuruFocus Article or News written by Value_Insider and the topic is about: "><meta data-n-head="true" data-hid="og:image" property="og:image" content="https://static.gurufocus.com/images/logo_global.png"><link data-n-head="true" rel="preconnect" href="https://static.gurufocus.com"><link data-n-head="true" rel="dns-prefetch" href="https://static.gurufocus.com"><link data-n-head="true" rel="icon" type="image/x-icon" href="/favicon.ico"><link data-n-head="true" rel="preconnect" href="https://fonts.googleapis.com"><link data-n-head="true" rel="preconnect" href="https://fonts.gstatic.com"><link data-n-head="true" rel="stylesheet" href="https://fonts.googleapis.com/css2?family=Inter:wght@400;500;700;800&amp;display=swap"><link data-n-head="true" rel="canonical" href="https://www.gurufocus.com/news/1880400/seastar-medical-completes-business-combination-with-lmf-acquisition-opportunities"><script data-n-head="true" src="https://www.googletagmanager.com/gtag/js?id=AW-1005049228" async="true"></script><script data-n-head="true" src="//www.googletagmanager.com/gtm.js?id=GTM-K799DP4&amp;l=dataLayer" async="true"></script><noscript data-n-head="true" data-hid="gtm-noscript" pbody="true"><iframe src="//www.googletagmanager.com/ns.html?id=GTM-K799DP4&l=dataLayer" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><style data-vue-ssr-id="6f0a33d7:0 38d371e3:0 d8faaad2:0 6773750b:0 4e2eff05:0 6d70a38a:0 e28bf752:0 f56f3ab2:0 5e75a32f:0 78a21f67:0 34e9cf66:0 4339a035:0 a45ebf72:0 b0477d72:0 5c3c5cc3:0 46e41cf2:0 1ad96eb5:0 3d09c007:0 af18ac46:0 54a99eff:0 03f699c7:0 398e5a2f:0 5670f209:0 969bc93e:0 219ecae3:0 570f8bde:0 e334b5b2:0 18a5b17d:0 6c5af3a9:0 1810f8e5:0 17f7f332:0 5aac5047:0 622b0887:0 3dc47cc5:0 136eca27:0 081590ab:0 ad090732:0 a47726f2:0 b6425c6e:0 93184b02:0 f1b6e9c6:0 30587576:0 5f885a83:0 162a0dab:0 0c899146:0 13595526:0 cd9ab772:0 a51e5eba:0 16be24e7:0 a31550ca:0 b80d49a0:0 17cfdfa9:0 132df51d:0 52dd7476:0 aba8ca66:0 e55163e4:0 bd966c90:0 9227845c:0 1c2d6a75:0 ff05dc32:0 39165dd6:0 b0db0410:0 65636ebb:0 01d032f8:0 4ca7b345:0 d53df7fc:0 589a57d8:0 6cd0e432:0 abde3830:0 562d78e2:0 b0432b12:0 2fcb6f26:0 35f1b355:0">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</style>
  </head>
  <body data-n-head="">
    <div data-server-rendered="true" id="__nuxt"><!----><div id="__layout"><div class="app-wrapper purge-css-ignore gf keep-all"><div class="main-container"><section id="notification-bar" class="el-container notification-bar enable-darkmode notification-bar" data-v-0a791c85><div center="" class="alert-item" data-v-0a791c85><a href="/pricing?ref=/&amp;sel=premium&amp;utm_source=webApp_fromPricing&amp;utm_medium=userClick&amp;utm_campaign=notificaton_bar_fromPricing" data-v-0a791c85><div slot="title" class="content-section" data-v-0a791c85><!----> <span class="title-section title-section-xl" style="color:var(--color-10) !important;" data-v-0a791c85> Enjoy a 7-Day Free Trial Thru Nov 04, 2022!</span> <span class="link-section" data-v-0a791c85><a href="/pricing?ref=/&amp;sel=premium&amp;utm_source=webApp_fromPricing&amp;utm_medium=userClick&amp;utm_campaign=notificaton_bar_fromPricing" class="link-button link-button-xl" style="color:var(--color-10) !important;" data-v-0a791c85>
              
            </a></span> <!----> <!----></div></a></div></section> <div id="navbar" client-width="1200" class="navbar-desktop align-child-center bg-theme" data-v-b2389082><div class="navbar" data-v-b2389082><div class="navbar-brand" data-v-b2389082><a href="/" class="nuxt-link-active" style="background-color:transparent;" data-v-b2389082><img width="80" height="24" src="https://static.gurufocus.com/images/logo_header.png" alt="Logo" style="margin-top:-6px;" data-v-b2389082></a> <button type="button" class="el-button navbar-collapse-button square el-button--default el-button--mini" data-v-b2389082><!----><!----><span><i class="gf-icon-bars" data-v-b2389082></i></span></button></div> <div class="navbar-item navbar-right-item" style="padding: 12px 8px !important;" data-v-b2389082><a href="/register" data-v-b2389082><button type="button" class="el-button gf login-button el-button--default el-button--mini" data-v-b2389082><!----><!----><span><span class="fw-bolder" data-v-b2389082>Sign Up</span></span></button></a></div> <div class="navbar-item navbar-right-item" data-v-b2389082><div data-v-b2389082><a href="/login" class="block p-v-lg p-h-sm" data-v-b2389082><span class="fw-bolder color-white" data-v-b2389082>Login</span></a></div> <div class="navbar-dropdown" data-v-b2389082><a href="/register" class="navbar-link" data-v-b2389082>
            Free Sign-up
          </a> <a href="/login" class="navbar-link" data-v-b2389082>
            Login
          </a> <a href="/membership/new/index.html#/" class="navbar-link" data-v-b2389082>
            7-Day Free Trial
          </a></div></div> <div class="navbar-item switch-outer" style="padding:12px 8px !important;float:right;" data-v-017ca636 data-v-b2389082><div class="color-theme-bg border-radius" style="height: 32px;" data-v-017ca636><svg width="32" height="32" viewBox="0 0 40 40" fill="none" xmlns="http://www.w3.org/2000/svg" data-v-017ca636><path d="M0 20C0 8.95431 8.95431 0 20 0C31.0457 0 40 8.95431 40 20C40 31.0457 31.0457 40 20 40C8.95431 40 0 31.0457 0 20Z" data-v-017ca636></path> <path fill-rule="evenodd" clip-rule="evenodd" d="M19.7074 9.13178C19.8526 9.38932 19.8329 9.70809 19.6572 9.94582C18.5988 11.3777 18.0895 13.1419 18.2219 14.9175C18.3543 16.6931 19.1197 18.3623 20.3787 19.6213C21.6378 20.8804 23.3069 21.6457 25.0825 21.7781C26.8582 21.9105 28.6223 21.4012 30.0542 20.3428C30.2919 20.1671 30.6107 20.1474 30.8682 20.2926C31.1258 20.4377 31.274 20.7206 31.2468 21.015C31.0498 23.147 30.2497 25.1787 28.9401 26.8726C27.6304 28.5664 25.8655 29.8522 23.8518 30.5796C21.8381 31.307 19.6589 31.4458 17.5691 30.9798C15.4794 30.5139 13.5655 29.4624 12.0516 27.9484C10.5376 26.4345 9.48615 24.5206 9.02019 22.4309C8.55423 20.3412 8.69305 18.1619 9.42042 16.1482C10.1478 14.1345 11.4336 12.3696 13.1275 11.06C14.8213 9.75034 16.8531 8.95022 18.985 8.75319C19.2794 8.72599 19.5623 8.87424 19.7074 9.13178ZM17.5721 10.5175C16.2967 10.8479 15.0958 11.4342 14.0449 12.2466C12.5765 13.382 11.4618 14.912 10.8312 16.6578C10.2006 18.4036 10.0803 20.2928 10.4842 22.1045C10.8882 23.9161 11.7998 25.5753 13.1122 26.8878C14.4247 28.2003 16.0839 29.1118 17.8956 29.5158C19.7072 29.9197 21.5965 29.7994 23.3422 29.1688C25.088 28.5382 26.618 27.4235 27.7534 25.9551C28.5659 24.9042 29.1521 23.7033 29.4825 22.428C28.0868 23.0939 26.5325 23.3904 24.971 23.2739C22.8371 23.1148 20.8311 22.1951 19.318 20.682C17.805 19.1689 16.8852 17.163 16.7261 15.029C16.6096 13.4675 16.9062 11.9133 17.5721 10.5175Z" fill="white" data-v-017ca636></path></svg></div></div> <div class="navbar-item" style="padding:0 !important;" data-v-b2389082><div data-v-b2389082><a href="/" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-b2389082> Home
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-b2389082></i></a></div> <div class="navbar-dropdown" data-v-b2389082><a href="/" class="navbar-link" data-v-b2389082>
              Homepage
            </a><a href="/pricing" class="navbar-link" data-v-b2389082>
              Membership Levels
            </a><a href="/about" class="navbar-link" data-v-b2389082>
              About Us
            </a><a href="/discussion" class="navbar-link" data-v-b2389082>
              General Discussion
            </a><a href="/stocks" class="navbar-link" data-v-b2389082>
              Complete Stock List
            </a><a href="https://www.gurufocus.com/ads/books/index.php" class="navbar-link" data-v-b2389082><!----> <!---->
              The book
            </a><a href="https://open.spotify.com/show/7cIRp3PmnEaqEcAXHU3z9u" class="navbar-link" data-v-b2389082><!----> <!---->
              Podcast
            </a><a href="https://www.gurufocus.com/news/281207/data-coverage-of-gurufocus-premium-membership-" class="navbar-link" data-v-b2389082><!----> <!---->
              Membership Data Coverage
            </a><a href="https://www.gurufocus.com/letter.php" class="navbar-link" data-v-b2389082><!----> <!---->
              Founder's Message
            </a><a href="https://www.gurufocus.com/membership/new/index.html#/?ref=topMenu&amp;sel=premium&amp;utm_source=webApp_fromOld&amp;utm_medium=userClick&amp;utm_campaign=topMenu_fromOld" class="navbar-link" data-v-b2389082><!----> <!---->
              Free Trial
            </a></div></div><div class="navbar-item" style="padding:0 !important;" data-v-b2389082><div data-v-b2389082><a href="/screener" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-b2389082> Screeners
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-b2389082></i></a></div> <div class="navbar-dropdown" data-v-b2389082><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/screener" class="t-icon" data-v-b2389082>
                  GuruFocus Screeners
                </a></div> <a href="/screener" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-b2389082>
                All-In-One Screener
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Ben%20Graham%20Lost%20Formula&amp;id=70" class="navbar-link" data-v-b2389082>
                Ben Graham Lost Formula
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Canadian%20Faster%20Growers&amp;id=73" class="navbar-link" data-v-b2389082>
                Canadian Faster Growers
                <!----> <!----> <!----> <!----></a><a href="/screener?name=CEO%20Buys&amp;id=74" class="navbar-link" data-v-b2389082>
                CEO Buys
                <!----> <!----> <!----> <!----></a><a href="/screener?name=CEO%20Buys%20after%20Price%20Drop%20%3E%2020%25&amp;id=75" class="navbar-link" data-v-b2389082>
                CEO Buys after Price Drop &gt; 20%
                <!----> <!----> <!----> <!----></a><!----><a href="/screener?name=Dividend%20Aristocrats%202022&amp;id=61843" class="navbar-link" data-v-b2389082>
                Dividend Aristocrats 2022
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Dividend%20Growth%20Portfolio&amp;id=77" class="navbar-link" data-v-b2389082>
                Dividend Growth Portfolio
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Dividend%20Income%20Portfolio&amp;id=78" class="navbar-link" data-v-b2389082>
                Dividend Income Portfolio
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Fast%20Growers&amp;id=79" class="navbar-link" data-v-b2389082>
                Fast Growers
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Good%20Companies&amp;id=103" class="navbar-link" data-v-b2389082>
                Good Companies
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Hedge%20Fund%20Guru%20Top%2010%20Aggregated&amp;id=80" class="navbar-link" data-v-b2389082>
                Hedge Fund Guru Top 10 Aggregated
                <!----> <!----> <!----> <!----></a><a href="/screener?name=High%20Quality&amp;id=81" class="navbar-link" data-v-b2389082>
                High Quality
                <!----> <!----> <!----> <!----></a><a href="/screener?name=High%20Quality%20Low%20Capex%20w%20ROE%20ROC%20min&amp;id=84" class="navbar-link" data-v-b2389082>
                High Quality Low Capex w ROE ROC min
                <!----> <!----> <!----> <!----></a><a href="/screener?name=High%20Quality%20&amp;%20Low%20Capex&amp;id=87" class="navbar-link" data-v-b2389082>
                High Quality &amp; Low Capex
                <!----> <!----> <!----> <!----></a><a href="/screener?name=High%20Yield%20Insider%20Buys&amp;id=88" class="navbar-link" data-v-b2389082>
                High Yield Insider Buys
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Historical%20High%20Dividend%20Yields&amp;id=89" class="navbar-link" data-v-b2389082>
                Historical High Dividend Yields
                <!----> <!----> <!----> <!----></a><a href="/screener?name=International%20Gurus%27%20Top%20Holdings&amp;id=90" class="navbar-link" data-v-b2389082>
                International Gurus' Top Holdings
                <!----> <!----> <!----> <!----></a><a href="/screener?name=James%20Montier%20Short%20Screen&amp;id=91" class="navbar-link" data-v-b2389082>
                James Montier Short Screen
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Margin%20Decliners&amp;id=92" class="navbar-link" data-v-b2389082>
                Margin Decliners
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Mega%20Caps&amp;id=93" class="navbar-link" data-v-b2389082>
                Mega Caps
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Peter%20Lynch%20&amp;%20Warren%20Buffett&amp;id=94" class="navbar-link" data-v-b2389082>
                Peter Lynch &amp; Warren Buffett
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Peter%20Lynch%20Growth%20w%20Lower%20Valuation&amp;id=95" class="navbar-link" data-v-b2389082>
                Peter Lynch Growth w Lower Valuation
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Peter%20Lynch%20S&amp;L%20Traded%20Below%20Book&amp;id=96" class="navbar-link" data-v-b2389082>
                Peter Lynch S&amp;L Traded Below Book
                <!----> <!----> <!----> <!----></a><a href="/screener?name=PFCF%20Screener&amp;id=97" class="navbar-link" data-v-b2389082>
                PFCF Screener
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Piotroski%20Score%20Screener&amp;id=98" class="navbar-link" data-v-b2389082>
                Piotroski Score Screener
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Predictable%20Companies&amp;id=99" class="navbar-link" data-v-b2389082>
                Predictable Growth Companies
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Profitable%20predictable%20margin%20expanders&amp;id=100" class="navbar-link" data-v-b2389082>
                Profitable predictable margin expanders
                <!----> <!----> <!----> <!----></a><!----><a href="/screener?name=Stocks%20Sold%20w%20less%20Cash&amp;id=102" class="navbar-link" data-v-b2389082>
                Stocks Sold w less Cash
                <!----> <!----> <!----> <!----></a><a href="/screener?name=The%20Stalwarts&amp;id=104" class="navbar-link" data-v-b2389082>
                The Stalwarts
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/screener?manage=screen" class="t-icon" data-v-b2389082>
                  My Screeners
                </a></div> <a href="/screener" class="navbar-link" data-v-b2389082>
                Create My Screener
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/ideas" class="t-icon" data-v-b2389082>
                  Value Screens
                </a></div> <a href="/ideas" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-b2389082>
                Stock Ideas
                <!----> <!----> <!----> <!----></a><a href="/screener" class="navbar-link" data-v-b2389082>
                All-In-One Screener
                <!----> <!----> <!----> <!----></a><a href="/screener?view=map&amp;show_header=false" class="navbar-link" data-v-b2389082>
                S&amp;P 500 Map
                <!----> <!----> <!----> <!----></a><a href="/screener?view=bubble&amp;show_header=false" class="navbar-link" data-v-b2389082>
                S&amp;P 500 Bubble
                <!----> <!----> <!----> <!----></a><a href="/screener?view=aggregate&amp;show_header=false" class="navbar-link" data-v-b2389082>
                S&amp;P 500 Aggregate
                <!----> <!----> <!----> <!----></a><a href="/screener/buffett-munger" class="navbar-link" data-v-b2389082>
                Buffett-Munger Screener
                <!----> <!----> <!----> <!----></a><a href="/industry" class="navbar-link" data-v-b2389082>
                Industry Overview
                <!----> <!----> <!----> <!----></a><a href="/screener/valuedcf" class="navbar-link" data-v-b2389082>
                Undervalued Predictable
                <!----> <!----> <!----> <!----></a><a href="/screener/grahamncav" class="navbar-link" data-v-b2389082>
                Benjamin Graham Net-Net
                <!----> <!----> <!----> <!----></a><a href="/screener/52weeklow" class="navbar-link" data-v-b2389082>
                52-week/3Y/5Y Lows
                <!----> <!----> <!----> <!----></a><a href="/screener/52weekhigh" class="navbar-link" data-v-b2389082>
                52-week/3Y/5Y Highs
                <!----> <!----> <!----> <!----></a><a href="/screener/magic-formula" class="navbar-link" data-v-b2389082>
                Magic Formula(Greenblatt)
                <!----> <!----> <!----> <!----></a><a href="/screener/dividend-stocks" class="navbar-link" data-v-b2389082>
                Dividend Stocks
                <!----> <!----> <!----> <!----></a><a href="/screener/peter-lynch-stocks" class="navbar-link" data-v-b2389082>
                Peter Lynch Screen
                <!----> <!----> <!----> <!----></a><a href="/screener/guru-sp-grid" class="navbar-link" data-v-b2389082>
                S&amp;P500 Grid
                <!----> <!----> <!----> <!----></a><a href="/screener/predictable" class="navbar-link" data-v-b2389082>
                Predictable Companies
                <!----> <!----> <!----> <!----></a><a href="/screener/spinoff" class="navbar-link" data-v-b2389082>
                Spin Off List
                <!----> <!----> <!----> <!----></a><a href="/screener/lowpb" class="navbar-link" data-v-b2389082>
                Historical Low P/B List
                <!----> <!----> <!----> <!----></a><a href="/screener/lowps" class="navbar-link" data-v-b2389082>
                Historical Low P/S List
                <!----> <!----> <!----> <!----></a><a href="/screener/short-stocks" class="navbar-link" data-v-b2389082>
                High Short Interest
                <!----> <!----> <!----> <!----></a><a href="/screener/upcoming-special-dividends" class="navbar-link" data-v-b2389082>
                Upcoming Special Dividends
                <!----> <!----> <!----> <!----></a><a href="/screener/delisted" class="navbar-link" data-v-b2389082>
                Delisted Stocks
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="https://www.gurufocus.com/model_portfolio.php" class="t-icon" data-v-b2389082>
                  Model Portfolios
                </a></div> <a href="https://www.gurufocus.com/model_portfolio.php" class="navbar-link" data-v-b2389082>
                Performances Overview
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=largecap" class="navbar-link" data-v-b2389082>
                Most Broadly Held Portfolio
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=hr_largecap" class="navbar-link" data-v-b2389082>
                Most Weighted Portfolio
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=midcap" class="navbar-link" data-v-b2389082>
                Buffett-Munger Top 25
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=gfscore_91_100" class="navbar-link" data-v-b2389082>
                GF Score &lt;= 100 Top 25
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=smallcap" class="navbar-link" data-v-b2389082>
                Top 25 Undervalued Predictable
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=cap20" class="navbar-link" data-v-b2389082>
                Top 25 52-week Low Predictable
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=cap40" class="navbar-link" data-v-b2389082>
                Top 25 Historical Low P/S
              </a></div><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/ideas" class="t-icon" data-v-b2389082>
                  Stock Comparison
                </a></div> <a href="/ideas/airline-stocks" class="navbar-link" data-v-b2389082>
                Airline Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/artificial-intelligence-stocks" class="navbar-link" data-v-b2389082>
                Artificial Intelligence Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/bank-stocks" class="navbar-link" data-v-b2389082>
                Bank Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/biotech-stocks" class="navbar-link" data-v-b2389082>
                Biotech Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/blockchain-stocks" class="navbar-link" data-v-b2389082>
                Blockchain Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/chinese-stocks" class="navbar-link" data-v-b2389082>
                Chinese Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/dividend-stocks" class="navbar-link" data-v-b2389082>
                Dividend Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/ev-stocks" class="navbar-link" data-v-b2389082>
                EV Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/growth-stocks" class="navbar-link" data-v-b2389082>
                Growth Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/oil-stocks" class="navbar-link" data-v-b2389082>
                Oil Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/value-stocks" class="navbar-link" data-v-b2389082>
                Value Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/virtual-reality-stocks" class="navbar-link" data-v-b2389082>
                Virtual Reality Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas#compare-stocks" class="navbar-link" data-v-b2389082>
                Compare More Stocks…
                <!----> <!----> <!----> <!----></a></div></div></div><div class="navbar-item" style="padding:0 !important;" data-v-b2389082><div data-v-b2389082><a href="/guru/latest-picks" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-b2389082> Gurus
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-b2389082></i></a></div> <div class="navbar-dropdown" data-v-b2389082><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/guru/latest-picks" class="t-icon" data-v-b2389082>
                  Guru Trades
                </a></div> <a href="/guru/latest-picks" class="navbar-link" data-v-b2389082>
                Latest Guru Picks
                <!----> <!----> <!----> <!----></a><a href="/guru/realtime-picks" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-b2389082>
                Real Time Picks
                <!----> <!----> <!----> <!----></a><a href="/guru/portfolio" class="navbar-link" data-v-b2389082>
                Guru Portfolio
                <!----> <!----> <!----> <!----></a><a href="/guru/top-holdings" class="navbar-link" data-v-b2389082>
                Top 10 Holdings View
                <!----> <!----> <!----> <!----></a><a href="/guru/bargains" class="navbar-link" data-v-b2389082>
                Guru Bargains
                <!----> <!----> <!----> <!----></a><a href="/guru/hot-picks" class="navbar-link" data-v-b2389082>
                Hot Picks
                <!----> <!----> <!----> <!----></a><a href="/guru/aggregated-portfolio" class="navbar-link" data-v-b2389082>
                Aggregated Portfolio
                <!----> <!----> <!----> <!----></a><a href="/guru/consensus-picks" class="navbar-link" data-v-b2389082>
                Consensus Picks
                <!----> <!----> <!----> <!----></a><a href="/guru/etfs" class="navbar-link" data-v-b2389082>
                ETFs
                <!----> <!----> <!----> <!----></a><a href="/guru/scoreboard" class="navbar-link" data-v-b2389082>
                Score Board
                <!----> <!----> <!----> <!----></a><a href="/guru/sector-picks" class="navbar-link" data-v-b2389082>
                Sector Picks
                <!----> <!----> <!----> <!----></a><a href="/guru/international-picks" class="navbar-link" data-v-b2389082>
                International Picks
                <!----> <!----> <!----> <!----></a><a href="/guru/industry-trends" class="navbar-link" data-v-b2389082>
                Industry Trends
                <!----> <!----> <!----> <!----></a><a href="/guru/geographic-trends" class="navbar-link" data-v-b2389082>
                Geographic Trend
                <!----> <!----> <!----> <!----></a><a href="/guru/option-holdings" class="navbar-link" data-v-b2389082>
                Options
                <!----> <!----> <!----> <!----></a><a href="/guru/european-shortings" class="navbar-link" data-v-b2389082>
                European Shorting
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/guru/list" class="t-icon" data-v-b2389082>
                  Guru Lists
                </a></div> <a href="/guru/list" class="navbar-link" data-v-b2389082>
                Complete Guru List
                <!----> <!----> <!----> <!----></a><a href="/guru/warren+buffett/summary" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-b2389082>
                Warren Buffett
                <!----> <!----> <!----> <!----></a><a href="/guru/bill+gates/summary" class="navbar-link" data-v-b2389082>
                Bill Gates
                <!----> <!----> <!----> <!----></a><a href="/guru/mohnish+pabrai/summary" class="navbar-link" data-v-b2389082>
                Mohnish Pabrai
                <!----> <!----> <!----> <!----></a><a href="/guru/carl+icahn/summary" class="navbar-link" data-v-b2389082>
                Carl Icahn
                <!----> <!----> <!----> <!----></a><a href="/guru/george+soros/summary" class="navbar-link" data-v-b2389082>
                George Soros
                <!----> <!----> <!----> <!----></a><a href="/guru/david+tepper/summary" class="navbar-link" data-v-b2389082>
                David Tepper
                <!----> <!----> <!----> <!----></a><a href="/guru/seth+klarman/summary" class="navbar-link" data-v-b2389082>
                Seth Klarman
                <!----> <!----> <!----> <!----></a><a href="/guru/bill+ackman/summary" class="navbar-link" data-v-b2389082>
                Bill Ackman
                <!----> <!----> <!----> <!----></a><a href="/guru/joel+greenblatt/summary" class="navbar-link" data-v-b2389082>
                Joel Greenblatt
                <!----> <!----> <!----> <!----></a><a href="/guru/charlie+munger/summary" class="navbar-link" data-v-b2389082>
                Charlie Munger
                <!----> <!----> <!----> <!----></a><a href="/guru/michael+price/summary" class="navbar-link" data-v-b2389082>
                Michael Price
                <!----> <!----> <!----> <!----></a><a href="/guru/julian+robertson/summary" class="navbar-link" data-v-b2389082>
                Julian Robertson
                <!----> <!----> <!----> <!----></a><a href="/guru/chuck+akre/summary" class="navbar-link" data-v-b2389082>
                Chuck Akre
                <!----> <!----> <!----> <!----></a><a href="/guru/david+einhorn/summary" class="navbar-link" data-v-b2389082>
                David Einhorn
                <!----> <!----> <!----> <!----></a><a href="/guru/tom+gayner/summary" class="navbar-link" data-v-b2389082>
                Tom Gayner
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/guru/list" class="t-icon" data-v-b2389082>
                  My Guru Lists
                </a></div> </div></div></div><div class="navbar-item" style="padding:0 !important;" data-v-b2389082><div data-v-b2389082><a href="/insider/summary" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-b2389082> Insiders
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-b2389082></i></a></div> <div class="navbar-dropdown" data-v-b2389082><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/insider/summary" class="t-icon" data-v-b2389082>
                  Insider Trading Tracker
                </a></div> <a href="/insider/summary" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-b2389082>
                Real-Time Insider Picks
                <!----> <!----> <!----> <!----></a><a href="/insider/ceo" class="navbar-link" data-v-b2389082>
                CEO Buys/Sells
                <!----> <!----> <!----> <!----></a><a href="/insider/cfo" class="navbar-link" data-v-b2389082>
                CFO Buys/Sells
                <!----> <!----> <!----> <!----></a><a href="/insider/trend" class="navbar-link" data-v-b2389082>
                Insider Trends
                <!----> <!----> <!----> <!----></a><a href="/insider/cluster" class="navbar-link" data-v-b2389082>
                Insider Cluster
                <!----> <!----> <!----> <!----></a><a href="/insider/double" class="navbar-link" data-v-b2389082>
                Guru + Insider Double Buys
                <!----> <!----> <!----> <!----></a><a href="/insider/triple" class="navbar-link" data-v-b2389082>
                Triple Buys/Sells
                <!----> <!----> <!----> <!----></a><a href="/insider/chinese" class="navbar-link" data-v-b2389082>
                Chinese Insider
                <!----> <!----> <!----> <!----></a><a href="/insiders" class="navbar-link" data-v-b2389082>
                Complete Insider List
                <!----> <!----> <!----> <!----></a></div></div></div><div class="navbar-item" style="padding:0 !important;" data-v-b2389082><div data-v-b2389082><a href="/economic_indicators" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-b2389082> Market
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-b2389082></i></a></div> <div class="navbar-dropdown" data-v-b2389082><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/stock-market-valuations.php" class="t-icon" data-v-b2389082>
                  US Market Valuation
                </a></div> <a href="https://www.gurufocus.com/stock-market-valuations.php" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-b2389082>
                Buffett Indicator
              </a><a href="https://www.gurufocus.com/yield_curve.php" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-b2389082>
                U.S. Treasury Yield Curve
              </a><a href="https://www.gurufocus.com/shiller-PE.php" class="navbar-link" data-v-b2389082>
                Shiller P/E
              </a><a href="https://www.gurufocus.com/sector_shiller_pe.php" class="navbar-link" data-v-b2389082>
                Shiller P/E by Sectors
              </a><a href="/market/sp500-gf-value" class="navbar-link" data-v-b2389082>
                GF Value for S&amp;P 500 Index
                <!----> <!----> <!----> <!----></a><a href="https://www.gurufocus.com/buffett_assets_allocations.php" class="navbar-link" data-v-b2389082>
                Buffett Assets Allocation
              </a></div><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/global-market-valuation.php" class="t-icon" data-v-b2389082>
                  Global Market Valuation
                </a></div> <a href="https://www.gurufocus.com/global-market-valuation.php" class="navbar-link" data-v-b2389082>
                Global Market Overview
              </a><a href="https://www.gurufocus.com/stock-market-valuations.php" class="navbar-link" data-v-b2389082>
                USA
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=CHN" class="navbar-link" data-v-b2389082>
                China
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=JPN" class="navbar-link" data-v-b2389082>
                Japan
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=IND" class="navbar-link" data-v-b2389082>
                India
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=CND" class="navbar-link" data-v-b2389082>
                Canada
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=GBR" class="navbar-link" data-v-b2389082>
                UK
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=CND" class="navbar-link" data-v-b2389082>
                France
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=GER" class="navbar-link" data-v-b2389082>
                Germany
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=BRZ" class="navbar-link" data-v-b2389082>
                Brazil
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=AUS" class="navbar-link" data-v-b2389082>
                Australia
              </a><a href="https://www.gurufocus.com/global-market-valuation.php" class="navbar-link" data-v-b2389082>
                More...
              </a></div><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/economic_indicators" class="t-icon" data-v-b2389082>
                  Economic Indicators
                </a></div> <a href="/economic_indicators" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-b2389082>
                Economic Indicators Overview
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/229/the-dow-jones-industrial-average-djia" class="navbar-link" data-v-b2389082>
                The Dow Jones Industrial Average (DJIA)
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/63/sp-500-index" class="navbar-link" data-v-b2389082>
                SP 500 Index
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/232/nasdaq-composite-index" class="navbar-link" data-v-b2389082>
                Nasdaq Composite Index
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/20/gross-domestic-product-gdp" class="navbar-link" data-v-b2389082>
                Gross Domestic Product (GDP)
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/56/shiller-pe" class="navbar-link" data-v-b2389082>
                Shiller PE
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/60/ratio-of-wilshire-5000-over-gnp" class="navbar-link" data-v-b2389082>
                Ratio of Wilshire 5000 over GNP
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/10/civilian-unemployment-rate" class="navbar-link" data-v-b2389082>
                Civilian Unemployment Rate
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/231/russell-2000-small-cap-price-index" class="navbar-link" data-v-b2389082>
                Russell 2000 Small Cap Price Index
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/234/cboe-volatility-index-the-vix" class="navbar-link" data-v-b2389082>
                CBOE Volatility Index (VIX)
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/14/total-nonfarm-payrolls-all-employees" class="navbar-link" data-v-b2389082>
                Total Nonfarm Payrolls: All Employees
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators" class="navbar-link" data-v-b2389082>
                More...
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/industry" class="t-icon" data-v-b2389082>
                  Sector &amp; Industry Performance
                </a></div> <a href="/industry" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-b2389082>
                Global Industry Overview
                <!----> <!----> <!----> <!----></a><a href="/industry/usa" class="navbar-link" data-v-b2389082>
                USA
                <!----> <!----> <!----> <!----></a><a href="/industry/asia" class="navbar-link" data-v-b2389082>
                Asia
                <!----> <!----> <!----> <!----></a><a href="/industry/europe" class="navbar-link" data-v-b2389082>
                Europe
                <!----> <!----> <!----> <!----></a><a href="/industry/canada" class="navbar-link" data-v-b2389082>
                Canada
                <!----> <!----> <!----> <!----></a><a href="/industry/uk-ireland" class="navbar-link" data-v-b2389082>
                UK/Ireland
                <!----> <!----> <!----> <!----></a><a href="/industry/oceania" class="navbar-link" data-v-b2389082>
                Oceania
                <!----> <!----> <!----> <!----></a><a href="/industry/latin-america" class="navbar-link" data-v-b2389082>
                Latin America
                <!----> <!----> <!----> <!----></a><a href="/industry/africa" class="navbar-link" data-v-b2389082>
                Africa
                <!----> <!----> <!----> <!----></a><a href="/industry/india-pakistan" class="navbar-link" data-v-b2389082>
                India/Pakistan
                <!----> <!----> <!----> <!----></a></div></div></div><div class="navbar-item" style="padding:0 !important;" data-v-b2389082><div data-v-b2389082><a href="/news?cat=timeless" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-b2389082> Articles
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-b2389082></i></a></div> <div class="navbar-dropdown" data-v-b2389082><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/news" class="t-icon" data-v-b2389082>
                  Articles
                </a></div> <a href="/news?cat=timeless" class="navbar-link" data-v-b2389082>
                Editors' Picks
                <!----> <!----> <!----> <!----></a><a href="/news?cat=qa" class="navbar-link" data-v-b2389082>
                Q&amp;A with Gurus
                <!----> <!----> <!----> <!----></a><a href="/news?cat=rank" class="navbar-link" data-v-b2389082>
                Top Ranked
                <!----> <!----> <!----> <!----></a><a href="/news?cat=guru" class="navbar-link" data-v-b2389082>
                News
                <!----> <!----> <!----> <!----></a><a href="/news?cat=contest" class="navbar-link" data-v-b2389082>
                Value Idea Contest
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-b2389082><div class="navbar-sub-title" data-v-b2389082><a href="/news/post" class="t-icon" data-v-b2389082>
                  Submit Articles
                </a></div> <a href="/news/post" class="navbar-link" data-v-b2389082>
                Submit Article Online
                <!----> <!----> <!----> <!----></a><a href="https://www.gurufocus.com/news/70028" class="navbar-link" data-v-b2389082>
                Writers Wanted
              </a></div></div></div><div class="navbar-item" style="padding:0 !important;" data-v-b2389082><div data-v-b2389082><div class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-b2389082> Tools
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-b2389082></i></div></div> <div class="navbar-dropdown" data-v-b2389082><a href="https://www.gurufocus.com/model_portfolio.php" class="navbar-link" data-v-b2389082><!----> <!---->
              Model Portfolios
            </a><a href="/screener" class="navbar-link" data-v-b2389082>
              All-In-One Screener
            </a><a href="https://www.gurufocus.com/download_financials_batch.php" class="navbar-link" data-v-b2389082><!----> <!---->
              Data Batch Download
            </a><a href="/guru/download-guru-portfolio" class="navbar-link" data-v-b2389082>
              Guru Portfolio Download
            </a><a href="/insider/data-export" class="navbar-link" data-v-b2389082>
              Insider Data Download
            </a><a href="/excel-add-in" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-b2389082>
              Excel Add-In
            </a><a href="/google-sheets-add-on" class="navbar-link" data-v-b2389082>
              Google Sheets Add-On
            </a><a href="/api" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-b2389082>
              API
            </a><a href="https://www.gurufocus.com/download_stockmanual.php" class="navbar-link" data-v-b2389082><!----> <!---->
              Manual of Stocks
            </a><a href="/stock/AAPL/dcf" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-b2389082>
              DCF Calculator
            </a><a href="/stock/AAPL/chart" class="navbar-link" data-v-b2389082>
              Interactive Chart
            </a><a href="/screener?view=map&amp;show_header=false" class="navbar-link" data-v-b2389082>
              Maps
            </a><a href="/fund-letters" class="navbar-link" data-v-b2389082>
              Fund Letters Archive
            </a><a href="/compare-table" class="navbar-link" data-v-b2389082>
              Stock Comparison Table
            </a><a href="/mobile-app" class="navbar-link" data-v-b2389082>
              Mobile App
            </a><a href="/discussion" class="navbar-link" data-v-b2389082>
              Discussion Board
            </a></div></div><div class="navbar-item" style="padding:0 !important;" data-v-b2389082><div data-v-b2389082><a href="https://gurufocusetf.com/" target="_blank" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-b2389082> ETF
          <!----></a></div> <!----></div><div class="navbar-item" style="padding:0 !important;" data-v-b2389082><div data-v-b2389082><a href="/pricing" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-b2389082> Pricing
          <!----></a></div> <!----></div><div class="navbar-item navbar-right-item" style="padding:0 !important;" data-v-b2389082><div data-v-b2389082><a href="/tutorial" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-b2389082> Tutorials
          <!----></a></div> <div class="navbar-dropdown" data-v-b2389082><a href="/tutorial" class="navbar-link" data-v-b2389082>
              Tutorials 
            </a><a href="/glossary" class="navbar-link" data-v-b2389082>
              Financial Glossary
            </a><a href="https://www.gurufocus.com/faq.php" class="navbar-link" data-v-b2389082><!----> <!---->
              FAQ
            </a><a href="/changelog" class="navbar-link" data-v-b2389082>
              Change Log
            </a><a href="https://www.gurufocus.com/ticket/open.php" class="navbar-link" data-v-b2389082><!----> <!---->
              Contact Us
            </a></div></div><div class="navbar-item navbar-right-item" style="padding:0 !important;" data-v-b2389082><div data-v-b2389082><div class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-b2389082> Support
          <!----></div></div> <div class="navbar-dropdown" data-v-b2389082><span data-name="Support" slot="reference" data-v-b2389082><span class="navbar-link nuxt-link-exact-active nuxt-link-active"><i class="gfp-live-chat"></i>
    Chat Support
  </span> <div id="phplive_btn_1570480208"></div></span><a href="https://www.gurufocus.com/ticket/open.php" target="_blank" class="navbar-link" data-v-b2389082><i class="gf-icon-tickets" data-v-b2389082></i>
              Create a ticket
            </a><a href="/schedule_meeting" class="navbar-link" data-v-b2389082><i class="gfp-calendar" data-v-b2389082></i>
              Schedule a Meeting
            </a><span slot="reference" class="phone-session" data-v-c1848554 data-v-b2389082><span data-v-c1848554><i class="gf-icon-phone" data-v-c1848554></i>
    469-248-6885
  </span></span><a href="https://status.gurufocus.com/" class="navbar-link" data-v-b2389082><!----> <i class="gf-icon-wrench" data-v-b2389082></i>
              Status
            </a></div></div> <div class="navbar-item navbar-item-hoverable navbar-right-item" style="padding:0 !important;" data-v-7b891cb3 data-v-b2389082><div data-v-7b891cb3><a href="/pricing?ref=news-message_id-subject&amp;sel=premium&amp;utm_source=webApp_fromPricing&amp;utm_medium=userClick&amp;utm_campaign=new_navbar_free_trial_fromPricing" class="block p-v-lg p-h-sm" data-v-7b891cb3><span class="basic-navbar-title" data-v-7b891cb3>
        Subscribe
      </span></a></div> <div class="navbar-dropdown" data-v-7b891cb3><a href="/pricing?ref=news-message_id-subject&amp;sel=premium&amp;utm_source=webApp_fromPricing&amp;utm_medium=userClick&amp;utm_campaign=new_navbar_free_trial_item_fromPricing" class="navbar-link" data-v-7b891cb3>
      Free Trial
    </a><a href="https://www.gurufocus.com/user_referrals.php" class="navbar-link" data-v-7b891cb3>
      Refer a Friend and Earn $50
    </a></div></div> <!----></div> <div class="el-dialog__wrapper" style="display:none;" data-v-b2389082><div role="dialog" aria-modal="true" aria-label="dialog" class="el-dialog" style="margin-top:15vh;width:800px;"><div class="el-dialog__header"><span class="el-dialog__title"></span><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><!----><div class="el-dialog__footer"><span class="dialog-footer" data-v-b2389082><button type="button" class="el-button el-button--default el-button--mini" data-v-b2389082><!----><!----><span>Cancel</span></button> <button type="button" class="el-button el-button--primary el-button--mini" data-v-b2389082><!----><!----><span>Confirm</span></button></span></div></div></div></div> <div id="tags-view" class="tags-view" style="padding-left:0px;" data-v-96daf91c><!----></div> <section class="el-container"><main id="components-root" class="el-main auto-height-on-print capture-areaz" style="height:calc(100vh - 110px);"><section class="el-container enable-darkmode is-vertical" data-v-faf6c114><main class="el-main center" data-v-faf6c114 data-v-faf6c114><div frame="frame-xl" class="gf center" style="padding-bottom:0px;" data-v-04d79f4b data-v-faf6c114><div class="el-row" style="margin-left:-20px;margin-right:-20px;" data-v-04d79f4b><div id="article-main-section-1880400" class="el-col el-col-16" style="padding-left:20px;padding-right:20px;" data-v-04d79f4b><h1 class="t-h1 fc-primary fw-bolder subject" data-v-04d79f4b> SeaStar Medical Completes Business Combination with LMF Acquisition Opportunities
        <!----> <!----> <!----></h1> <!----> <!----> <div class="row-padding" data-v-f5b5b832 data-v-04d79f4b><div class="author-item global-flex-container" data-v-f5b5b832><div style="margin-right: 12px;" data-v-f5b5b832><a href="/user/undefined" class="left avatar" data-v-f5b5b832><img alt="Author's Avatar" height="48px" width="48px" src="https://ui-avatars.com/api/?length=2&amp;background=random&amp;name=User" style="vertical-align:middle;border-radius:50%;object-fit:scale-down;" data-v-f5b5b832></a></div> <div data-v-f5b5b832><div data-v-f5b5b832><a href="/user/undefined" class="fc-normal-i body-small fw-bolder" style="margin-right: 12px;" data-v-f5b5b832><span data-v-f5b5b832> Value_Insider </span></a> <button type="button" class="el-button gf no-border el-button--primary el-button--mini" data-v-f5b5b832><!----><!----><span>Follow</span></button></div> <div class="body-small fc-light" style="line-height: 24px; margin-top: 2px;" data-v-f5b5b832><span data-v-f5b5b832> 5 minutes ago </span></div></div></div> <div class="fc-normal global-flex-container fc-normal" style="float:right;position:relative;top:-34px;font-size:24px;" data-v-f5b5b832><!----> <div><span style="display:inline-block !important;" data-v-809c1338><i class="el-icon-collection" style="cursor: pointer;font-size: 20px;" data-v-809c1338></i> <div class="el-dialog__wrapper" style="display:none;" data-v-809c1338><div role="dialog" aria-modal="true" aria-label="Bookmark" class="el-dialog" style="margin-top:15vh;"><div class="el-dialog__header"><span class="el-dialog__title">Bookmark</span><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><!----><div class="el-dialog__footer"><span class="dialog-footer" data-v-809c1338><button type="button" class="el-button el-button--default el-button--mini" data-v-809c1338><!----><!----><span>Cancel</span></button> <button type="button" class="el-button el-button--primary el-button--mini" data-v-809c1338><!----><!----><span>Confirm</span></button></span></div></div></div></span> <span class="share-button" style="display:inline-block !important;" data-v-058a2f4c><div role="tooltip" id="el-popover-4745" aria-hidden="true" class="el-popover el-popper gf aio-popover no-padding" style="width:undefinedpx;display:none;"><!----><!----></div><span title="Share &amp; Print" class=" " style="background:transparent;" data-v-058a2f4c><i class="gf-icon-share hover-pointer" data-v-058a2f4c></i></span></span> <i class="gf-icon-printer cursor-pointer"></i></div></div></div> <!----> <img src="" alt="Article's Main Image" title="" width="50%" style="padding-top:40px;max-height:600px;display:block;margin:auto;padding-bottom:10px;object-fit:contain;float:left;margin-right:24px;" data-v-04d79f4b> <div id="article-body-1880400" class="main-body" style="margin-top:40px;" data-v-04d79f4b><div class="mw_release"><p><em>LMF Acquisition Opportunities Renamed SeaStar Medical Holding Corporation</em><br></p> <p><em>SeaStar Medical Holding Corporation Common Stock and Warrants to Commence Trading on Nasdaq Under New Ticker Symbol “ICU” and “ICUCW”</em></p> <p>DENVER and TAMPA, Fla., Oct.  28, 2022  (GLOBE NEWSWIRE) -- SeaStar Medical, Inc., a medical technology company developing proprietary solutions to reduce the consequences of hyperinflammation on vital organs, today announced that it has completed its <a href="https://www.globenewswire.com/Tracker?data=5LPeZOhkxHR7vk5Jqz3z74gmfCJgH9KyMxooPi0Q0xYgRVuTR_rE6PhMZBV_4BQp8Sm6WaZggbOKjBikx9NWMgeXX3RdRjfen_XBEdlIusVlJlEQZWSxXp12seZZqdmDQ9JXd7XhgrCibcECLpMxcsYdEG1J_qEfRWlYY8I3B9kvfiwdAVtljZYdqCwpdHxN" rel="nofollow" target="_blank">previously announced</a> business combination with LMF Acquisition Opportunities, Inc. (<span data-v-23e1831b><div role="tooltip" id="el-popover-2665" aria-hidden="true" class="el-popover el-popper  gf" style="width:undefinedpx;display:none;"><!----><!----></div><a href="/stock/LMAO/summary" target="" class="color-primary" data-v-23e1831b>LMAO</a></span><span>, </span><a target="_blank" title href="/stock/LMAO/financials" class="stock-link">Financial</a>) (<span data-v-23e1831b><div role="tooltip" id="el-popover-7067" aria-hidden="true" class="el-popover el-popper  gf" style="width:undefinedpx;display:none;"><!----><!----></div><a href="/stock/LMAO/summary" target="" class="color-primary" data-v-23e1831b>LMAO</a></span><span>, </span><a target="_blank" title href="/stock/LMAO/financials" class="stock-link">Financial</a>), a special purpose acquisition company sponsored by LM Funding America, Inc. ( LMFA). The business combination closed on October 28, 2022.</p> <p>Following the closing of the business combination, LMF Acquisition Opportunities, Inc. was renamed SeaStar Medical Holding Corporation and will operate under the same management team as SeaStar Medical, which is led by Eric Schlorff, CEO. Caryl Baron will serve as interim CFO. The common stock and warrants of SeaStar Medical Holding Corporation are expected to begin trading on Nasdaq on October 31, 2022, under the new ticker symbols “ICU” and “ICUCW,” respectively.</p> <p>The transaction was unanimously approved by both Boards of Directors of SeaStar Medical and LMAO. The holders of a majority of the SeaStar Medical voting power have approved the merger. Stockholders of LMAO approved the transaction at a special meeting of LMAO stockholders on October 18, 2022, with more than 96% of the votes cast supporting the transaction.</p> <p>Eric Schlorff, President and Chief Executive Officer of SeaStar Medical Holding Corporation, stated, “We are excited to begin the next phase of our journey as a public company. This transaction provides us greater resources to advance our Selective Cytopheretic Device (SCD) for patients suffering from the devastating consequences of hyperinflammation. We have submitted our Humanitarian Device Exemption (HDE) application to the U.S. Food and Drug Administration (FDA) for pediatric use, and we plan to launch a pivotal study of the SCD in adults with acute kidney injury (AKI) in the first quarter of 2023. As a public company, we will be better positioned to move these programs forward.”</p> <p>Bruce M. Rodgers, Chairman and CEO of LM Funding, the sponsor of LMF Acquisition Opportunities, commented, “We are proud that all of our hard work over the past several years has led us to this very significant milestone. We are extremely pleased that the transaction received the overwhelming support of the stockholders of LMF Acquisition and believe it will unlock significant value for the stockholders of LM Funding and SeaStar Medical. We look forward to supporting SeaStar Medical Holding Corporation as they continue to advance potentially lifesaving therapies as a public company.”</p> <p>Maxim Group LLC served as sole financial advisor and Morgan Lewis &amp; Bockius LLP served as legal counsel to SeaStar Medical in connection with the business combination. Foley &amp; Lardner LLP served as legal counsel to LMAO in connection with the business combination. Ellenoff Grossman &amp; Schole LLP served as legal counsel to Maxim Group LLC.</p> <p><strong>About SeaStar Medical, Inc.</strong></p> <p>Denver-based SeaStar Medical is a medical technology company that is focusing on redefining how extracorporeal therapies may reduce the consequences of excessive inflammation on vital organs. SeaStar Medical’s novel technologies rely on science and innovation to provide life-saving solutions to critically ill patients. It is developing and commercializing extracorporeal therapies that target the effector cells that drive systemic inflammation, causing direct tissue damage and secreting a range of pro-inflammatory cytokines that initiate and propagate imbalanced immune responses. For more information visit <a href="https://www.globenewswire.com/Tracker?data=gvoDMAqAQ9PXjSx5SOidWruhuQ24eSJrloFB2I3fCuWF1QJaIr9m6e4ZWeTtMu1VSh2h1ao_5QUDnswFqBuW-Fmn8N7khOLkvBn4CeWguh1rDbz4inW8hoQbsgxg1LdL6gq2vrowWKWL2zPMKxGqS74_KKXerWXv5nRcsdci1CuezR7E6MTTRrVFqdXe41CgaCVH6IMqrNouFBQZIkpGJF3GfTBEN7jPqZFtRA8iPid7XQtIY8eYmpmx9SUy3ommWirvkwNk1KItA3L7Au4JIiwFGjNgTXv7niriMwjEcGtgDQvVSr2j2DQu7K1pq-G6vVo_9OipohzFK79DJnb11dRUt5kmbEEb6MexEjR7xXcSB-PsHcUKMjjVihnV2gA_mIYmgGzWOkZQxtl-snSoSZiph-rqkiSBhd3Siq1gk7oSvly7sI-bJauD3NzoYoc3eE3ZmO3vaA9ydXXXW0s48jndKtfo16Boqk9ds-I5F45lrTCabkEwM24Et0DC97gcshUpqfVL02VkYQgrV2JReQ==" rel="nofollow" target="_blank">http://www.seastarmedical.com/</a> or visit us on <a href="https://www.globenewswire.com/Tracker?data=KOar8xYOz0pooriy4Ucyu1uYlLHhMZvLilW6IlQpxjhEDUzgUj0Pjsd_Y3e_0ZFOTIuBKMPb81uFk2Y7aXT3bjlj5NPF8y5PbPSuR5M6jKIzdhYZqAFk5Dp89EmfPijDWtYUXOmkXR5gmWSoZtgkG4B0FKWZy2gBriK81RWgLIGIr3WXrdkHbNAUSq397OGPj4EyxPnErqzZ6OGdgUOgOD0nywiHmdIHt7kWf1wlo0aCyJU_NZnNcYh1Lz3LkwZbSzl5yUOGOfnfHKYFpNW3-25MY0UKvRi-Nw6Z1fBQaUHLADgF5_Ri85D46C2RjqzVL7R7AQKExIuZcki3YnEC2Jh0G6cD6t1KTcKNxzEom8EyUuBT2TRJ0975CmZdtiFadWScNN-rc3hQi8tUrbpj59DIWq7lMrvoIFfbrTHHvPVMhXl-9OkqUPHO-VCJiAxHolmbJNAqvWffWAEJBh2SFaXg75GYy6t6B7nrecwRmZvLkc18N0_6eOyIkMT27qytY8iGscW4s2gqnpcJsp1UF2Ndmk2gLB1Rzt03iAlqxWupI54n74rXbfkdsfIm6D7sTngVh4amiUmZPHty8YpaVr-ZrjwxQqXGJIrelpDCx4AKsbgWG0HQkoG4whDBCDk-2i0CNBhT1SgpKr_loKQgciSFOxATO87gHB3DYBw0-gTPyA-7QLS9sKvskJbeF4iDDX6B1rSxrFRx6WXJ7ITsC9fU-ay7YkyWP_jkz3HtHUI3kguywGwNIbswneF4tw8A" rel="nofollow" target="_blank">LinkedIn</a> or <a href="https://www.globenewswire.com/Tracker?data=s4dwcw0v56SzT-NWQiTojNNTWdc3UCEiOlApVlko3fyjEBULjNbRWwPKbghhd7sXePd0EO1EXWMd8nX0yWs2cyn-D9jQ8lSPiyLud_m7x8BOjRWGfaCAZb4IWMu6GAESyF4385TP1-ulKUk1_cn4igcUkRSxSBEOmxlyUFSCRuXq2yTeSv8d3Yd-y_fZsstTtYzfDbe0leUUVOqT_6vYypeLbP0nuqeKeS-iVr3SUck6oKN6PSSY2ZaT9flqjeYId1QUU-uh1R0Vcb9Y5s4bRz_WQb7piRjqf0sNdic7hqHmkj6Ai3J27lL-gWEpgNj7g6hhHdx6kmBBDwpLRWO_7_pUOTdtwG4EMvUDILyh-Gsq94uHiZBNXe4-NYlq9ckiJTW5MgoQCSMzBpsO5O7HWJShALFvoPVVoiERMoeqI2bMNTcMBkvr2ZTiZvtw-tWo0KImCd9nmujKgYAz2ITxHoLyjJdu0beykeFD7mrGQWWGlqKJtnlxZmpso6lzdh5ZCbHrSjQQk7xMbk-Ka5kJ9_mB0dnLUlTrIGxFPMfVy6OvKRu2JOFOH2ai4wYuXv6YWl_UjavkgPAkGb2DvZltyejN2Zw-14T5N6Tlq0eEsq7EG6iARBc2TgB0MJ501h0JjmvVwB7UpwyNcZiDRX_k6A==" rel="nofollow" target="_blank">Twitter</a>.</p> <p><strong>About LM Funding America, Inc.</strong></p> <p>LM Funding America, Inc., ( LMFA) together with its subsidiaries, is a cryptocurrency mining business that commenced Bitcoin mining operations in September 2022. The Company also operates a technology-based specialty finance company that provides funding to nonprofit community associations (Associations) primarily located in the state of Florida, as well as in the states of Washington, Colorado, and Illinois, by funding a certain portion of the Associations' rights to delinquent accounts that are selected by the Associations arising from unpaid Association assessments.</p> <p><strong>Forward-Looking Statements</strong></p> <p>This press release contains certain forward-looking statements within the meaning of the “safe harbor” provisions of the Private Securities Litigation Reform Act of 1955. These forward-looking statements include, without limitation, SeaStar Medical Holding Corporation’s, LMAO’s and SeaStar Medical’s expectations with respect to the proposed business combination between LMAO and SeaStar Medical, including statements regarding the benefits of the transaction, the ability of SeaStar Medical Holding Corporation to achieve value for its stakeholders, the implied valuation of SeaStar Medical, the products offered by SeaStar Medical Holding Corporation and the markets in which it operates, and the expected timing of regulatory approval of SeaStar Medical Holding Corporation’s products. Words such as “believe,” “project,” “expect,” “anticipate,” “estimate,” “intend,” “strategy,” “future,” “opportunity,” “plan,” “may,” “should,” “will,” “would,” “will be,” “will continue,” “will likely result,” and similar expressions are intended to identify such forward-looking statements. Forward-looking statements are predictions, projections and other statements about future events that are based on current expectations and assumptions and, as a result, are subject to significant risks and uncertainties that could cause the actual results to differ materially from the expected results. Most of these factors are outside LMAO’s and SeaStar Medical’s control and are difficult to predict. Factors that may cause actual future events to differ materially from the expected results, include, but are not limited to: (i) the inability to recognize the anticipated benefits of the business combination, which may be affected by, among other things, competition and the ability of the post-combination company to grow and manage growth profitability and retain its key employees, (ii) costs related to the business combination, (iii) the outcome of any legal proceedings that may be instituted against SeaStar Medical Holding Corporation following the announcement of the closing of the business combination, (x) the ability to maintain the listing of its securities on the Nasdaq, (iv) the ability to implement business plans, forecasts, and other expectations after the completion of the proposed business combination, and identify and realize additional opportunities, (v) the risk of downturns and the possibility of rapid change in the highly competitive industry in which SeaStar Medical Holding Corporation operates, (vi) the risk that SeaStar Medical Holding Corporation and its current and future collaborators are unable to successfully develop and commercialize its products or services, or experience significant delays in doing so, including failure to achieve approval of its products by applicable federal and state regulators, (vii) the risk that SeaStar Medical Holding Corporation may never achieve or sustain profitability; (viii) the risk that SeaStar Medical Holding Corporation may need to raise additional capital to execute its business plan, which many not be available on acceptable terms or at all; (ix) the risk that third-parties suppliers and manufacturers are not able to fully and timely meet their obligations, (x) the risk of product liability or regulatory lawsuits or proceedings relating to SeaStar Medical’s products and services, (xi) the risk that SeaStar Medical Holding Corporation is unable to secure or protect its intellectual property, and (xiii) other risks and uncertainties indicated from time to time in LMAO’s registration statement on Form S-4, as amended (File No. 333-264993), including those under the “Risk Factors” section therein and in LMAO’s other filings with the SEC. The foregoing list of factors is not exhaustive. Forward-looking statements speak only as of the date they are made. Readers are cautioned not to put undue reliance on forward-looking statements, and SeaStar Medical, LMAO and SeaStar Medical Holding Corporation assume no obligation and do not intend to update or revise these forward-looking statements, whether as a result of new information, future events, or otherwise.</p> <p><strong>Media Relations Contact:</strong><br>Patty Caballero<br>Email: <a href="https://www.globenewswire.com/Tracker?data=MBjDDlkmPlPeXA9USWBWfzRmPkDqtm27dJ2v8zL1N6qxIU5ItKrr0YLl50rlLrx1KbSD4eERazSGptd3XhHOXpLy3ePiBzR6xlhT-kbBo5UKNf6zzI7-C8V4Dv8mHvdl3r1KqoD1IS4HUOr035kB-VAdtku8IEI0CDRoTSTpgx9NGWEjfIQ-QqXZNGKJT-34yU5yX51pJeh8a5614d0GjW6xg7OOIio3dJdJPAauD8r8mLltVyLSlEDzhVhbyc5SUWjwuiBe6uz7UA3iGfNqDQ==" rel="nofollow" target="_blank"><span class="__cf_email__" data-cfemail="8bfbeafffff2cbfbf8e8e8e4e5f8fee7ffe2e5eca5e5eeff">[email&#160;protected]</span></a><br>Tel: 862.216.7523</p> <p><strong>SeaStar Medical Investor Contact:</strong><br>JTC Team, LLC<br>Jenene Thomas<br>Tel: (833) 475-8247<br>Email: <a href="https://www.globenewswire.com/Tracker?data=hHjyTE8KJrh11ieuaZhkawQaN2r2ZjWLQuUIhux2qSLMHwkDoTIRRGGI9KTjyswsH-COcTJf3TMVjffTCeP3BA==" rel="nofollow" target="_blank"><span class="__cf_email__" data-cfemail="d88bbdb98bacb9aa98b2acbbb1aaf6bbb7b5">[email&#160;protected]</span></a></p> <p><strong>LM Funding Investor Contact:</strong><br>Crescendo Communications, LLC<br>David Waldman or Ted Ayvas<br>Tel: 212-671-1020<br>Email: <a href="https://www.globenewswire.com/Tracker?data=QfvvPQ5l_E36CsBD_mP3kGYXZfrLg5pj8L6tWjYXqz18Lp0GhPG7_oWglbNsm3L2z8DILChivhuzsuzLJ1wbnJWCOX-k96uw1a1ilgaY73Y=" rel="nofollow" target="_blank"><span class="__cf_email__" data-cfemail="4925242f28092a3b2c3a2a2c272d2664203b672a2624">[email&#160;protected]</span></a></p> <img src="https://www.globenewswire.com/newsroom/ti?nf=ODY4NDgwOSM1MjMxMTg0IzUwMDEwMzQwNg==" alt="ti?nf=ODY4NDgwOSM1MjMxMTg0IzUwMDEwMzQwNg==" class="__GNW8366DE3E__IMG"> <br><img src="https://ml.globenewswire.com/media/NTYxMTc3NWYtMzgyMC00NTFlLTg0MWEtMGM2MzExODVjMzk4LTUwMDEwMzQwNg==/tiny/LMF-Acquisition-Opportunities-.png" alt="LMF-Acquisition-Opportunities-.png"></div></div> <!----> <div style="margin-top:20px;margin-bottom:30px;" data-v-04d79f4b><span data-v-04d79f4b><span class="fs-large fw-bolder" data-v-04d79f4b>Rating: </span> <div role="slider" aria-valuenow="0" aria-valuetext="" aria-valuemin="0" aria-valuemax="5" tabindex="0" class="el-rate my_rating" data-v-04d79f4b><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"><!----></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"><!----></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"><!----></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"><!----></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"><!----></i></span><!----></div> <span class="fs-large fw-bolder" data-v-04d79f4b>NaN</span> <span class="fs-large" data-v-04d79f4b>/ 5 ( votes)</span></span> <div class="fc-normal global-flex-container fc-normal" style="float:right;position:relative;top:0px;font-size:24px;" data-v-04d79f4b><!----> <div><span style="display:inline-block !important;" data-v-809c1338><i class="el-icon-collection" style="cursor: pointer;font-size: 20px;" data-v-809c1338></i> <div class="el-dialog__wrapper" style="display:none;" data-v-809c1338><div role="dialog" aria-modal="true" aria-label="Bookmark" class="el-dialog" style="margin-top:15vh;"><div class="el-dialog__header"><span class="el-dialog__title">Bookmark</span><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><!----><div class="el-dialog__footer"><span class="dialog-footer" data-v-809c1338><button type="button" class="el-button el-button--default el-button--mini" data-v-809c1338><!----><!----><span>Cancel</span></button> <button type="button" class="el-button el-button--primary el-button--mini" data-v-809c1338><!----><!----><span>Confirm</span></button></span></div></div></div></span> <span class="share-button" style="display:inline-block !important;" data-v-058a2f4c><div role="tooltip" id="el-popover-8472" aria-hidden="true" class="el-popover el-popper gf aio-popover no-padding" style="width:undefinedpx;display:none;"><!----><!----></div><span title="Share &amp; Print" class=" " style="background:transparent;" data-v-058a2f4c><i class="gf-icon-share hover-pointer" data-v-058a2f4c></i></span></span> <i class="gf-icon-printer cursor-pointer"></i></div></div></div> <div id="article-view-1880400" style="height:1px;" data-v-04d79f4b></div> <lazy-component class="comment-section" style="min-height:2px;" data-v-04d79f4b><div class="article-comment gf-border-b" style="padding:40px 0;" data-v-06c524aa data-v-04d79f4b><!----> <div data-v-06c524aa><a href="https://www.gurufocus.com/forum/login.php?0" class="color-main-blue-i" data-v-06c524aa> Please Login to Comment </a></div> <!----> <div class="row-padding" style="display:none;" data-v-06c524aa><editor id="comment-editor-1880400" api-key="xfli4zk8nqwi7onsi4cqfz3e67p26wd3lh3bym9l67xplf9c" init="[object Object]" class="invert" data-v-06c524aa></editor> <div class="p-t-md" data-v-06c524aa><!----> <!----> <!----></div></div> <!---->  <!----></div></lazy-component> <lazy-component class="author-section" style="min-height:200px;" data-v-04d79f4b><div style="padding:40px 0;border-top:1px solid var(--color-border);" data-v-48cf3c5a data-v-04d79f4b><div class="global-flex-container-start" style="position: relative;" data-v-48cf3c5a><a href="/user/0" class="link" style="margin-right:16px;" data-v-48cf3c5a><img alt="Author's Avatar" height="64px" width="64px" src="https://ui-avatars.com/api/?length=2&amp;background=random&amp;name=User" style="vertical-align:middle;border-radius:50%;object-fit:scale-down;" data-v-48cf3c5a></a> <div data-v-48cf3c5a><div class="fs-large fc-light-grey" data-v-48cf3c5a>WRITTEN BY </div> <button type="button" class="el-button bg-main-blue-i fc-white-i right-float el-button--default el-button--medium" style="position:absolute;right:0px;top:0px;" data-v-48cf3c5a><!----><!----><span>Follow</span></button> <div data-v-48cf3c5a><a href="/user/undefined" class="link" data-v-48cf3c5a><h3 class="fs-20 fw-bolder fc-normal" data-v-48cf3c5a> Value_Insider </h3></a></div> <div class="fs-large fc-light-grey" style="margin-top:14px;" data-v-48cf3c5a><!----></div></div></div> <br data-v-48cf3c5a> <!----> <div class="el-row" style="margin-left:-5px;margin-right:-5px;display:flex;" data-v-48cf3c5a></div></div></lazy-component></div> <div class="el-col el-col-8" style="padding-left:20px;padding-right:20px;border-left:1px solid var(--color-border);" data-v-04d79f4b><div style="margin-top:20px;" data-v-2498ff90 data-v-04d79f4b data-v-04d79f4b><Adsense data-ad-client="ca-pub-4020868656364652" ins-style="display:inline-block;width:380px;height:300px" data-ad-slot="8601925817" data-v-2498ff90></Adsense> <div style="padding-bottom: 32px; margin-bottom: 32px;  border-bottom: 1px solid var(--color-border);" data-v-2498ff90><h3 class="fs-x-large-s fc-normal fw-bolder inline" style="margin-bottom: 12px;" data-v-2498ff90>Request A Demo</h3> <div data-v-2498ff90>
      Learn more about GuruFocus' key features, including All-In-One Screener, backtesting, 30-year financial, stock summary page, guru trades, insider trades, excel Add-in, google sheets and much more.
    </div> <div style="text-align:center; margin-top: 16px;" data-v-2498ff90><a href="/schedule_meeting" data-v-2498ff90><button type="button" class="el-button gf el-button--primary el-button--small" data-v-2498ff90><!----><!----><span><i class="gfp-calendar" data-v-2498ff90></i>
          Request A Demo
        </span></button></a></div></div> <!----> <!----> <!----> <!----> <!----> <!----> <h3 class="fs-x-large-s fc-normal fw-bolder inline" style="margin-bottom: 12px;" data-v-2498ff90>
    GuruFocus Screeners
  </h3> <div class="screener-part" style="margin-bottom:32px;padding-bottom:32px;border-bottom:1px solid var(--color-border);" data-v-2498ff90><!----></div> <h3 class="fs-x-large-s fc-normal fw-bolder inline row-padding" data-v-2498ff90>
    Related Articles
  </h3> <!----></div></div></div> <hr class="thin" data-v-04d79f4b></div> <!----> <div id="article-bottom" class="p-b-md" style="height:8px;" data-v-faf6c114></div></main> <footer class="el-footer" style="height:60px;" data-v-faf6c114></footer></section></main> <!----><!----><!----><!----><!----></section> <!----></div> <!----> <div class="el-dialog__wrapper" style="display:none;" data-v-c509df94><div role="dialog" aria-modal="true" aria-label="dialog" class="el-dialog" style="margin-top:15vh;"><div class="el-dialog__header"><div id="title-empty" style="height:0;padding:0;margin:0;" data-v-c509df94></div><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><!----><div class="el-dialog__footer"><div class="footer-section" data-v-c509df94><button type="button" class="el-button button-item el-button--default el-button--mini" data-v-c509df94><!----><!----><span>Cancel</span></button> <button type="button" class="el-button button-item el-button--primary el-button--mini" data-v-c509df94><!----><!----><span>Confirm</span></button></div></div></div></div> <div id="myModal" class="modal"><img id="modalImg" class="modal-content"> <div id="modalCaption"></div></div></div></div></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>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</script><script src="/_nuxt/ef8c10d9cfb121cbebfc.1666968294810.js" defer></script><script src="/_nuxt/e2e861bb68d2d18901c0.1666968294810.js" defer></script><script src="/_nuxt/3bb5c735649d9ebd50b2.1666968294810.js" defer></script><script src="/_nuxt/35dd883787dfd9d043ca.1666968294810.js" defer></script><script src="/_nuxt/1640204b2b3d60127a6c.1666968294810.js" defer></script><script src="/_nuxt/fad86d0f06964fba330c.1666968294810.js" defer></script>
  <script>(function(){var js = "window['__CF$cv$params']={r:'7615a658fe335872',m:'CP5m5Zi0nl6PB7lQ6m0.Ab1xWwjNQDabMq7TjKJV08I-1666980853-0-AaG64DL2IwwhgFdVrBb8nJGSHk9yxKk6r89eXsA0WOqRHv468uKbWYFBWPUDsjeA3Vt+2hFAJsAxj9S1Pw6sMjXShyEiGAUE748PpmTYyi+/p4i6aDst0HuSwOO2277BV0dTeIboZx49G6V09FFWmlPIb9p79XTVQdRfFONTF/h+LRiPmDBCnUBSgx1JUCtnW8xaIpFt6UDX03sFSMnFfaim8F0ja2jkIkrvKQ5Ck6QK',s:[0xfd77b8f2c8,0x2c4d3bc9f0],u:'/cdn-cgi/challenge-platform/h/b'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/b/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script></body>
</html>
