<!doctype html>
<html data-n-head-ssr data-n-head="">
<head data-n-head="">
<title data-n-head="true">Willdan to Participate in Upco - GuruFocus.com</title><meta data-n-head="true" charset="utf-8"><meta data-n-head="true" name="viewport" content="width=device-width, initial-scale=1"><meta data-n-head="true" data-hid="description" name="description" content="GuruFocus Article or News written by Business Wire and the topic is about: "><meta data-n-head="true" data-hid="keywords" name="keywords" content="GuruFocus, Article, News, Business Wire, NAS:WLDN"><meta data-n-head="true" name="twitter:card" content="summary_large_image"><meta data-n-head="true" name="twitter:site" content="@gurufocus"><meta data-n-head="true" name="twitter:creator" content="@gurufocus"><meta data-n-head="true" name="twitter:title" content="Willdan to Participate in Upcoming Investor Conference"><meta data-n-head="true" name="twitter:description" content=""><meta data-n-head="true" name="twitter:image" content=""><meta data-n-head="true" name="og:image" content=""><link data-n-head="true" rel="icon" type="image/x-icon" href="/favicon.ico"><script data-n-head="true" src="https://www.googletagmanager.com/gtag/js?id=AW-1005049228" async="true"></script><script data-n-head="true" src="//www.googletagmanager.com/gtm.js?id=GTM-K799DP4&amp;l=dataLayer" async="true"></script><noscript data-n-head="true" data-hid="gtm-noscript" pbody="true"><iframe src="//www.googletagmanager.com/ns.html?id=GTM-K799DP4&l=dataLayer" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><link rel="stylesheet" href="/_nuxt/8e2198e87ba312b17c67.1642028864177.css"><link rel="stylesheet" href="/_nuxt/352fc49752e68484eec8.1642028864177.css">
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body data-n-head="">
<div data-server-rendered="true" id="__nuxt"><div id="__layout"><div class="app-wrapper purge-css-ignore"><div class="main-container"><section id="notification-bar" class="el-container notification-bar notification-bar" data-v-851b3408><div center="" class="alert-item" data-v-851b3408><a href="https://www.gurufocus.com/membership/new/index.html#/?sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=notificaton_bar" target="_top" data-v-851b3408><div slot="title" class="content-section" data-v-851b3408> <span class="fc-white title-section title-section-xl" data-v-851b3408> Get Your 7-Day Free Trial!</span> <span class="link-section" data-v-851b3408><a href="https://www.gurufocus.com/membership/new/index.html#/?sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=notificaton_bar" target="_top" class="fc-white-i link-button link-button-xl" data-v-851b3408>
Start Now!
</a></span>  <span class="cursor-pointer close-class" data-v-851b3408><i class="gf-icon-close fc-white close-icon" data-v-851b3408></i></span></div></a></div></section> <div id="navbar" client-width="1200" style="background-color:#195DAA;display:flex;justify-content:center;align-items:center;" data-v-03d926e2><div class="navbar" data-v-03d926e2><div class="navbar-brand" data-v-03d926e2><a href="https://www.gurufocus.com" data-v-03d926e2><img src="//static.gurufocus.com/images/logo_small_new.png" alt="Logo" style="margin-top: -6px;" data-v-03d926e2></a> <button type="button" class="el-button navbar-collapse-button square el-button--default el-button--mini" data-v-03d926e2><span><i class="gf-icon-bars" data-v-03d926e2></i></span></button></div> <div class="navbar-item navbar-right-item" style="padding: 12px 8px !important;" data-v-03d926e2><a href="/login?ref=%2Fnews%2F1616232%2Fwilldan-to-participate-in-upcoming-investor-conference" data-v-03d926e2><button type="button" class="el-button el-button--default el-button--small" style="background:white;color:#195DAA;" data-v-03d926e2><span> Login </span></button></a></div> <div class="navbar-item" data-v-03d926e2><span style="line-height: 24px;" data-v-03d926e2>Home <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-03d926e2></i></span> <div class="navbar-dropdown" data-v-03d926e2><a target="_blank" href="https://www.gurufocus.com" class="navbar-link" data-v-03d926e2>
Homepage
</a><a target="_blank" href="https://www.gurufocus.com/membership.php" class="navbar-link" data-v-03d926e2>
Membership Levels
</a><a target="_blank" href="https://www.gurufocus.com/flarum/t/general-discussion" class="navbar-link" data-v-03d926e2>
General Discussion
</a><a target="_blank" href="https://www.gurufocus.com/stock_list.php" class="navbar-link" data-v-03d926e2>
Complete Stock List
</a><a target="_blank" href="https://www.gurufocus.com/ads/books/" class="navbar-link" data-v-03d926e2>
The book
</a><a href="/podcast" class="navbar-link" data-v-03d926e2>
Podcast
</a><a target="_blank" href="https://www.gurufocus.com/news/281207/data-coverage-of-gurufocus-premium-membership-" class="navbar-link" data-v-03d926e2>
Membership Data Coverage
</a><a target="_blank" href="https://www.gurufocus.com/letter.php" class="navbar-link" data-v-03d926e2>
Founder's Message
</a><a target="_blank" href="https://www.gurufocus.com/membership/new/index.html#/?ref=topMenu&amp;sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=topMenu" class="navbar-link" data-v-03d926e2>
Free Trial
</a></div></div><div class="navbar-item" data-v-03d926e2><span style="line-height: 24px;" data-v-03d926e2>Screeners <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-03d926e2></i></span> <div class="navbar-dropdown" data-v-03d926e2><div class="navbar-sub" data-v-03d926e2><div class="navbar-sub-title" data-v-03d926e2><a href="/screener" class="color-primary" data-v-03d926e2>
GuruFocus Screeners
</a></div> <a href="/screener" class="navbar-link" style="color:red;font-weight:bold;" data-v-03d926e2>
All-In-One Screener
   </a><a href="/screener?name=Dividend%20Income%20Portfolio&amp;id=3829" class="navbar-link" data-v-03d926e2>
Dividend Income Portfolio
   </a><a href="/screener?name=Ben%20Graham%20Lost%20Formula&amp;id=70" class="navbar-link" data-v-03d926e2>
Ben Graham Lost Formula
   </a><a href="/screener?name=Canadian%20Faster%20Growers&amp;id=73" class="navbar-link" data-v-03d926e2>
Canadian Faster Growers
   </a><a href="/screener?name=CEO%20Buys&amp;id=74" class="navbar-link" data-v-03d926e2>
CEO Buys
   </a><a href="/screener?name=CEO%20Buys%20after%20Price%20Drop%20%3E%2020%25&amp;id=75" class="navbar-link" data-v-03d926e2>
CEO Buys after Price Drop &gt; 20%
   </a><a href="/screener?name=Dividend%20Growth%20Portfolio&amp;id=77" class="navbar-link" data-v-03d926e2>
Dividend Growth Portfolio
   </a><a href="/screener?name=Dividend%20Income%20Portfolio&amp;id=78" class="navbar-link" data-v-03d926e2>
Dividend Income Portfolio
   </a><a href="/screener?name=Fast%20Growers&amp;id=79" class="navbar-link" data-v-03d926e2>
Fast Growers
   </a><a href="/screener?name=Hedge%20Fund%20Guru%20Top%2010%20Aggregated&amp;id=80" class="navbar-link" data-v-03d926e2>
Hedge Fund Guru Top 10 Aggregated
   </a><a href="/screener?name=High%20Quality&amp;id=81" class="navbar-link" data-v-03d926e2>
High Quality
   </a><a href="/screener?name=High%20Quality%20Low%20Capex%20w%20ROE%20ROC%20min&amp;id=84" class="navbar-link" data-v-03d926e2>
High Quality Low Capex w ROE ROC min
   </a><a href="/screener?name=High%20Quality%20&amp;%20Low%20Capex&amp;id=87" class="navbar-link" data-v-03d926e2>
High Quality &amp; Low Capex
   </a><a href="/screener?name=High%20Yield%20Insider%20Buys&amp;id=88" class="navbar-link" data-v-03d926e2>
High Yield Insider Buys
   </a><a href="/screener?name=Historical%20High%20Dividend%20Yields&amp;id=89" class="navbar-link" data-v-03d926e2>
Historical High Dividend Yields
   </a><a href="/screener?name=International%20Gurus%27%20Top%20Holdings&amp;id=90" class="navbar-link" data-v-03d926e2>
International Gurus' Top Holdings
   </a><a href="/screener?name=James%20Montier%20Short%20Screen&amp;id=91" class="navbar-link" data-v-03d926e2>
James Montier Short Screen
   </a><a href="/screener?name=Margin%20Decliners&amp;id=92" class="navbar-link" data-v-03d926e2>
Margin Decliners
   </a><a href="/screener?name=Mega%20Caps&amp;id=93" class="navbar-link" data-v-03d926e2>
Mega Caps
   </a><a href="/screener?name=Peter%20Lynch%20&amp;%20Warren%20Buffett&amp;id=94" class="navbar-link" data-v-03d926e2>
Peter Lynch &amp; Warren Buffett
   </a><a href="/screener?name=Peter%20Lynch%20Growth%20w%20Lower%20Valuation&amp;id=95" class="navbar-link" data-v-03d926e2>
Peter Lynch Growth w Lower Valuation
   </a><a href="/screener?name=Peter%20Lynch%20S&amp;L%20Traded%20Below%20Book&amp;id=96" class="navbar-link" data-v-03d926e2>
Peter Lynch S&amp;L Traded Below Book
   </a><a href="/screener?name=PFCF%20Screener&amp;id=97" class="navbar-link" data-v-03d926e2>
PFCF Screener
   </a><a href="/screener?name=Piotroski%20Score%20Screener&amp;id=98" class="navbar-link" data-v-03d926e2>
Piotroski Score Screener
   </a><a href="/screener?name=Predictable%20Companies&amp;id=99" class="navbar-link" data-v-03d926e2>
Predictable Growth Companies
   </a><a href="/screener?name=Profitable%20predictable%20margin%20expanders&amp;id=100" class="navbar-link" data-v-03d926e2>
Profitable predictable margin expanders
   </a><a href="/screener?name=Stocks%20Sold%20w%20less%20Cash&amp;id=102" class="navbar-link" data-v-03d926e2>
Stocks Sold w less Cash
   </a><a href="/screener?name=Good%20Companies&amp;id=103" class="navbar-link" data-v-03d926e2>
Good Companies
   </a><a href="/screener?name=The%20Stalwarts&amp;id=104" class="navbar-link" data-v-03d926e2>
The Stalwarts
   </a></div><div class="navbar-sub" data-v-03d926e2><div class="navbar-sub-title" data-v-03d926e2><a href="/screener?manage=screen" class="color-primary" data-v-03d926e2>
My Screeners
</a></div> <a href="/screener" class="navbar-link" data-v-03d926e2>
Create My Screener
   </a></div><div class="navbar-sub" data-v-03d926e2><div class="navbar-sub-title" data-v-03d926e2><a href="/screener/buffett-munger" class="color-primary" data-v-03d926e2>
Value Screens
</a></div> <a href="/screener" class="navbar-link" style="color:red;font-weight:bold;" data-v-03d926e2>
All-In-One Screener
   </a><a href="/screener?view=map&amp;show_header=false" class="navbar-link" data-v-03d926e2>
S&amp;P 500 Map
   </a><a href="/screener?view=bubble&amp;show_header=false" class="navbar-link" data-v-03d926e2>
S&amp;P 500 Bubble
   </a><a href="/screener?view=aggregate&amp;show_header=false" class="navbar-link" data-v-03d926e2>
S&amp;P 500 Aggregate
   </a><a href="/screener/buffett-munger" class="navbar-link" data-v-03d926e2>
Buffett-Munger Screener
   </a><a target="_blank" href="https://www.gurufocus.com/industry_overview.php?region=USA" class="navbar-link" data-v-03d926e2>
Industry Overview
</a><a href="/screener/valuedcf" class="navbar-link" data-v-03d926e2>
Undervalued Predictable
   </a><a href="/screener/grahamncav" class="navbar-link" data-v-03d926e2>
Benjamin Graham Net-Net
   </a><a href="/screener/52weeklow" class="navbar-link" data-v-03d926e2>
52-week/3Y/5Y Lows
   </a><a href="/screener/52weekhigh" class="navbar-link" data-v-03d926e2>
52-week/3Y/5Y Highs
   </a><a href="/screener/magic-formula" class="navbar-link" data-v-03d926e2>
Magic Formula(Greenblatt)
   </a><a href="/screener/dividend-stocks" class="navbar-link" data-v-03d926e2>
Dividend Stocks
   </a><a href="/screener/peter-lynch-stocks" class="navbar-link" data-v-03d926e2>
Peter Lynch Screen
   </a><a href="/screener/guru-sp-grid" class="navbar-link" data-v-03d926e2>
S&amp;P500 Grid
   </a><a href="/screener/predictable" class="navbar-link" data-v-03d926e2>
Predictable Companies
   </a><a href="/screener/spinoff" class="navbar-link" data-v-03d926e2>
Spin Off List
   </a><a href="/screener/lowpb" class="navbar-link" data-v-03d926e2>
Historical Low P/B List
   </a><a href="/screener/lowps" class="navbar-link" data-v-03d926e2>
Historical Low P/S List
   </a><a href="/screener/short-stocks" class="navbar-link" data-v-03d926e2>
High Short Interest
   </a><a href="/screener/upcoming-special-dividends" class="navbar-link" data-v-03d926e2>
Upcoming Special Dividends
   </a><a href="/screener/delisted" class="navbar-link" data-v-03d926e2>
Delisted Stocks
   </a><div class="navbar-sub-title" data-v-03d926e2>
Model Portfolios
</div><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php" class="navbar-link" data-v-03d926e2>
Performances
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=smallcap" class="navbar-link" data-v-03d926e2>
Undervalued Predictable
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=midcap" class="navbar-link" data-v-03d926e2>
Buffett-Munger
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=cap40" class="navbar-link" data-v-03d926e2>
Low P/S
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=lowpb" class="navbar-link" data-v-03d926e2>
Low P/B
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=cap20" class="navbar-link" data-v-03d926e2>
52w Low Predictable
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=largecap" class="navbar-link" data-v-03d926e2>
Broadest Owned
</a><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php?mp=hr_largecap" class="navbar-link" data-v-03d926e2>
Most Weighted
</a></div></div></div><div class="navbar-item" data-v-03d926e2><span style="line-height: 24px;" data-v-03d926e2>Gurus <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-03d926e2></i></span> <div class="navbar-dropdown" data-v-03d926e2><div class="navbar-sub" data-v-03d926e2> <a href="/guru/latest-picks" class="navbar-link" data-v-03d926e2>
Latest Guru Picks
   </a><a href="/guru/list" class="navbar-link" data-v-03d926e2>
List of Gurus
   </a><a href="/guru/realtime-picks" class="navbar-link" data-v-03d926e2>
Real Time Picks
   </a><a href="/guru/portfolio" class="navbar-link" data-v-03d926e2>
Guru Portfolio
   </a><a href="/guru/top-holdings" class="navbar-link" data-v-03d926e2>
Top 10 Holdings View
   </a><a href="/guru/bargains" class="navbar-link" data-v-03d926e2>
Guru Bargains
   </a><a href="/guru/hot-picks" class="navbar-link" data-v-03d926e2>
Hot Picks
   </a><a href="/guru/aggregated-portfolio" class="navbar-link" data-v-03d926e2>
Aggregated Portfolio
   </a><a href="/guru/consensus-picks" class="navbar-link" data-v-03d926e2>
Consensus Picks
   </a><a href="/guru/etfs" class="navbar-link" data-v-03d926e2>
ETFS
   </a><a href="/guru/scoreboard" class="navbar-link" data-v-03d926e2>
Score Board
   </a><a href="/guru/sector-picks" class="navbar-link" data-v-03d926e2>
Sector Picks
   </a><a href="/guru/international-picks" class="navbar-link" data-v-03d926e2>
International Picks
   </a><a href="/guru/industry-trends" class="navbar-link" data-v-03d926e2>
Industry Trends
   </a><a href="/guru/geographic-trends" class="navbar-link" data-v-03d926e2>
Geographic Trend
   </a><a href="/guru/option-holdings" class="navbar-link" data-v-03d926e2>
Options
   </a><a href="/guru/european-shortings" class="navbar-link" data-v-03d926e2>
European Shorting
   </a></div><div class="navbar-sub" data-v-03d926e2> <a href="/guru/warren+buffett/summary" class="navbar-link" data-v-03d926e2>
Warren Buffett
   </a><a href="/guru/bill+gates/summary" class="navbar-link" data-v-03d926e2>
Bill Gates
   </a><a href="/guru/mohnish+pabrai/summary" class="navbar-link" data-v-03d926e2>
Mohnish Pabrai
   </a><a href="/guru/carl+icahn/summary" class="navbar-link" data-v-03d926e2>
Carl Icahn
   </a><a href="/guru/george+soros/summary" class="navbar-link" data-v-03d926e2>
George Soros
   </a><a href="/guru/david+tepper/summary" class="navbar-link" data-v-03d926e2>
David Tepper
   </a><a href="/guru/seth+klarman/summary" class="navbar-link" data-v-03d926e2>
Seth Klarman
   </a><a href="/guru/bill+ackman/summary" class="navbar-link" data-v-03d926e2>
Bill Ackman
   </a><a href="/guru/joel+greenblatt/summary" class="navbar-link" data-v-03d926e2>
Joel Greenblatt
   </a><a href="/guru/charlie+munger/summary" class="navbar-link" data-v-03d926e2>
Charlie Munger
   </a></div></div></div><div class="navbar-item" data-v-03d926e2><span style="line-height: 24px;" data-v-03d926e2>Insiders <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-03d926e2></i></span> <div class="navbar-dropdown" data-v-03d926e2><a href="/insider/summary" class="navbar-link" data-v-03d926e2>
All Insiders
</a><a href="/insider/ceo" class="navbar-link" data-v-03d926e2>
CEO Buys/Sells
</a><a href="/insider/trend" class="navbar-link" data-v-03d926e2>
Insider Trends
</a><a href="/insider/cluster" class="navbar-link" data-v-03d926e2>
Insider Cluster
</a><a href="/insider/cfo" class="navbar-link" data-v-03d926e2>
CFO Buys/Sells
</a><a href="/insider/double" class="navbar-link" data-v-03d926e2>
Guru + Insider Double Buys
</a><a href="/insider/triple" class="navbar-link" data-v-03d926e2>
Triple buys/Sells
</a><a href="/insider/canadian" class="navbar-link" data-v-03d926e2>
Canadian Insider
</a><a href="/insider/dutch" class="navbar-link" data-v-03d926e2>
Dutch Insider
</a></div></div><div class="navbar-item" data-v-03d926e2><span style="line-height: 24px;" data-v-03d926e2>Market <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-03d926e2></i></span> <div class="navbar-dropdown" data-v-03d926e2><div class="navbar-sub" data-v-03d926e2><div class="navbar-sub-title" data-v-03d926e2><a href="/stock-market-valuations.php" class="color-primary" data-v-03d926e2>
Market Valuation
</a></div> <a target="_blank" href="https://www.gurufocus.com/stock-market-valuations.php" class="navbar-link" data-v-03d926e2>
Buffett Indicator
</a><a target="_blank" href="https://www.gurufocus.com/industry_overview.php?region=USA" class="navbar-link" data-v-03d926e2>
Industry Overview
</a><a target="_blank" href="https://www.gurufocus.com/yield_curve.php" class="navbar-link" data-v-03d926e2>
U.S. Treasury Yield Curve
</a><a target="_blank" href="https://www.gurufocus.com/shiller-PE.php" class="navbar-link" data-v-03d926e2>
Shiller P/E
</a><a target="_blank" href="https://www.gurufocus.com/global-market-valuation.php" class="navbar-link" data-v-03d926e2>
Global Market Valuations
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/58/sp-500-earnings" class="navbar-link" data-v-03d926e2>
Economic Data
</a><a target="_blank" href="https://www.gurufocus.com/sector_shiller_pe.php" class="navbar-link" data-v-03d926e2>
Shiller P/E by Sectors
</a><a target="_blank" href="https://www.gurufocus.com/buffett_assets_allocations.php" class="navbar-link" data-v-03d926e2>
Buffett Assets Allocation
 </a><a href="/market/sp500-gf-value" class="navbar-link" data-v-03d926e2>
GF Value for SP500 Index
   </a></div><div class="navbar-sub" data-v-03d926e2><div class="navbar-sub-title" data-v-03d926e2><a href="/economic_indicators/58/sp-500-earnings" class="color-primary" data-v-03d926e2>
Economic Indicators
</a></div> <a target="_blank" href="https://www.gurufocus.com/economic_indicators/229/the-dow-jones-industrial-average-djia" class="navbar-link" data-v-03d926e2>
The Dow Jones Industrial Average (DJIA)
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/63/sp-500-index" class="navbar-link" data-v-03d926e2>
SP 500 Index
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/232/nasdaq-composite-index" class="navbar-link" data-v-03d926e2>
Nasdaq Composite Index
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/20/gross-domestic-product-gdp" class="navbar-link" data-v-03d926e2>
Gross Domestic Product (GDP)
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/56/shiller-pe" class="navbar-link" data-v-03d926e2>
Shiller PE
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/60/ratio-of-wilshire-5000-over-gnp" class="navbar-link" data-v-03d926e2>
Ratio of Wilshire 5000 over GNP
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/10/civilian-unemployment-rate" class="navbar-link" data-v-03d926e2>
Civilian Unemployment Rate
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/231/russell-2000-small-cap-price-index" class="navbar-link" data-v-03d926e2>
Russell 2000 Small Cap Price Index
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/234/cboe-volatility-index-the-vix" class="navbar-link" data-v-03d926e2>
CBOE Volatility Index (VIX)
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/14/total-nonfarm-payrolls-all-employees" class="navbar-link" data-v-03d926e2>
Total Nonfarm Payrolls: All Employees
</a><a target="_blank" href="https://www.gurufocus.com/economic_indicators/58/sp-500-earnings" class="navbar-link" data-v-03d926e2>
More...
</a></div><div class="navbar-sub" data-v-03d926e2><div class="navbar-sub-title" data-v-03d926e2><a href="/global-market-valuation.php" class="color-primary" data-v-03d926e2>
By Country
</a></div> <a target="_blank" href="https://www.gurufocus.com/stock-market-valuations.php" class="navbar-link" data-v-03d926e2>
USA
</a><a target="_blank" href="https://www.gurufocus.com/global-market-valuation.php?country=IND" class="navbar-link" data-v-03d926e2>
India
</a><a target="_blank" href="https://www.gurufocus.com/global-market-valuation.php?country=CHN" class="navbar-link" data-v-03d926e2>
China
</a><a target="_blank" href="https://www.gurufocus.com/global-market-valuation.php" class="navbar-link" data-v-03d926e2>
More
</a></div></div></div><div class="navbar-item" data-v-03d926e2><span style="line-height: 24px;" data-v-03d926e2>Articles <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-03d926e2></i></span> <div class="navbar-dropdown" data-v-03d926e2><div class="navbar-sub" data-v-03d926e2><div class="navbar-sub-title" data-v-03d926e2><a href="/news" class="color-primary" data-v-03d926e2>
Articles
</a></div> <a href="/news?cat=timeless" class="navbar-link" data-v-03d926e2>
Editors' Picks
   </a><a href="/news?cat=qa" class="navbar-link" data-v-03d926e2>
Q&amp;A with Gurus
   </a><a href="/news?cat=rank" class="navbar-link" data-v-03d926e2>
Top Ranked
   </a><a href="/news?cat=guru" class="navbar-link" data-v-03d926e2>
News
   </a><a href="/news?cat=contest" class="navbar-link" data-v-03d926e2>
Value Idea Contest
   </a></div><div class="navbar-sub" data-v-03d926e2><div class="navbar-sub-title" data-v-03d926e2><a href="/news/post" class="color-primary" data-v-03d926e2>
Submit Articles
</a></div> <a href="/news/post" class="navbar-link" data-v-03d926e2>
Submit Article Online
   </a><a target="_blank" href="https://www.gurufocus.com/news/70028" class="navbar-link" data-v-03d926e2>
Writers Wanted
</a></div></div></div><div class="navbar-item" data-v-03d926e2><span style="line-height: 24px;" data-v-03d926e2>Tools <i class="gf-icon-chevron-down" style="font-size: 10px;" data-v-03d926e2></i></span> <div class="navbar-dropdown" data-v-03d926e2><a target="_blank" href="https://www.gurufocus.com/model_portfolio.php" class="navbar-link" data-v-03d926e2>
Model Portfolios
</a><a href="/screener" class="navbar-link" data-v-03d926e2>
All-In-One Screener
</a><a target="_blank" href="https://www.gurufocus.com/download_financials_batch.php" class="navbar-link" data-v-03d926e2>
Data Batch Download
</a><a href="/guru/download-guru-portfolio" class="navbar-link" data-v-03d926e2>
Guru Portfolio Download
</a><a href="/insider/data-export" class="navbar-link" data-v-03d926e2>
Insider Data Download
</a><a target="_blank" href="https://www.gurufocus.com/excel_Add_in.php" class="navbar-link" data-v-03d926e2>
Excel Add-In
</a><a target="_blank" href="https://www.gurufocus.com/api.php" class="navbar-link" data-v-03d926e2>
API
</a><a target="_blank" href="https://www.gurufocus.com/download_stockmanual.php" class="navbar-link" data-v-03d926e2>
Manual of Stocks
</a><a href="/stock/AAPL/dcf" class="navbar-link" data-v-03d926e2>
DCF Calculator
</a><a href="/stock/AAPL/chart" class="navbar-link" data-v-03d926e2>
Interactive Chart
</a><a href="/screener?view=map&amp;show_header=false" class="navbar-link" data-v-03d926e2>
Maps
</a><a href="/fund-letters" class="navbar-link" data-v-03d926e2>
Fund Letters Archive
</a><a href="/compare-table?tab=current-analysis" class="navbar-link" data-v-03d926e2>
Stock Comparison Table
</a><a target="_blank" href="https://www.gurufocus.com/app.php" class="navbar-link" data-v-03d926e2>
Mobile App
</a><a href="/discussion" class="navbar-link" data-v-03d926e2>
Discussion Board
</a></div></div><div class="navbar-item navbar-right-item" data-v-03d926e2><span style="line-height: 24px;" data-v-03d926e2>Tutorials </span> <div class="navbar-dropdown" data-v-03d926e2><a target="_blank" href="https://www.gurufocus.com/tutorials.php" class="navbar-link" data-v-03d926e2>
Tutorials &amp; Webinars
</a><a target="_blank" href="https://www.gurufocus.com/faq.php" class="navbar-link" data-v-03d926e2>
FAQ
</a><a href="/changelog" class="navbar-link" data-v-03d926e2>
Change Log
</a><a target="_blank" href="https://www.gurufocus.com/ticket/open.php" class="navbar-link" data-v-03d926e2>
Contact Us
</a></div></div><div class="navbar-item navbar-right-item" data-v-03d926e2><span style="line-height: 24px;" data-v-03d926e2>Support </span> <div class="navbar-dropdown" data-v-03d926e2><span data-name="Support" slot="reference" data-v-03d926e2><span class="navbar-link nuxt-link-exact-active nuxt-link-active"> Chat Support</span> <div id="phplive_btn_1570480208"></div></span><a target="_blank" href="https://www.gurufocus.com/ticket/open.php" class="navbar-link" data-v-03d926e2>
Create a ticket
</a></div></div> <div class="navbar-item" data-v-403015a1 data-v-03d926e2><a id="gfgf-etf-link" href="https://gurufocusetf.com" class="fc-white-i" data-v-403015a1>
ETF
</a></div> <div class="navbar-item navbar-right-item" data-v-4116fc36 data-v-03d926e2><a href="https://www.gurufocus.com/membership/new/index.html#/?sel=premium&utm_source=webApp&utm_medium=userClick&utm_campaign=new_navbar_free_trial" data-v-4116fc36><span class="basic-navbar-title" data-v-4116fc36>
Subscribe
</span></a> <div class="navbar-dropdown" data-v-4116fc36><a href="https://www.gurufocus.com/membership/new/index.html#/?sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=new_navbar_free_trial_item" class="navbar-link" data-v-4116fc36>
Free Trial ($449/year)
</a><a href="https://www.gurufocus.com/user_referrals.php" class="navbar-link" data-v-4116fc36>
Refer a Friend and Earn $50
</a></div></div> </div></div> <div id="tags-view" style="height:32px;margin:8px 0;padding-left:0px;" data-v-ac30c1b0></div> <section class="el-container"><main id="components-root" class="el-main auto-height-on-print capture-areaz" style="height:calc(100vh - 73px);"><section class="el-container is-vertical" data-v-1e9470a0><main class="el-main center" data-v-1e9470a0><div frame="frame-xl" class="center" style="padding-bottom:40px;" data-v-b2396c44 data-v-1e9470a0><div class="ad-image-container" data-v-6a6691c2 data-v-b2396c44><img src="https://static.gurufocus.com/images/icons/i/Banner/CTA%20Large.png" alt="Get Premium to unlock powerful stock data" width="100%" data-v-6a6691c2></div> <div class="el-row" style="margin-left:-20px;margin-right:-20px;" data-v-b2396c44><div id="article-main-section-1616232" class="el-col el-col-16" style="padding-left:20px;padding-right:20px;" data-v-b2396c44><h1 class="fc-primary fw-bolder subject" data-v-b2396c44> Willdan to Participate in Upcoming Investor Conference
  </h1>   <div class="row-padding" data-v-d5141fe2 data-v-b2396c44><div class="author-item global-flex-container" data-v-d5141fe2><div style="margin-right: 12px;" data-v-d5141fe2><a href="/user/gumozhyhru" class="left avatar" data-v-d5141fe2><img alt="Author's Avatar" height="48px" width="48px" src="https://avatar.gurufocus.com/590272_small.png" style="vertical-align:middle;border-radius:50%;object-fit:scale-down;" data-v-d5141fe2></a></div> <div data-v-d5141fe2><div data-v-d5141fe2><a href="/user/gumozhyhru" class="fc-normal-i body-small fw-bolder" style="margin-right: 12px;" data-v-d5141fe2><span data-v-d5141fe2> Business Wire </span></a> <button type="button" class="el-button bg-main-blue-i fc-white-i el-button--default el-button--mini" data-v-d5141fe2><span>Follow</span></button></div> <div class="body-small fc-light" style="line-height: 24px; margin-top: 2px;" data-v-d5141fe2><span data-v-d5141fe2> 1 minutes ago </span></div></div></div> <div class="fc-normal fc-normal" style="float:right;position:relative;top:-34px;font-size:24px;" data-v-d5141fe2> <span style="display:inline-block !important;" data-v-e08d839a><i class="el-icon-collection" style="cursor: pointer;font-size: 20px;position: relative;top: -2px;" data-v-e08d839a></i> <div class="el-dialog__wrapper" style="display:none;" data-v-e08d839a><div role="dialog" aria-modal="true" aria-label="Bookmark" class="el-dialog" style="margin-top:15vh;"><div class="el-dialog__header"><span class="el-dialog__title">Bookmark</span><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><div class="el-dialog__footer"><span class="dialog-footer" data-v-e08d839a><button type="button" class="el-button el-button--default el-button--mini" data-v-e08d839a><span>Cancel</span></button> <button type="button" class="el-button el-button--primary el-button--mini" data-v-e08d839a><span>Confirm</span></button></span></div></div></div></span> <span class="share-button" style="display:inline-block !important;" data-v-0449eb4e><div role="tooltip" id="el-popover-2780" aria-hidden="true" class="el-popover el-popper aio-popover no-padding" style="width:undefinedpx;display:none;"></div><span class=" " style="background:transparent;" data-v-0449eb4e><i class="gf-icon-share hover-pointer" data-v-0449eb4e></i></span></span> <i class="gf-icon-printer cursor-pointer"></i></div></div> <div class="article-stock-section" style="margin-top:32px;" data-v-b2396c44><div style="height:78px;"></div> </div>  <img alt="Article's Main Image" width="100%" src="" style="padding-top:40px;max-height:600px;display:block;margin:auto;padding-bottom:10px;object-fit:contain;" data-v-b2396c44> <div id="article-body-1616232" class="main-body" style="margin-top:40px;" data-v-b2396c44><p>
Willdan Group, Inc. (Nasdaq: WLDN) today announced that members of its executive team will participate in Sidoti Winter Virtual Investor Conference taking place January 19 – January 20, 2022.
</p><p>
Willdan executives will conduct one-on-one meetings with investors throughout the day on Thursday, January 20, 2022. Willdan’s current investor presentation document is available at ir.willdangroup.com. Individual investor conference meetings are not webcast.
</p><p><strong>About Sidoti &amp; Company, LLC</strong></p><p>
For over two decades, Sidoti has been a premier provider of independent securities research focused specifically on Small Cap and Micro Cap companies and the institutions that invest their securities, with most of our coverage in the $50 million to $3 billion market cap range. Our approach affords companies and institutional clients a combination of high-quality research, a Small Cap and Micro Cap focused nationwide sales effort, and broad access to corporate management teams. We serve 500+ institutional clients in the U.S. and Canada, including many leading managers with portfolios with $200 million to $2 billion of AUM. Sidoti promotes meaningful interaction between issuers and investors in the Small Cap and Micro Cap space through a series of investor conferences (<a href>www.sidoti.com%2Fevents</a>) we host each year.
</p><p><strong>About Willdan</strong></p><p>
Willdan is a nationwide provider of professional technical and consulting services to utilities, government agencies, and private industry. Willdan’s service offerings span a broad set of complementary disciplines that include electric grid solutions, energy efficiency and sustainability, engineering and planning, and municipal financial consulting. For additional information, visit Willdan's website at <a href>www.willdan.com</a>.
</p><p><strong>Forward-Looking Statements</strong></p><p>
Statements in this press release that are not purely historical are forward-looking statements within the meaning of the Private Securities Litigation Reform Act of 1995. It is important to note that actual results could differ materially from those in any such forward-looking statements. Factors that could cause actual results to differ materially include, but are not limited to, the risk factors listed from time to time in Willdan’s reports filed with the Securities and Exchange Commission, including, but not limited to, the Annual Report on Form 10-K filed for the year ended January 1, 2021. Willdan cautions investors not to place undue reliance on the forward-looking statements contained in this press release. Willdan disclaims any obligation to, and does not undertake to, update or revise any forward-looking statements in this press release.
</p><p><img src="https://cts.businesswire.com/ct/CT?id=bwnews&sty=20220113005351r1&sid=txguf&distro=ftp" alt="CT?id=bwnews&sty=20220113005351r1&sid=txguf&distro=ftp"></p><p><span>View source version on businesswire.com: </span><span><a href="https://www.businesswire.com/news/home/20220113005351/en/" rel="nofollow" target="_blank">https://www.businesswire.com/news/home/20220113005351/en/</a></span></p><p></p></div>  <div style="margin-top:20px;margin-bottom:30px;" data-v-b2396c44><span data-v-b2396c44><span class="fs-large fw-bolder" data-v-b2396c44>Rating: </span> <div role="slider" aria-valuenow="0" aria-valuetext="" aria-valuemin="0" aria-valuemax="5" tabindex="0" class="el-rate my_rating" data-v-b2396c44><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"></i></span></div> <span class="fs-large fw-bolder" data-v-b2396c44>NaN</span> <span class="fs-large" data-v-b2396c44>/ 5 ( votes)</span></span> <div class="fc-normal fc-normal" style="float:right;position:relative;top:0px;font-size:24px;" data-v-b2396c44> <span style="display:inline-block !important;" data-v-e08d839a><i class="el-icon-collection" style="cursor: pointer;font-size: 20px;position: relative;top: -2px;" data-v-e08d839a></i> <div class="el-dialog__wrapper" style="display:none;" data-v-e08d839a><div role="dialog" aria-modal="true" aria-label="Bookmark" class="el-dialog" style="margin-top:15vh;"><div class="el-dialog__header"><span class="el-dialog__title">Bookmark</span><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><div class="el-dialog__footer"><span class="dialog-footer" data-v-e08d839a><button type="button" class="el-button el-button--default el-button--mini" data-v-e08d839a><span>Cancel</span></button> <button type="button" class="el-button el-button--primary el-button--mini" data-v-e08d839a><span>Confirm</span></button></span></div></div></div></span> <span class="share-button" style="display:inline-block !important;" data-v-0449eb4e><div role="tooltip" id="el-popover-2909" aria-hidden="true" class="el-popover el-popper aio-popover no-padding" style="width:undefinedpx;display:none;"></div><span class=" " style="background:transparent;" data-v-0449eb4e><i class="gf-icon-share hover-pointer" data-v-0449eb4e></i></span></span> <i class="gf-icon-printer cursor-pointer"></i></div></div> <div id="article-view-1616232" style="height:1px;" data-v-b2396c44></div> <lazy-component class="author-section" style="min-height:200px;" data-v-b2396c44><div style="padding:40px 0;border-top:1px solid #DFE6EC;border-bottom:1px solid #DFE6EC;" data-v-4cbe4798 data-v-b2396c44><div class="global-flex-container-start" style="position: relative;" data-v-4cbe4798><a href="/user/590272" class="link" style="margin-right:16px;" data-v-4cbe4798><img alt="Author's Avatar" height="64px" width="64px" src="https://avatar.gurufocus.com/590272_big.png" style="vertical-align:middle;border-radius:50%;object-fit:scale-down;" data-v-4cbe4798></a> <div data-v-4cbe4798><div class="fs-large fc-light-grey" data-v-4cbe4798>WRITTEN BY </div> <button type="button" class="el-button bg-main-blue-i fc-white-i right-float el-button--default el-button--medium" style="position:absolute;right:0px;top:0px;" data-v-4cbe4798><span>Follow</span></button> <div data-v-4cbe4798><a href="/user/gumozhyhru" class="link" data-v-4cbe4798><h3 class="fs-20 fw-bolder fc-normal" data-v-4cbe4798> Business Wire </h3></a></div> <div class="fs-large fc-light-grey" style="margin-top:14px;" data-v-4cbe4798></div></div></div> <br data-v-4cbe4798>  <div class="el-row" style="margin-left:-5px;margin-right:-5px;display:flex;" data-v-4cbe4798></div></div></lazy-component> <lazy-component class="comment-section" style="min-height:200px;" data-v-b2396c44><div class="el-card article-comment is-never-shadow" style="border:none;padding:40px 0;" data-v-593f497d data-v-17452fac data-v-b2396c44>  <div data-v-593f497d data-v-17452fac><a href="https://www.gurufocus.com/forum/login.php?0" class="color-main-blue-i" data-v-593f497d data-v-17452fac> Please Login to Comment </a></div>  <div class="row-padding" style="display:none;" data-v-593f497d data-v-17452fac><editor id="comment-editor-1616232" api-key="xfli4zk8nqwi7onsi4cqfz3e67p26wd3lh3bym9l67xplf9c" init="[object Object]" data-v-593f497d data-v-17452fac></editor> <div class="row-padding-top" data-v-593f497d data-v-17452fac>  </div></div>  </div></lazy-component></div> <div class="el-col el-col-8" style="padding-left:20px;padding-right:20px;" data-v-b2396c44><div style="margin-top:20px;" data-v-3b24d38a data-v-b2396c44 data-v-b2396c44><Adsense data-ad-client="ca-pub-4020868656364652" ins-style="display:inline-block;width:380px;height:300px" data-ad-slot="8601925817" data-v-3b24d38a></Adsense>       <h3 class="fs-x-large-s fc-normal fw-bolder inline" style="margin-bottom: 12px;" data-v-3b24d38a>
GuruFocus Screeners
</h3> <div class="screener-part" style="margin-bottom:32px;padding-bottom:32px;border-bottom:1px solid #EAEFF3;" data-v-3b24d38a></div> <h3 class="fs-x-large-s fc-normal fw-bolder inline row-padding" data-v-3b24d38a>
Related Articles
</h3>  <a href="/news?cat=qa" class="fs-x-large-s fc-normal-i fw-bolder underline-on-hover" style="display:block;" data-v-3b24d38a> Q&amp;A with Gurus </a> <div class="section-padding" style="min-height:60px;" data-v-3b24d38a></div></div></div></div> <hr class="thin" data-v-b2396c44></div>  <div id="article-bottom" class="row-padding" style="height:1px;" data-v-1e9470a0></div></main> <div id="myModal" class="modal" data-v-1e9470a0><img id="modalImg" class="modal-content" data-v-1e9470a0> <div id="modalCaption" data-v-1e9470a0></div></div> <footer class="el-footer" style="height:60px;" data-v-1e9470a0></footer></section></main> </section> <div closeable="true" class="el-dialog__wrapper" style="display:none;z-index:100000;" data-v-6cb47dd4><div role="dialog" aria-modal="true" aria-label="dialog" class="el-dialog" style="margin-top:10%;width:580px;"><div class="el-dialog__header"><div id="title-empty" style="height:0;padding:0;margin:0;" data-v-6cb47dd4></div><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div></div></div></div>  <div class="el-dialog__wrapper" style="display:none;" data-v-f35d8750><div role="dialog" aria-modal="true" aria-label="dialog" class="el-dialog" style="margin-top:15vh;"><div class="el-dialog__header"><div id="title-empty" style="height:0;padding:0;margin:0;" data-v-f35d8750></div><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><div class="el-dialog__footer"><div class="footer-section" data-v-f35d8750><button type="button" class="el-button button-item el-button--default el-button--mini" data-v-f35d8750><span>Cancel</span></button> <button type="button" class="el-button button-item el-button--primary el-button--mini" data-v-f35d8750><span>Confirm</span></button></div></div></div></div></div></div></div><script>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</script><script src="/_nuxt/64dddeff8e4cf69c185c.1642028862731.js" defer></script><script src="/_nuxt/5479ad4fd2f3719fffb3.1642028862731.js" defer></script><script src="/_nuxt/0acc7b741bd37556af0a.1642028862731.js" defer></script><script src="/_nuxt/8b0d045660ad661fd768.1642028862731.js" defer></script><script src="/_nuxt/26640f5f9ec8b05ad33f.1642028862731.js" defer></script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'6ccfb68f3a4282c3',m:'UpbLVYF49gMJ0DQEPc3YeyZFPBSfftYg0BL.xCWHo5Q-1642088322-0-AfQFZo+ySHVb45NeAlney8yRUTjpdR6WRQ/M2hce/2TUenICciuSY94B5OoYVVNozkbd+9Noi8ycbwLAPw9v0lcHPgN4H1tblQeGEHQ4tBR5VMpPQYTXwrhemfJocdEjHf/ndiEUXN/0DKHHvs26mM6AMxTu4ZTAkH/QhM6OrbGO76U+j5AJnhzYpNGfpRSNdkE6w0KqsOpJkmf5l2VHXZ0=',s:[0xa236b041d9,0xce8b86a09d],}})();</script></body>
</html>
