<!doctype html>
<html data-n-head-ssr lang="en" data-n-head="%7B%22lang%22:%7B%22ssr%22:%22en%22%7D%7D">
  <head >
    <title>Belden&#x27;s New DCX System Suppor - GuruFocus.com</title><meta data-n-head="ssr" charset="utf-8"><meta data-n-head="ssr" name="viewport" content="width=device-width, initial-scale=1"><meta data-n-head="ssr" name="viewport" content="initial-scale=1.0, user-scalable=no"><meta data-n-head="ssr" data-hid="twitter:url" name="twitter:url" content="https://www.gurufocus.com/news/1909362/beldens-new-dcx-system-supports-fast-easy-management-of-terminations-in-fiberdense-environments"><meta data-n-head="ssr" data-hid="description" name="description" content="GuruFocus Article or News written by Business Wire and the topic is about: "><meta data-n-head="ssr" data-hid="keywords" name="keywords" content="GuruFocus, Article, News, Business Wire, NYSE:BDC"><meta data-n-head="ssr" name="twitter:card" content="summary_large_image"><meta data-n-head="ssr" name="twitter:site" content="@gurufocus"><meta data-n-head="ssr" name="twitter:creator" content="@gurufocus"><meta data-n-head="ssr" data-hid="twitter:title" name="twitter:title" content="Belden&#x27;s New DCX System Supports Fast &amp; Easy Management of Terminations in Fiber-Dense Environments"><meta data-n-head="ssr" data-hid="twitter:description" name="twitter:description" content=""><meta data-n-head="ssr" data-hid="twitter:image" name="twitter:image" content="https://static.gurufocus.com/images/logo_global.png"><meta data-n-head="ssr" data-hid="og:title" property="og:title" content="Belden&#x27;s New DCX System Suppor - GuruFocus.com"><meta data-n-head="ssr" data-hid="og:url" property="og:url" content="https://www.gurufocus.com/news/1909362/beldens-new-dcx-system-supports-fast-easy-management-of-terminations-in-fiberdense-environments"><meta data-n-head="ssr" data-hid="og:description" property="og:description" content="GuruFocus Article or News written by Business Wire and the topic is about: "><meta data-n-head="ssr" data-hid="og:image" property="og:image" content="https://static.gurufocus.com/images/logo_global.png"><link data-n-head="ssr" rel="preconnect" href="https://static.gurufocus.com"><link data-n-head="ssr" rel="dns-prefetch" href="https://static.gurufocus.com"><link data-n-head="ssr" rel="icon" type="image/x-icon" href="/favicon.ico"><link data-n-head="ssr" rel="preconnect" href="https://fonts.googleapis.com"><link data-n-head="ssr" rel="preconnect" href="https://fonts.gstatic.com"><link data-n-head="ssr" rel="stylesheet" href="https://fonts.googleapis.com/css2?family=Inter:wght@400;500;700;800&amp;display=swap"><link data-n-head="ssr" rel="canonical" href="https://www.gurufocus.com/news/1909362/beldens-new-dcx-system-supports-fast-easy-management-of-terminations-in-fiberdense-environments"><link rel="preload" href="/_nuxt/3dca26e1a942ee3370e2.1670886052668.js" as="script"><link rel="preload" href="/_nuxt/3d285c5b892e01014dee.1670886052668.js" as="script"><link rel="preload" href="/_nuxt/251a8d00407cdb46e20f.1670886052668.js" as="script"><link rel="preload" href="/_nuxt/a65abe463e05a9f6d062.css" as="style"><link rel="preload" href="/_nuxt/62e277b21d1eb02fd398.1670886052668.js" as="script"><link rel="preload" href="/_nuxt/0f54e172b9c54c7f2880.css" as="style"><link rel="preload" href="/_nuxt/55db85c2eaab01a2040f.1670886052668.js" as="script"><link rel="preload" href="/_nuxt/ba8c165eda00c15ecf01.1670886052668.js" as="script"><link rel="preload" href="/_nuxt/7137465b6ed1f8f8117f.1670886052668.js" as="script"><link rel="preload" href="/_nuxt/eee40703422c7e6cbcc6.css" as="style"><link rel="preload" href="/_nuxt/6d78823361b361b26e8e.1670886052668.js" as="script"><link rel="preload" href="/_nuxt/2cc7d9a70ff9076f81dc.css" as="style"><link rel="preload" href="/_nuxt/f43604036a99b2bd5943.1670886052668.js" as="script"><link rel="preload" href="/_nuxt/a1a08f702653129ae9ee.1670886052668.js" as="script"><link rel="stylesheet" href="/_nuxt/a65abe463e05a9f6d062.css"><link rel="stylesheet" href="/_nuxt/0f54e172b9c54c7f2880.css"><link rel="stylesheet" href="/_nuxt/eee40703422c7e6cbcc6.css"><link rel="stylesheet" href="/_nuxt/2cc7d9a70ff9076f81dc.css">
  </head>
  <body >
    <div data-server-rendered="true" id="__nuxt"><!----><div id="__layout"><section class="el-container app-wrapper purge-css-ignore gf keep-all bg-neutral-10 is-vertical"><header id="header" class="el-header" style="height:auto;text-align:start;font-size:12px;"><a href="https://www.gurufocus.com/membership/new/index.html#/?ref=/&amp;sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=notificaton_bar" data-v-4254ded0><div center type="error" effect="dark" class="alert-item notification-bar enable-darkmode" data-v-4254ded0><span style="margin-right: 8px;" data-v-4254ded0>🚀</span> <span class="title-section title-section-xl" style="color:var(--color-10) !important" data-v-4254ded0>Enjoy a 7-Day Free Trial Thru Dec 20, 2022!</span> <span data-v-4254ded0>✨</span></div></a> <div id="navbar" class="navbar-desktop align-child-center bg-theme" data-v-8a7038a4><div class="navbar" data-v-8a7038a4><div class="navbar-brand" data-v-8a7038a4><a href="/" style="background-color: transparent;" data-v-8a7038a4><img width="80" height="24" src="https://static.gurufocus.com/images/logo_header.png" alt="Logo" style="margin-top: -6px;" data-v-8a7038a4></a></div> <div class="navbar-item navbar-right-item" style="padding: 12px 8px !important;" data-v-8a7038a4><a href="/register" data-v-8a7038a4><button type="button" class="el-button gf login-button el-button--default el-button--mini" data-v-8a7038a4><!----><!----><span><span class="fw-bolder" data-v-8a7038a4>Sign Up</span></span></button></a></div> <div class="navbar-item navbar-right-item" data-v-8a7038a4><div data-v-8a7038a4><a href="/login" class="block p-v-lg p-h-sm" data-v-8a7038a4><span class="fw-bolder color-white" data-v-8a7038a4>Login</span></a></div> <div class="navbar-dropdown" data-v-8a7038a4><a href="/register" class="navbar-link" data-v-8a7038a4>
            Free Sign-up
          </a> <a href="/login" class="navbar-link" data-v-8a7038a4>
            Login
          </a> <a href="/membership/new/index.html#/" class="navbar-link" data-v-8a7038a4>
            7-Day Free Trial
          </a></div></div> <div class="navbar-item switch-outer" style="padding:12px 8px !important;float:right;" data-v-8c41f506 data-v-8a7038a4><div class="color-theme-bg border-radius" style="height: 32px;" data-v-8c41f506><svg width="32" height="32" viewBox="0 0 40 40" fill="none" xmlns="http://www.w3.org/2000/svg" data-v-8c41f506><path d="M0 20C0 8.95431 8.95431 0 20 0C31.0457 0 40 8.95431 40 20C40 31.0457 31.0457 40 20 40C8.95431 40 0 31.0457 0 20Z" data-v-8c41f506></path> <path fill-rule="evenodd" clip-rule="evenodd" d="M19.7074 9.13178C19.8526 9.38932 19.8329 9.70809 19.6572 9.94582C18.5988 11.3777 18.0895 13.1419 18.2219 14.9175C18.3543 16.6931 19.1197 18.3623 20.3787 19.6213C21.6378 20.8804 23.3069 21.6457 25.0825 21.7781C26.8582 21.9105 28.6223 21.4012 30.0542 20.3428C30.2919 20.1671 30.6107 20.1474 30.8682 20.2926C31.1258 20.4377 31.274 20.7206 31.2468 21.015C31.0498 23.147 30.2497 25.1787 28.9401 26.8726C27.6304 28.5664 25.8655 29.8522 23.8518 30.5796C21.8381 31.307 19.6589 31.4458 17.5691 30.9798C15.4794 30.5139 13.5655 29.4624 12.0516 27.9484C10.5376 26.4345 9.48615 24.5206 9.02019 22.4309C8.55423 20.3412 8.69305 18.1619 9.42042 16.1482C10.1478 14.1345 11.4336 12.3696 13.1275 11.06C14.8213 9.75034 16.8531 8.95022 18.985 8.75319C19.2794 8.72599 19.5623 8.87424 19.7074 9.13178ZM17.5721 10.5175C16.2967 10.8479 15.0958 11.4342 14.0449 12.2466C12.5765 13.382 11.4618 14.912 10.8312 16.6578C10.2006 18.4036 10.0803 20.2928 10.4842 22.1045C10.8882 23.9161 11.7998 25.5753 13.1122 26.8878C14.4247 28.2003 16.0839 29.1118 17.8956 29.5158C19.7072 29.9197 21.5965 29.7994 23.3422 29.1688C25.088 28.5382 26.618 27.4235 27.7534 25.9551C28.5659 24.9042 29.1521 23.7033 29.4825 22.428C28.0868 23.0939 26.5325 23.3904 24.971 23.2739C22.8371 23.1148 20.8311 22.1951 19.318 20.682C17.805 19.1689 16.8852 17.163 16.7261 15.029C16.6096 13.4675 16.9062 11.9133 17.5721 10.5175Z" fill="white" data-v-8c41f506></path></svg></div></div> <div class="navbar-item" style="padding:0 !important;" data-v-8a7038a4><div data-v-8a7038a4><a href="/" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-8a7038a4>
          Home
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-8a7038a4></i></a></div> <div class="navbar-dropdown" data-v-8a7038a4><a href="/" class="navbar-link" data-v-8a7038a4>
              Homepage
            </a><a href="/pricing" class="navbar-link" data-v-8a7038a4>
              Membership Levels
            </a><a href="/about" class="navbar-link" data-v-8a7038a4>
              About Us
            </a><a href="/discussion" class="navbar-link" data-v-8a7038a4>
              General Discussion
            </a><a href="/stocks" class="navbar-link" data-v-8a7038a4>
              Complete Stock List
            </a><a href="https://www.gurufocus.com/ads/books/index.php" class="navbar-link" data-v-8a7038a4><!----> <!---->
              The book
            </a><a href="https://www.gurufocus.com/news/281207/data-coverage-of-gurufocus-premium-membership-" class="navbar-link" data-v-8a7038a4><!----> <!---->
              Membership Data Coverage
            </a><a href="https://www.gurufocus.com/letter.php" class="navbar-link" data-v-8a7038a4><!----> <!---->
              Founder's Message
            </a><a href="https://www.gurufocus.com/membership/new/index.html#/?ref=topMenu&amp;sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=topMenu" class="navbar-link" data-v-8a7038a4><!----> <!---->
              Free Trial
            </a></div></div><div class="navbar-item" style="padding:0 !important;" data-v-8a7038a4><div data-v-8a7038a4><a href="/screener" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-8a7038a4>
          Screeners
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-8a7038a4></i></a></div> <div class="navbar-dropdown" data-v-8a7038a4><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/screener" class="t-icon" data-v-8a7038a4>
                  GuruFocus Screeners
                </a></div> <a href="/screener" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-8a7038a4>
                All-In-One Screener
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Ben%20Graham%20Lost%20Formula&amp;id=70" class="navbar-link" data-v-8a7038a4>
                Ben Graham Lost Formula
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Canadian%20Faster%20Growers&amp;id=73" class="navbar-link" data-v-8a7038a4>
                Canadian Faster Growers
                <!----> <!----> <!----> <!----></a><a href="/screener?name=CEO%20Buys&amp;id=74" class="navbar-link" data-v-8a7038a4>
                CEO Buys
                <!----> <!----> <!----> <!----></a><a href="/screener?name=CEO%20Buys%20after%20Price%20Drop%20%3E%2020%25&amp;id=75" class="navbar-link" data-v-8a7038a4>
                CEO Buys after Price Drop &gt; 20%
                <!----> <!----> <!----> <!----></a><!----><a href="/screener?name=Dividend%20Aristocrats%202022&amp;id=61843" class="navbar-link" data-v-8a7038a4>
                Dividend Aristocrats 2022
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Dividend%20Growth%20Portfolio&amp;id=77" class="navbar-link" data-v-8a7038a4>
                Dividend Growth Portfolio
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Dividend%20Income%20Portfolio&amp;id=78" class="navbar-link" data-v-8a7038a4>
                Dividend Income Portfolio
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Fast%20Growers&amp;id=79" class="navbar-link" data-v-8a7038a4>
                Fast Growers
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Good%20Companies&amp;id=103" class="navbar-link" data-v-8a7038a4>
                Good Companies
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Hedge%20Fund%20Guru%20Top%2010%20Aggregated&amp;id=80" class="navbar-link" data-v-8a7038a4>
                Hedge Fund Guru Top 10 Aggregated
                <!----> <!----> <!----> <!----></a><a href="/screener?name=High%20Quality&amp;id=81" class="navbar-link" data-v-8a7038a4>
                High Quality
                <!----> <!----> <!----> <!----></a><a href="/screener?name=High%20Quality%20Low%20Capex%20w%20ROE%20ROC%20min&amp;id=84" class="navbar-link" data-v-8a7038a4>
                High Quality Low Capex w ROE ROC min
                <!----> <!----> <!----> <!----></a><a href="/screener?name=High%20Quality%20&amp;%20Low%20Capex&amp;id=87" class="navbar-link" data-v-8a7038a4>
                High Quality &amp; Low Capex
                <!----> <!----> <!----> <!----></a><a href="/screener?name=High%20Yield%20Insider%20Buys&amp;id=88" class="navbar-link" data-v-8a7038a4>
                High Yield Insider Buys
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Historical%20High%20Dividend%20Yields&amp;id=89" class="navbar-link" data-v-8a7038a4>
                Historical High Dividend Yields
                <!----> <!----> <!----> <!----></a><a href="/screener?name=International%20Gurus%27%20Top%20Holdings&amp;id=90" class="navbar-link" data-v-8a7038a4>
                International Gurus' Top Holdings
                <!----> <!----> <!----> <!----></a><a href="/screener?name=James%20Montier%20Short%20Screen&amp;id=91" class="navbar-link" data-v-8a7038a4>
                James Montier Short Screen
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Margin%20Decliners&amp;id=92" class="navbar-link" data-v-8a7038a4>
                Margin Decliners
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Mega%20Caps&amp;id=93" class="navbar-link" data-v-8a7038a4>
                Mega Caps
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Peter%20Lynch%20&amp;%20Warren%20Buffett&amp;id=94" class="navbar-link" data-v-8a7038a4>
                Peter Lynch &amp; Warren Buffett
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Peter%20Lynch%20Growth%20w%20Lower%20Valuation&amp;id=95" class="navbar-link" data-v-8a7038a4>
                Peter Lynch Growth w Lower Valuation
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Peter%20Lynch%20S&amp;L%20Traded%20Below%20Book&amp;id=96" class="navbar-link" data-v-8a7038a4>
                Peter Lynch S&amp;L Traded Below Book
                <!----> <!----> <!----> <!----></a><a href="/screener?name=PFCF%20Screener&amp;id=97" class="navbar-link" data-v-8a7038a4>
                PFCF Screener
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Piotroski%20Score%20Screener&amp;id=98" class="navbar-link" data-v-8a7038a4>
                Piotroski Score Screener
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Predictable%20Companies&amp;id=99" class="navbar-link" data-v-8a7038a4>
                Predictable Growth Companies
                <!----> <!----> <!----> <!----></a><a href="/screener?name=Profitable%20predictable%20margin%20expanders&amp;id=100" class="navbar-link" data-v-8a7038a4>
                Profitable predictable margin expanders
                <!----> <!----> <!----> <!----></a><!----><a href="/screener?name=Stocks%20Sold%20w%20less%20Cash&amp;id=102" class="navbar-link" data-v-8a7038a4>
                Stocks Sold w less Cash
                <!----> <!----> <!----> <!----></a><a href="/screener?name=The%20Stalwarts&amp;id=104" class="navbar-link" data-v-8a7038a4>
                The Stalwarts
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/screener?manage=screen" class="t-icon" data-v-8a7038a4>
                  My Screeners
                </a></div> <a href="/screener" class="navbar-link" data-v-8a7038a4>
                Create My Screener
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/ideas" class="t-icon" data-v-8a7038a4>
                  Value Screens
                </a></div> <a href="/ideas" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-8a7038a4>
                Stock Ideas
                <!----> <!----> <!----> <!----></a><a href="/screener" class="navbar-link" data-v-8a7038a4>
                All-In-One Screener
                <!----> <!----> <!----> <!----></a><a href="/screener?view=map&amp;show_header=false" class="navbar-link" data-v-8a7038a4>
                S&amp;P 500 Map
                <!----> <!----> <!----> <!----></a><a href="/screener?view=bubble&amp;show_header=false" class="navbar-link" data-v-8a7038a4>
                S&amp;P 500 Bubble
                <!----> <!----> <!----> <!----></a><a href="/screener?view=aggregate&amp;show_header=false" class="navbar-link" data-v-8a7038a4>
                S&amp;P 500 Aggregate
                <!----> <!----> <!----> <!----></a><a href="/screener/buffett-munger" class="navbar-link" data-v-8a7038a4>
                Buffett-Munger Screener
                <!----> <!----> <!----> <!----></a><a href="/industry" class="navbar-link" data-v-8a7038a4>
                Industry Overview
                <!----> <!----> <!----> <!----></a><a href="/screener/valuedcf" class="navbar-link" data-v-8a7038a4>
                Undervalued Predictable
                <!----> <!----> <!----> <!----></a><a href="/screener/grahamncav" class="navbar-link" data-v-8a7038a4>
                Benjamin Graham Net-Net
                <!----> <!----> <!----> <!----></a><a href="/screener/52weeklow" class="navbar-link" data-v-8a7038a4>
                52-week/3Y/5Y Lows
                <!----> <!----> <!----> <!----></a><a href="/screener/52weekhigh" class="navbar-link" data-v-8a7038a4>
                52-week/3Y/5Y Highs
                <!----> <!----> <!----> <!----></a><a href="/screener/magic-formula" class="navbar-link" data-v-8a7038a4>
                Magic Formula(Greenblatt)
                <!----> <!----> <!----> <!----></a><a href="/screener/dividend-stocks" class="navbar-link" data-v-8a7038a4>
                Dividend Stocks
                <!----> <!----> <!----> <!----></a><a href="/screener/peter-lynch-stocks" class="navbar-link" data-v-8a7038a4>
                Peter Lynch Screen
                <!----> <!----> <!----> <!----></a><a href="/screener/guru-sp-grid" class="navbar-link" data-v-8a7038a4>
                S&amp;P500 Grid
                <!----> <!----> <!----> <!----></a><a href="/screener/predictable" class="navbar-link" data-v-8a7038a4>
                Predictable Companies
                <!----> <!----> <!----> <!----></a><a href="/screener/spinoff" class="navbar-link" data-v-8a7038a4>
                Spin Off List
                <!----> <!----> <!----> <!----></a><a href="/screener/lowpb" class="navbar-link" data-v-8a7038a4>
                Historical Low P/B List
                <!----> <!----> <!----> <!----></a><a href="/screener/lowps" class="navbar-link" data-v-8a7038a4>
                Historical Low P/S List
                <!----> <!----> <!----> <!----></a><a href="/screener/short-stocks" class="navbar-link" data-v-8a7038a4>
                High Short Interest
                <!----> <!----> <!----> <!----></a><a href="/screener/upcoming-special-dividends" class="navbar-link" data-v-8a7038a4>
                Upcoming Special Dividends
                <!----> <!----> <!----> <!----></a><a href="/screener/delisted" class="navbar-link" data-v-8a7038a4>
                Delisted Stocks
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="https://www.gurufocus.com/model_portfolio.php" class="t-icon" data-v-8a7038a4>
                  Model Portfolios
                </a></div> <a href="https://www.gurufocus.com/model_portfolio.php" class="navbar-link" data-v-8a7038a4>
                Performances Overview
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=largecap" class="navbar-link" data-v-8a7038a4>
                Most Broadly Held Portfolio
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=hr_largecap" class="navbar-link" data-v-8a7038a4>
                Most Weighted Portfolio
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=midcap" class="navbar-link" data-v-8a7038a4>
                Buffett-Munger Top 25
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=gfscore_91_100" class="navbar-link" data-v-8a7038a4>
                GF Score &lt;= 100 Top 25
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=smallcap" class="navbar-link" data-v-8a7038a4>
                Top 25 Undervalued Predictable
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=cap20" class="navbar-link" data-v-8a7038a4>
                Top 25 52-week Low Predictable
              </a><a href="https://www.gurufocus.com/model_portfolio.php?mp=cap40" class="navbar-link" data-v-8a7038a4>
                Top 25 Historical Low P/S
              </a></div><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/ideas" class="t-icon" data-v-8a7038a4>
                  Stock Comparison
                </a></div> <a href="/ideas/airline-stocks" class="navbar-link" data-v-8a7038a4>
                Airline Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/artificial-intelligence-stocks" class="navbar-link" data-v-8a7038a4>
                Artificial Intelligence Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/bank-stocks" class="navbar-link" data-v-8a7038a4>
                Bank Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/biotech-stocks" class="navbar-link" data-v-8a7038a4>
                Biotech Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/blockchain-stocks" class="navbar-link" data-v-8a7038a4>
                Blockchain Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/chinese-stocks" class="navbar-link" data-v-8a7038a4>
                Chinese Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/dividend-stocks" class="navbar-link" data-v-8a7038a4>
                Dividend Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/ev-stocks" class="navbar-link" data-v-8a7038a4>
                EV Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/growth-stocks" class="navbar-link" data-v-8a7038a4>
                Growth Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/oil-stocks" class="navbar-link" data-v-8a7038a4>
                Oil Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/value-stocks" class="navbar-link" data-v-8a7038a4>
                Value Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas/virtual-reality-stocks" class="navbar-link" data-v-8a7038a4>
                Virtual Reality Stocks
                <!----> <!----> <!----> <!----></a><a href="/ideas#compare-stocks" class="navbar-link" data-v-8a7038a4>
                Compare More Stocks…
                <!----> <!----> <!----> <!----></a></div></div></div><div class="navbar-item" style="padding:0 !important;" data-v-8a7038a4><div data-v-8a7038a4><a href="/guru/latest-picks" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-8a7038a4>
          Gurus
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-8a7038a4></i></a></div> <div class="navbar-dropdown" data-v-8a7038a4><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/guru/latest-picks" class="t-icon" data-v-8a7038a4>
                  Guru Trades
                </a></div> <a href="/guru/latest-picks" class="navbar-link" data-v-8a7038a4>
                Latest Guru Picks
                <!----> <!----> <!----> <!----></a><a href="/guru/realtime-picks" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-8a7038a4>
                Real Time Picks
                <!----> <!----> <!----> <!----></a><a href="/guru/portfolio" class="navbar-link" data-v-8a7038a4>
                Guru Portfolio
                <!----> <!----> <!----> <!----></a><a href="/guru/top-holdings" class="navbar-link" data-v-8a7038a4>
                Top 10 Holdings View
                <!----> <!----> <!----> <!----></a><a href="/guru/bargains" class="navbar-link" data-v-8a7038a4>
                Guru Bargains
                <!----> <!----> <!----> <!----></a><a href="/guru/hot-picks" class="navbar-link" data-v-8a7038a4>
                Hot Picks
                <!----> <!----> <!----> <!----></a><a href="/guru/aggregated-portfolio" class="navbar-link" data-v-8a7038a4>
                Aggregated Portfolio
                <!----> <!----> <!----> <!----></a><a href="/guru/consensus-picks" class="navbar-link" data-v-8a7038a4>
                Consensus Picks
                <!----> <!----> <!----> <!----></a><a href="/guru/etfs" class="navbar-link" data-v-8a7038a4>
                ETFs
                <!----> <!----> <!----> <!----></a><a href="/guru/scoreboard" class="navbar-link" data-v-8a7038a4>
                Score Board
                <!----> <!----> <!----> <!----></a><a href="/guru/sector-picks" class="navbar-link" data-v-8a7038a4>
                Sector Picks
                <!----> <!----> <!----> <!----></a><a href="/guru/international-picks" class="navbar-link" data-v-8a7038a4>
                International Picks
                <!----> <!----> <!----> <!----></a><a href="/guru/industry-trends" class="navbar-link" data-v-8a7038a4>
                Industry Trends
                <!----> <!----> <!----> <!----></a><a href="/guru/geographic-trends" class="navbar-link" data-v-8a7038a4>
                Geographic Trend
                <!----> <!----> <!----> <!----></a><a href="/guru/option-holdings" class="navbar-link" data-v-8a7038a4>
                Options
                <!----> <!----> <!----> <!----></a><a href="/guru/european-shortings" class="navbar-link" data-v-8a7038a4>
                European Shorting
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/guru/list" class="t-icon" data-v-8a7038a4>
                  Guru Lists
                </a></div> <a href="/guru/list" class="navbar-link" data-v-8a7038a4>
                Complete Guru List
                <!----> <!----> <!----> <!----></a><a href="/guru/warren%2Bbuffett/summary" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-8a7038a4>
                Warren Buffett
                <!----> <!----> <!----> <!----></a><a href="/guru/bill%2Bgates/summary" class="navbar-link" data-v-8a7038a4>
                Bill Gates
                <!----> <!----> <!----> <!----></a><a href="/guru/mohnish%2Bpabrai/summary" class="navbar-link" data-v-8a7038a4>
                Mohnish Pabrai
                <!----> <!----> <!----> <!----></a><a href="/guru/carl%2Bicahn/summary" class="navbar-link" data-v-8a7038a4>
                Carl Icahn
                <!----> <!----> <!----> <!----></a><a href="/guru/george%2Bsoros/summary" class="navbar-link" data-v-8a7038a4>
                George Soros
                <!----> <!----> <!----> <!----></a><a href="/guru/david%2Btepper/summary" class="navbar-link" data-v-8a7038a4>
                David Tepper
                <!----> <!----> <!----> <!----></a><a href="/guru/seth%2Bklarman/summary" class="navbar-link" data-v-8a7038a4>
                Seth Klarman
                <!----> <!----> <!----> <!----></a><a href="/guru/bill%2Backman/summary" class="navbar-link" data-v-8a7038a4>
                Bill Ackman
                <!----> <!----> <!----> <!----></a><a href="/guru/joel%2Bgreenblatt/summary" class="navbar-link" data-v-8a7038a4>
                Joel Greenblatt
                <!----> <!----> <!----> <!----></a><a href="/guru/charlie%2Bmunger/summary" class="navbar-link" data-v-8a7038a4>
                Charlie Munger
                <!----> <!----> <!----> <!----></a><a href="/guru/michael%2Bprice/summary" class="navbar-link" data-v-8a7038a4>
                Michael Price
                <!----> <!----> <!----> <!----></a><a href="/guru/julian%2Brobertson/summary" class="navbar-link" data-v-8a7038a4>
                Julian Robertson
                <!----> <!----> <!----> <!----></a><a href="/guru/chuck%2Bakre/summary" class="navbar-link" data-v-8a7038a4>
                Chuck Akre
                <!----> <!----> <!----> <!----></a><a href="/guru/david%2Beinhorn/summary" class="navbar-link" data-v-8a7038a4>
                David Einhorn
                <!----> <!----> <!----> <!----></a><a href="/guru/tom%2Bgayner/summary" class="navbar-link" data-v-8a7038a4>
                Tom Gayner
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/guru/list" class="t-icon" data-v-8a7038a4>
                  My Guru Lists
                </a></div> </div></div></div><div class="navbar-item" style="padding:0 !important;" data-v-8a7038a4><div data-v-8a7038a4><a href="/insider/summary" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-8a7038a4>
          Insiders
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-8a7038a4></i></a></div> <div class="navbar-dropdown" data-v-8a7038a4><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/insider/summary" class="t-icon" data-v-8a7038a4>
                  Insider Trading Tracker
                </a></div> <a href="/insider/summary" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-8a7038a4>
                Real-Time Insider Picks
                <!----> <!----> <!----> <!----></a><a href="/insider/ceo" class="navbar-link" data-v-8a7038a4>
                CEO Buys/Sells
                <!----> <!----> <!----> <!----></a><a href="/insider/cfo" class="navbar-link" data-v-8a7038a4>
                CFO Buys/Sells
                <!----> <!----> <!----> <!----></a><a href="/insider/trend" class="navbar-link" data-v-8a7038a4>
                Insider Trends
                <!----> <!----> <!----> <!----></a><a href="/insider/cluster" class="navbar-link" data-v-8a7038a4>
                Insider Cluster
                <!----> <!----> <!----> <!----></a><a href="/insider/double" class="navbar-link" data-v-8a7038a4>
                Guru + Insider Double Buys
                <!----> <!----> <!----> <!----></a><a href="/insider/triple" class="navbar-link" data-v-8a7038a4>
                Triple Buys/Sells
                <!----> <!----> <!----> <!----></a><a href="/insider/chinese" class="navbar-link" data-v-8a7038a4>
                Chinese Insider
                <!----> <!----> <!----> <!----></a><a href="/insiders" class="navbar-link" data-v-8a7038a4>
                Complete Insider List
                <!----> <!----> <!----> <!----></a></div></div></div><div class="navbar-item" style="padding:0 !important;" data-v-8a7038a4><div data-v-8a7038a4><a href="/economic_indicators" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-8a7038a4>
          Market
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-8a7038a4></i></a></div> <div class="navbar-dropdown" data-v-8a7038a4><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/stock-market-valuations.php" class="t-icon" data-v-8a7038a4>
                  US Market Valuation
                </a></div> <a href="https://www.gurufocus.com/stock-market-valuations.php" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-8a7038a4>
                Buffett Indicator
              </a><a href="https://www.gurufocus.com/yield_curve.php" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-8a7038a4>
                U.S. Treasury Yield Curve
              </a><a href="https://www.gurufocus.com/shiller-PE.php" class="navbar-link" data-v-8a7038a4>
                Shiller P/E
              </a><a href="https://www.gurufocus.com/sector_shiller_pe.php" class="navbar-link" data-v-8a7038a4>
                Shiller P/E by Sectors
              </a><a href="/market/sp500-gf-value" class="navbar-link" data-v-8a7038a4>
                GF Value for S&amp;P 500 Index
                <!----> <!----> <!----> <!----></a><a href="https://www.gurufocus.com/buffett_assets_allocations.php" class="navbar-link" data-v-8a7038a4>
                Buffett Assets Allocation
              </a></div><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/global-market-valuation.php" class="t-icon" data-v-8a7038a4>
                  Global Market Valuation
                </a></div> <a href="https://www.gurufocus.com/global-market-valuation.php" class="navbar-link" data-v-8a7038a4>
                Global Market Overview
              </a><a href="https://www.gurufocus.com/stock-market-valuations.php" class="navbar-link" data-v-8a7038a4>
                USA
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=CHN" class="navbar-link" data-v-8a7038a4>
                China
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=JPN" class="navbar-link" data-v-8a7038a4>
                Japan
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=IND" class="navbar-link" data-v-8a7038a4>
                India
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=CND" class="navbar-link" data-v-8a7038a4>
                Canada
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=GBR" class="navbar-link" data-v-8a7038a4>
                UK
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=CND" class="navbar-link" data-v-8a7038a4>
                France
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=GER" class="navbar-link" data-v-8a7038a4>
                Germany
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=BRZ" class="navbar-link" data-v-8a7038a4>
                Brazil
              </a><a href="https://www.gurufocus.com/global-market-valuation.php?country=AUS" class="navbar-link" data-v-8a7038a4>
                Australia
              </a><a href="https://www.gurufocus.com/global-market-valuation.php" class="navbar-link" data-v-8a7038a4>
                More...
              </a></div><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/economic_indicators" class="t-icon" data-v-8a7038a4>
                  Economic Indicators
                </a></div> <a href="/economic_indicators" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-8a7038a4>
                Economic Indicators Overview
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/229/the-dow-jones-industrial-average-djia" class="navbar-link" data-v-8a7038a4>
                The Dow Jones Industrial Average (DJIA)
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/63/sp-500-index" class="navbar-link" data-v-8a7038a4>
                SP 500 Index
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/232/nasdaq-composite-index" class="navbar-link" data-v-8a7038a4>
                Nasdaq Composite Index
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/20/gross-domestic-product-gdp" class="navbar-link" data-v-8a7038a4>
                Gross Domestic Product (GDP)
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/56/shiller-pe" class="navbar-link" data-v-8a7038a4>
                Shiller PE
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/60/ratio-of-wilshire-5000-over-gnp" class="navbar-link" data-v-8a7038a4>
                Ratio of Wilshire 5000 over GNP
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/10/civilian-unemployment-rate" class="navbar-link" data-v-8a7038a4>
                Civilian Unemployment Rate
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/231/russell-2000-small-cap-price-index" class="navbar-link" data-v-8a7038a4>
                Russell 2000 Small Cap Price Index
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/234/cboe-volatility-index-the-vix" class="navbar-link" data-v-8a7038a4>
                CBOE Volatility Index (VIX)
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators/14/total-nonfarm-payrolls-all-employees" class="navbar-link" data-v-8a7038a4>
                Total Nonfarm Payrolls: All Employees
                <!----> <!----> <!----> <!----></a><a href="/economic_indicators" class="navbar-link" data-v-8a7038a4>
                More...
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/industry" class="t-icon" data-v-8a7038a4>
                  Sector &amp; Industry Performance
                </a></div> <a href="/industry" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-8a7038a4>
                Global Industry Overview
                <!----> <!----> <!----> <!----></a><a href="/industry/usa" class="navbar-link" data-v-8a7038a4>
                USA
                <!----> <!----> <!----> <!----></a><a href="/industry/asia" class="navbar-link" data-v-8a7038a4>
                Asia
                <!----> <!----> <!----> <!----></a><a href="/industry/europe" class="navbar-link" data-v-8a7038a4>
                Europe
                <!----> <!----> <!----> <!----></a><a href="/industry/canada" class="navbar-link" data-v-8a7038a4>
                Canada
                <!----> <!----> <!----> <!----></a><a href="/industry/uk-ireland" class="navbar-link" data-v-8a7038a4>
                UK/Ireland
                <!----> <!----> <!----> <!----></a><a href="/industry/oceania" class="navbar-link" data-v-8a7038a4>
                Oceania
                <!----> <!----> <!----> <!----></a><a href="/industry/latin-america" class="navbar-link" data-v-8a7038a4>
                Latin America
                <!----> <!----> <!----> <!----></a><a href="/industry/africa" class="navbar-link" data-v-8a7038a4>
                Africa
                <!----> <!----> <!----> <!----></a><a href="/industry/india-pakistan" class="navbar-link" data-v-8a7038a4>
                India/Pakistan
                <!----> <!----> <!----> <!----></a></div></div></div><div class="navbar-item" style="padding:0 !important;" data-v-8a7038a4><div data-v-8a7038a4><a href="/news?cat=timeless" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-8a7038a4>
          Articles
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-8a7038a4></i></a></div> <div class="navbar-dropdown" data-v-8a7038a4><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/news" class="t-icon" data-v-8a7038a4>
                  Articles
                </a></div> <a href="/news?cat=timeless" class="navbar-link" data-v-8a7038a4>
                Editors' Picks
                <!----> <!----> <!----> <!----></a><a href="/news?cat=qa" class="navbar-link" data-v-8a7038a4>
                Q&amp;A with Gurus
                <!----> <!----> <!----> <!----></a><a href="/news?cat=rank" class="navbar-link" data-v-8a7038a4>
                Top Ranked
                <!----> <!----> <!----> <!----></a><a href="/news?cat=guru" class="navbar-link" data-v-8a7038a4>
                News
                <!----> <!----> <!----> <!----></a><a href="/news?cat=contest" class="navbar-link" data-v-8a7038a4>
                Value Idea Contest
                <!----> <!----> <!----> <!----></a></div><div class="navbar-sub" data-v-8a7038a4><div class="navbar-sub-title" data-v-8a7038a4><a href="/news/post" class="t-icon" data-v-8a7038a4>
                  Submit Articles
                </a></div> <a href="/news/post" class="navbar-link" data-v-8a7038a4>
                Submit Article Online
                <!----> <!----> <!----> <!----></a><a href="https://www.gurufocus.com/news/70028" class="navbar-link" data-v-8a7038a4>
                Writers Wanted
              </a></div></div></div><div class="navbar-item" style="padding:0 !important;" data-v-8a7038a4><div data-v-8a7038a4><div class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-8a7038a4>
          Tools
          <i class="gf-icon-chevron-down" style="font-size:10px;" data-v-8a7038a4></i></div></div> <div class="navbar-dropdown" data-v-8a7038a4><a href="https://www.gurufocus.com/model_portfolio.php" class="navbar-link" data-v-8a7038a4><!----> <!---->
              Model Portfolios
            </a><a href="/screener" class="navbar-link" data-v-8a7038a4>
              All-In-One Screener
            </a><a href="https://www.gurufocus.com/download_financials_batch.php" class="navbar-link" data-v-8a7038a4><!----> <!---->
              Data Batch Download
            </a><a href="/guru/download-guru-portfolio" class="navbar-link" data-v-8a7038a4>
              Guru Portfolio Download
            </a><a href="/insider/data-export" class="navbar-link" data-v-8a7038a4>
              Insider Data Download
            </a><a href="/excel-add-in" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-8a7038a4>
              Excel Add-In
            </a><a href="/google-sheets-add-on" class="navbar-link" data-v-8a7038a4>
              Google Sheets Add-On
            </a><a href="/api" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-8a7038a4>
              API
            </a><a href="https://www.gurufocus.com/download_stockmanual.php" class="navbar-link" data-v-8a7038a4><!----> <!---->
              Manual of Stocks
            </a><a href="/dcf-calculator" class="navbar-link" style="color:var(--color-danger-color);font-weight:700;" data-v-8a7038a4>
              DCF Calculator
            </a><a href="/stock/AAPL/chart" class="navbar-link" data-v-8a7038a4>
              Interactive Chart
            </a><a href="/screener?view=map&amp;show_header=false" class="navbar-link" data-v-8a7038a4>
              Maps
            </a><a href="/fund-letters" class="navbar-link" data-v-8a7038a4>
              Fund Letters Archive
            </a><a href="/compare-table" class="navbar-link" data-v-8a7038a4>
              Stock Comparison Table
            </a><a href="/mobile-app" class="navbar-link" data-v-8a7038a4>
              Mobile App
            </a><a href="/discussion" class="navbar-link" data-v-8a7038a4>
              Discussion Board
            </a></div></div><div class="navbar-item" style="padding:0 !important;" data-v-8a7038a4><div data-v-8a7038a4><a href="https://gurufocusetf.com/" target="_blank" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-8a7038a4>
          ETF
          <!----></a></div> <!----></div><div class="navbar-item" style="padding:0 !important;" data-v-8a7038a4><div data-v-8a7038a4><a href="/pricing" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-8a7038a4>
          Pricing
          <!----></a></div> <!----></div><div class="navbar-item navbar-right-item" style="padding:0 !important;" data-v-8a7038a4><div data-v-8a7038a4><a href="/tutorial" class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-8a7038a4>
          Tutorials
          <!----></a></div> <div class="navbar-dropdown" data-v-8a7038a4><a href="/tutorial" class="navbar-link" data-v-8a7038a4>
              Tutorials 
            </a><a href="/glossary" class="navbar-link" data-v-8a7038a4>
              Financial Glossary
            </a><a href="https://www.gurufocus.com/faq.php" class="navbar-link" data-v-8a7038a4><!----> <!---->
              FAQ
            </a><a href="/changelog" class="navbar-link" data-v-8a7038a4>
              Change Log
            </a><a href="https://www.gurufocus.com/ticket/open.php" class="navbar-link" data-v-8a7038a4><!----> <!---->
              Contact Us
            </a></div></div><div class="navbar-item navbar-right-item" style="padding:0 !important;" data-v-8a7038a4><div data-v-8a7038a4><div class="block" style="padding:16px 8px;line-height:24px;color:white !important;" data-v-8a7038a4>
          Support
          <!----></div></div> <div class="navbar-dropdown" data-v-8a7038a4><span data-name="Support" slot="reference" data-v-8a7038a4><span class="navbar-link nuxt-link-exact-active nuxt-link-active"><i class="gfp-live-chat"></i>
    Chat Support
  </span> <div id="phplive_btn_1570480208"></div></span><a href="https://www.gurufocus.com/ticket/open.php" target="_blank" class="navbar-link" data-v-8a7038a4><i class="gf-icon-tickets" data-v-8a7038a4></i>
              Create a ticket
            </a><a href="/schedule_meeting" class="navbar-link" data-v-8a7038a4><i class="gfp-calendar" data-v-8a7038a4></i>
              Schedule a Meeting
            </a><a href="/meeting" class="navbar-link" data-v-8a7038a4>
              User Engagement Meeting
            </a><span slot="reference" class="phone-session" data-v-c1848554 data-v-8a7038a4><span data-v-c1848554><i class="gf-icon-phone" data-v-c1848554></i>
    469-248-6885
  </span></span><a href="https://status.gurufocus.com/" class="navbar-link" data-v-8a7038a4><!----> <i class="gf-icon-wrench" data-v-8a7038a4></i>
              Status
            </a></div></div> <div class="navbar-item navbar-item-hoverable navbar-right-item" style="padding:0 !important;" data-v-7b891cb3 data-v-8a7038a4><div data-v-7b891cb3><a href="https://www.gurufocus.com/membership/new/index.html#/?ref=news-message_id-subject&amp;sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=new_navbar_free_trial" class="block p-v-lg p-h-sm" data-v-7b891cb3><span class="basic-navbar-title" data-v-7b891cb3>
        Subscribe
      </span></a></div> <div class="navbar-dropdown" data-v-7b891cb3><a href="https://www.gurufocus.com/membership/new/index.html#/?ref=news-message_id-subject&amp;sel=premium&amp;utm_source=webApp&amp;utm_medium=userClick&amp;utm_campaign=new_navbar_free_trial_item" class="navbar-link" data-v-7b891cb3>
      Free Trial
    </a><a href="https://www.gurufocus.com/user_referrals.php" class="navbar-link" data-v-7b891cb3>
      Refer a Friend and Earn $50
    </a></div></div> <!----></div></div> <div id="tags-view" class="tags-view" style="padding-left:10px;padding-right:10px;" data-v-4cfae286><div class="tags-view-section hide-on-print" style="display:flex" data-v-4cfae286><div style="margin-left: auto;order: 2;min-width: 48px;overflow:hidden" data-v-4cfae286><!----><!----><!----><!----><!----><!----><!----><!----><!----><!----><!----></div> <div class="search-bar-section" style="width:250px;" data-v-eed35b3c data-v-4cfae286><div class="flex flex-center flex-nowrap input-box" data-v-eed35b3c><i class="gf-icon-search t-icon" style="margin-left: 12px; margin-top: 4px;" data-v-eed35b3c></i> <input placeholder="Ticker, Guru, Company .." autocomplete="page-search" value="" class="input" data-v-eed35b3c> <!----></div> <!----></div> <!----></div></div> <!----></header> <section class="el-container" style="height:calc(100vh - 104px);"><main id="components-root" class="el-main auto-height-on-print capture-areaz scroll"><section class="el-container enable-darkmode page-container is-vertical" style="max-width:1400px;" data-v-4a02f964><main class="el-main center" data-v-4a02f964 data-v-4a02f964><div frame="frame-xl" class="gf center" style="padding-bottom:0px;" data-v-9fb2902a data-v-4a02f964><div class="el-row" style="margin-left:-20px;margin-right:-20px;" data-v-9fb2902a><div id="article-main-section-1909362" class="el-col el-col-16" style="padding-left:20px;padding-right:20px;" data-v-9fb2902a><h1 class="t-h1 fc-primary fw-bolder subject" data-v-9fb2902a>
        Belden's New DCX System Supports Fast &amp; Easy Management of Terminations in Fiber-Dense Environments
        <!----> <!----> <!----></h1> <!----> <!----> <div class="row-padding" data-v-70c3154b data-v-9fb2902a><div class="author-item global-flex-container" data-v-70c3154b><div style="margin-right: 12px;" data-v-70c3154b><a href="/user/gumozhyhru" class="left avatar" data-v-70c3154b><img alt="Author's Avatar" height="48px" width="48px" src="https://avatar.gurufocus.com/590272_small.png" style="vertical-align:middle;border-radius:50%;object-fit:scale-down;" data-v-70c3154b></a></div> <div data-v-70c3154b><div data-v-70c3154b><a href="/user/gumozhyhru" class="fc-normal-i body-small fw-bolder" style="margin-right: 12px;" data-v-70c3154b><span data-v-70c3154b> Business Wire </span></a> <button type="button" class="el-button gf no-border el-button--primary el-button--mini" data-v-70c3154b><!----><!----><span>
          Follow
        </span></button></div> <div class="body-small fc-light" style="line-height: 24px; margin-top: 2px;" data-v-70c3154b><span data-v-70c3154b> 2 minutes ago </span></div></div></div> <div class="fc-normal global-flex-container fc-normal" style="float:right;position:relative;top:-34px;font-size:24px;" data-v-70c3154b><!----> <div><span style="display:inline-block !important;" data-v-809c1338><i class="el-icon-collection" style="cursor: pointer;font-size: 20px;" data-v-809c1338></i> <div class="el-dialog__wrapper" style="display:none;" data-v-809c1338><div role="dialog" aria-modal="true" aria-label="Bookmark" class="el-dialog" style="margin-top:15vh;"><div class="el-dialog__header"><span class="el-dialog__title">Bookmark</span><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><!----><div class="el-dialog__footer"><span class="dialog-footer" data-v-809c1338><button type="button" class="el-button el-button--default el-button--mini" data-v-809c1338><!----><!----><span>Cancel</span></button> <button type="button" class="el-button el-button--primary el-button--mini" data-v-809c1338><!----><!----><span>Confirm</span></button></span></div></div></div></span> <span class="share-button" style="display:inline-block !important;" data-v-73745932><div role="tooltip" id="el-popover-6607" aria-hidden="true" class="el-popover el-popper gf aio-popover no-padding" style="width:undefinedpx;display:none;"><!----><!----></div><span title="Share &amp; Print" class=" " style="background:transparent;" data-v-73745932><i class="gf-icon-share hover-pointer" data-v-73745932></i></span></span> <i class="gf-icon-printer cursor-pointer"></i></div></div></div> <!----> <img src="" alt="Article's Main Image" title="" width="50%" style="padding-top:40px;max-height:600px;display:block;margin:auto;padding-bottom:10px;object-fit:contain;float:left;margin-right:24px;" data-v-9fb2902a> <div id="article-body-1909362" class="main-body" style="margin-top:40px;" data-v-9fb2902a><p>
Belden, a leading global supplier of network infrastructure solutions, is excited to announce the launch of its DCX System, an innovative, high-density, end-to-end fiber infrastructure solution with built-in futureproof functionality for any data center. It provides extremely high fiber termination density in a small footprint, with 3,840* terminations per DCX cabinet, 1,280 terminated fibers per square foot.
</p><p>
The DCX System is designed to maximize signal integrity through bend radius control for incoming and outgoing cables. Patch cord access is made simple with pull-out trays and plenty of clearance around each connector. The DCX System also supports many fiber termination methods and migration from any combination of 8- or 12-fiber pre-terminated adapter frames without infrastructure changes.
</p><p>
As an end-to-end fiber infrastructure solution, the DCX System includes:
</p><ul class="bwlistdisc"><li>
Space-saving optical distribution frame front-access cabinets that are completely configurable and scalable by assembling side by side and/or back-to-back
</li> <li>
Cabinet components, including additional cable entry brackets and patch cord telescopic spools, that are simple to install to dress incoming cables and patch cords
</li> <li>
Optical distribution frame housings that are available in left-to-right and right-to-left configurations, with a front-access design that pulls out for easy access to cables
</li> <li>
The adapter frames and cassettes maximize ROI by migrating networking technologies in the same housing such as the assembly of two (Base-24), four (Base-12) or six (Base-8) cassettes per housing tray
</li> <li>
Rack-mount patch panel housings available in 1U, 2U and 4U configurations that are compatible with all DCX Cassettes and Adapter Frames
</li></ul><p>
“Fiber usage is increasing in many environments, including data centers, broadcast environments and large venues and stadiums, to support higher density and emerging technologies,” says Benoit Chevarie, global product manager for connectivity at Belden. “The DCX System provides a way to effectively manage growing numbers of fiber connections to ensure uptime and efficient operation and maintenance.”
</p><p>
To learn more about the DCX System and managing high-density fiber connections, visit <a href>www.belden.com%2FDCX</a>.
</p><p><i>*Other termination models available outside of the United States</i></p><p><b>About Belden</b></p><p>
Belden Inc. delivers the infrastructure that makes the digital journey simpler, smarter and more secure. We’re moving beyond connectivity—from what we make to what we make possible through a performance-driven portfolio, forward-thinking expertise and purpose-built solutions. With a legacy of quality and reliability spanning 120-plus years, we have a strong foundation to continue building the future. We are headquartered in St. Louis and have manufacturing capabilities in North America, Europe, Asia and Africa. For more information, visit us at <a href>www.belden.com</a>; follow us on <a href>Facebook</a>, <a href>LinkedIn</a> and <a href>Twitter</a>.
</p><p><i>Belden, the Belden logo, Belden Horizon, Hirschmann, and Lumberg Automation are trademarks or registered trademarks of Belden Inc. or its affiliated companies in the United States and other jurisdictions. Belden and other parties may also have trademark rights in other terms used herein.</i></p><p><img src="https://cts.businesswire.com/ct/CT?id=bwnews&sty=20221213005123r1&sid=txguf&distro=ftp" alt="CT?id=bwnews&sty=20221213005123r1&sid=txguf&distro=ftp"></p><p><span>View source version on businesswire.com: </span><span><a href="https://www.businesswire.com/news/home/20221213005123/en/" rel="nofollow" target="_blank">https://www.businesswire.com/news/home/20221213005123/en/</a></span></p><p></p></div> <!----> <div style="margin-top:20px;margin-bottom:30px;" data-v-9fb2902a><span data-v-9fb2902a><span class="fs-large fw-bolder" data-v-9fb2902a>Rating: </span> <div role="slider" aria-valuenow="0" aria-valuetext="" aria-valuemin="0" aria-valuemax="5" tabindex="0" class="el-rate my_rating" data-v-9fb2902a><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"><!----></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"><!----></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"><!----></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"><!----></i></span><span class="el-rate__item" style="cursor:pointer;"><i class="el-rate__icon el-icon-star-off" style="color:#C6D1DE;"><!----></i></span><!----></div> <span class="fs-large fw-bolder" data-v-9fb2902a>NaN</span> <span class="fs-large" data-v-9fb2902a>/ 5 ( votes)</span></span> <div class="fc-normal global-flex-container fc-normal" style="float:right;position:relative;top:0px;font-size:24px;" data-v-9fb2902a><!----> <div><span style="display:inline-block !important;" data-v-809c1338><i class="el-icon-collection" style="cursor: pointer;font-size: 20px;" data-v-809c1338></i> <div class="el-dialog__wrapper" style="display:none;" data-v-809c1338><div role="dialog" aria-modal="true" aria-label="Bookmark" class="el-dialog" style="margin-top:15vh;"><div class="el-dialog__header"><span class="el-dialog__title">Bookmark</span><button type="button" aria-label="Close" class="el-dialog__headerbtn"><i class="el-dialog__close el-icon el-icon-close"></i></button></div><!----><div class="el-dialog__footer"><span class="dialog-footer" data-v-809c1338><button type="button" class="el-button el-button--default el-button--mini" data-v-809c1338><!----><!----><span>Cancel</span></button> <button type="button" class="el-button el-button--primary el-button--mini" data-v-809c1338><!----><!----><span>Confirm</span></button></span></div></div></div></span> <span class="share-button" style="display:inline-block !important;" data-v-73745932><div role="tooltip" id="el-popover-3989" aria-hidden="true" class="el-popover el-popper gf aio-popover no-padding" style="width:undefinedpx;display:none;"><!----><!----></div><span title="Share &amp; Print" class=" " style="background:transparent;" data-v-73745932><i class="gf-icon-share hover-pointer" data-v-73745932></i></span></span> <i class="gf-icon-printer cursor-pointer"></i></div></div></div> <div id="article-view-1909362" style="height:1px;" data-v-9fb2902a></div> <lazy-component class="comment-section" style="min-height:2px;" data-v-9fb2902a><div class="article-comment gf-border-b" style="padding:40px 0;" data-v-70275c48 data-v-9fb2902a><!----> <div data-v-70275c48><a href="https://www.gurufocus.com/forum/login.php?0" class="color-main-blue-i" data-v-70275c48> Please Login to Comment </a></div> <!----> <div class="row-padding" style="display:none;" data-v-70275c48><editor id="comment-editor-1909362" api-key="xfli4zk8nqwi7onsi4cqfz3e67p26wd3lh3bym9l67xplf9c" init="[object Object]" class="invert" data-v-70275c48></editor> <div class="p-t-md" data-v-70275c48><!----> <!----> <!----></div></div> <!---->  <!----></div></lazy-component> <lazy-component class="author-section" style="min-height:200px;" data-v-9fb2902a><div style="padding:40px 0;border-top:1px solid var(--color-border);" data-v-6c1d0641 data-v-9fb2902a><div class="global-flex-container-start" style="position: relative;" data-v-6c1d0641><a href="/user/590272" class="link" style="margin-right:16px;" data-v-6c1d0641><img alt="Author's Avatar" height="64px" width="64px" src="https://avatar.gurufocus.com/590272_small.png" style="vertical-align:middle;border-radius:50%;object-fit:scale-down;" data-v-6c1d0641></a> <div data-v-6c1d0641><div class="fs-large fc-light-grey" data-v-6c1d0641>
        WRITTEN BY
      </div> <button type="button" class="el-button bg-main-blue-i fc-white-i right-float el-button--default el-button--medium" style="position:absolute;right:0px;top:0px;" data-v-6c1d0641><!----><!----><span>
        Follow
      </span></button> <div data-v-6c1d0641><a href="/user/gumozhyhru" class="link" data-v-6c1d0641><h3 class="fs-20 fw-bolder fc-normal" data-v-6c1d0641>
            Business Wire
          </h3></a></div> <div class="fs-large fc-light-grey" style="margin-top:14px;" data-v-6c1d0641><!----></div></div></div> <br data-v-6c1d0641> <!----> <div class="el-row" style="margin-left:-5px;margin-right:-5px;display:flex;" data-v-6c1d0641></div></div></lazy-component></div> <div class="el-col el-col-8" style="padding-left:20px;padding-right:20px;border-left:1px solid var(--color-border);" data-v-9fb2902a><div style="margin-top:20px;" data-v-6c058c0c data-v-9fb2902a data-v-9fb2902a><Adsense data-ad-client="ca-pub-4020868656364652" ins-style="display:inline-block;width:380px;height:300px" data-ad-slot="8601925817" data-v-6c058c0c></Adsense> <div style="padding-bottom: 32px; margin-bottom: 32px;  border-bottom: 1px solid var(--color-border);" data-v-6c058c0c><h3 class="fs-x-large-s fc-normal fw-bolder inline" style="margin-bottom: 12px;" data-v-6c058c0c>
      Request A Demo
    </h3> <div data-v-6c058c0c>
      Learn more about GuruFocus' key features, including All-In-One Screener, backtesting, 30-year financial, stock summary page, guru trades, insider trades, excel Add-in, google sheets and much more.
    </div> <div style="text-align:center; margin-top: 16px;" data-v-6c058c0c><a href="/schedule_meeting" data-v-6c058c0c><button type="button" class="el-button gf el-button--primary el-button--small" data-v-6c058c0c><!----><!----><span><i class="gfp-calendar" data-v-6c058c0c></i>
          Request A Demo
        </span></button></a></div></div> <!----> <!----> <!----> <!----> <!----> <!----> <h3 class="fs-x-large-s fc-normal fw-bolder inline" style="margin-bottom: 12px;" data-v-6c058c0c>
    GuruFocus Screeners
  </h3> <div class="screener-part" style="margin-bottom:32px;padding-bottom:32px;border-bottom:1px solid var(--color-border);" data-v-6c058c0c><!----></div> <h3 class="fs-x-large-s fc-normal fw-bolder inline row-padding" data-v-6c058c0c>
    Related Articles
  </h3> <!----></div></div></div> <hr class="thin" data-v-9fb2902a></div> <!----> <div id="article-bottom" class="p-b-md" style="height:8px;" data-v-4a02f964></div></main> <footer class="el-footer" style="height:60px;" data-v-4a02f964></footer></section> <div class="page-footer use-darkmode gf" style="clear:both;margin-top:40px;" data-v-46447848><div class="divider-1" data-v-46447848></div> <div class="page-footer-row el-row el-row" data-v-46447848><div class="hide-on-print el-col el-col el-col-24 el-col-xs-6 el-col-sm-6 el-col-md-4 el-col-lg-4" data-v-46447848><div class="fs-large color-primary fw-bolder" data-v-46447848>
        Research Tools
      </div> <a href="https://www.gurufocus.com/screener" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        All-In-One Screener
      </a><a href="https://www.gurufocus.com/ideas" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Stock Ideas
      </a><a href="https://www.gurufocus.com/stocks" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Stock List
      </a><a href="https://www.gurufocus.com/guru/list" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Guru List
      </a><a href="https://www.gurufocus.com/guru/realtime-picks" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Guru Real-Time Picks
      </a><a href="https://www.gurufocus.com/insiders" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Insider List
      </a><a href="https://www.gurufocus.com/insider/summary" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Insider Trades
      </a><a href="https://www.gurufocus.com/economic_indicators" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Economic Indicators
      </a><a href="https://www.gurufocus.com/industry" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Sector &amp; Industry Performance
      </a><a href="https://www.gurufocus.com/stock/AAPL/dcf" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        DCF Calculator
      </a><a href="https://www.gurufocus.com/discussion" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Discussion Board
      </a> <!----></div><div class="hide-on-print el-col el-col el-col-24 el-col-xs-6 el-col-sm-6 el-col-md-4 el-col-lg-4" data-v-46447848><div class="fs-large color-primary fw-bolder" data-v-46447848>
        Product
      </div> <a href="https://www.gurufocus.com/pricing" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Pricing Plans
      </a><a href="https://www.gurufocus.com/excel-add-in" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Excel Add-In
      </a><a href="https://www.gurufocus.com/google-sheets-add-on" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Google Sheets Add-on
      </a><a href="https://www.gurufocus.com/api" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Data API
      </a><a href="https://www.gurufocus.com/compare-table" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Stock Comparison Table
      </a><a href="https://www.gurufocus.com/download_stockmanual.php" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Manual of Stocks
      </a><a href="https://www.gurufocus.com/mobile-app" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Mobile App
      </a><a href="https://www.gurufocus.cn/" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        中文
      </a> <!----></div><div class="hide-on-print el-col el-col el-col-24 el-col-xs-6 el-col-sm-6 el-col-md-4 el-col-lg-4" data-v-46447848><div class="fs-large color-primary fw-bolder" data-v-46447848>
        Education
      </div> <a href="https://www.gurufocus.com/glossary" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Financial Glossary
      </a><a href="https://www.gurufocus.com/tutorial" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Tutorials
      </a><a href="https://www.gurufocus.com/faq.php" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        FAQ
      </a><a href="https://www.gurufocus.com/schedule_meeting" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Schedule Free Session
      </a><a href="https://www.gurufocus.com/stock-market-valuations.php" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Buffett Indicator
      </a><a href="https://www.gurufocus.com/shiller-PE.php" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Shiller P/E
      </a><a href="https://www.gurufocus.com/yield_curve.php" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Yield Curve Today
      </a><a href="https://www.gurufocus.com/global-market-valuation.php" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Global Market Valuation
      </a><a href="https://www.gurufocus.com/buffett_assets_allocations.php" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Buffett Assets Allocation
      </a> <!----></div><div class="hide-on-print el-col el-col el-col-24 el-col-xs-6 el-col-sm-6 el-col-md-4 el-col-lg-4" data-v-46447848><div class="fs-large color-primary fw-bolder" data-v-46447848>
        Company
      </div> <a href="https://www.gurufocus.com/about" target="" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        About GuruFocus
      </a><a href="https://www.gurufocus.com/jobs.php" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Career
      </a><a href="https://www.gurufocus.com/ticket/open.php" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Contact Us
      </a><a href="https://gurufocusetf.com" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        ETF
      </a><a href="https://static.gurufocus.com/etf/GuruFocusADVPart2A.pdf?1" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        ADV Part 2A
      </a><a href="https://static.gurufocus.com/etf/GuruFocusADVPart2B.pdf?1" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        ADV Part 2B
      </a><a href="https://static.gurufocus.com/etf/GuruFocusADVPart3.pdf?1" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        ADV Part 3
      </a><a href="https://www.gurufocus.com/sponsor.php" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Advertise
      </a><a href="https://www.gurufocus.com/sitemap.php" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Site Map
      </a><a href="https://www.gurufocus.com/term-of-use" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Term of Use
      </a><a href="https://www.gurufocus.com/privacy-policy" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Privacy Policy
      </a><a href="https://www.gurufocus.com/user_referrals.php" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Referral Program
      </a><a href="https://www.gurufocus.com/membership/AffiliateProgramFAQ.php" target="_blank" class="fs-regular fc-regular color-primary" style="margin-top:8px;display:block;" data-v-46447848>
        Affiliate Program
      </a> <!----></div> <div class="el-col el-col el-col-24 el-col-xs-24 el-col-sm-24 el-col-md-8 el-col-lg-8" data-v-46447848><div style="position:relative;" data-v-46447848><div class="download-app" data-v-46447848><a href="https://itunes.apple.com/us/app/gurufocus/id1054144526" data-v-46447848><!----></a> <a href="https://play.google.com/store/apps/details?id=com.gurufocus.app" data-v-46447848><!----></a></div> <div class="fs-large color-primary fw-bolder" style="margin-bottom:6px;" data-v-46447848>
          Follow Us
        </div> <div style="font-size:25px;" data-v-46447848><a href="https://twitter.com/gurufocus" target="_blank" title="Twitter" data-v-46447848><i class="gfp-twitter-dark color-gray gf-margin-h-5" data-v-46447848></i></a> <a href="https://www.youtube.com/user/GuruFocusVideos" target="_blank" title="YouTube" data-v-46447848><i class="gfp-youtube-dark color-gray gf-margin-h-5" data-v-46447848></i></a> <a href="https://www.facebook.com/GuruFocus/" target="_blank" title="FaceBook" data-v-46447848><i class="gfp-facebook-dark color-gray gf-margin-h-5" data-v-46447848></i></a> <a href="https://www.instagram.com/gurufocus/" target="_blank" title="Instagram" data-v-46447848><i class="gfp-instagram color-gray gf-margin-h-5" data-v-46447848></i></a></div></div> <div class="fs-large color-primary fw-bolder" style="margin-top:10px;" data-v-46447848>
        Disclaimers
      </div> <div class="fs-small fc-regular page-footer-information" data-v-46447848>
        
        GuruFocus.com is not operated by a broker or a dealer. It has an affiliated registered investment adviser, which serves as the subadviser to an exchange traded fund. This investment adviser does not provide advice to individual investors. Under no circumstances does any information posted on GuruFocus.com represent a recommendation to buy or sell a security. The information on this site, and in its related newsletters, is not intended to be, nor does it constitute investment advice or recommendations. The individuals or entities selected as &quot;gurus&quot; may buy and sell securities before and after any particular article and report and information herein is published, with respect to the securities discussed in any article and report posted herein. Gurus may be added or dropped from the GuruFocus site at any time. In no event shall GuruFocus.com be liable to any member, guest or third party for any damages of any kind arising out of the use of any content or other material published or available on GuruFocus.com, or relating to the use of, or inability to use, GuruFocus.com or any content, including, without limitation, any investment losses, lost profits, lost opportunity, special, incidental, indirect, consequential or punitive damages. Past performance is a poor indicator of future performance. The information on this site, and in its related newsletters, is not intended to be, nor does it constitute investment advice or recommendations. The information on this site is in no way guaranteed for completeness, accuracy or in any other way. The gurus listed in this website are not affiliated with GuruFocus.com, LLC. Stock quotes provided by InterActive Data. Fundamental company data provided by Morningstar, updated daily.
      
      </div></div></div> <div class="divider-1" data-v-46447848></div> <div class="fs-small middle-align page-footer-brand" data-v-46447848>
    © 2004-2022 GuruFocus.com, LLC. All Rights Reserved.
  </div></div> <!----> <!----></main> <aside class="el-aside" style="width:0;overflow:hidden;" data-v-30a69892><!----> <div class="fixed-button chat-button" data-v-30a69892><span class="fixed-icon-wraper bg-main-blue"><i class="gfp-live-chat fixed-icon-item"></i></span></div> <div class="fixed-button note-bar-button" data-v-30a69892><span class="fixed-icon-wraper bg-main-blue" data-v-30a69892><i alt="Notes" title="Notes &amp; Discussions" class="fixed-icon-item el-icon-edit" data-v-30a69892></i></span></div> <!----></aside></section> <div id="myModal" class="modal"><img id="modalImg" class="modal-content"> <div id="modalCaption"></div></div> <!----> <!----></section></div></div><script>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</script><script src="/_nuxt/3dca26e1a942ee3370e2.1670886052668.js" defer></script><script src="/_nuxt/55db85c2eaab01a2040f.1670886052668.js" defer></script><script src="/_nuxt/ba8c165eda00c15ecf01.1670886052668.js" defer></script><script src="/_nuxt/7137465b6ed1f8f8117f.1670886052668.js" defer></script><script src="/_nuxt/6d78823361b361b26e8e.1670886052668.js" defer></script><script src="/_nuxt/f43604036a99b2bd5943.1670886052668.js" defer></script><script src="/_nuxt/a1a08f702653129ae9ee.1670886052668.js" defer></script><script src="/_nuxt/3d285c5b892e01014dee.1670886052668.js" defer></script><script src="/_nuxt/251a8d00407cdb46e20f.1670886052668.js" defer></script><script src="/_nuxt/62e277b21d1eb02fd398.1670886052668.js" defer></script>
  <script>(function(){var js = "window['__CF$cv$params']={r:'778f5dcd9ef220be',m:'qvqmMcLQoJP9VEPJ9vR8Q8dmC0T6z3ojznCGrZnixOI-1670941498-0-AWL5efR6JyIdEHCar5XwiBLE4IqogAlvYEsgOaOzyEifJ+JOqWfMoG1bNEeBi1trI9FHKHcHa0HOTvBq3yhk9YutdN6Du/tsyP4xPfSd4WkD72Gn7CYZV/F+KVqNY8Q9ztDhrvjh7v3/zgtSinsrXjVWIPKg2KGw5mcmNe+VK8LaWA8frVGAY8+EC9JgwmyuP3c6gsRZ0RSbmYE6WAdU34pxiMT8Uzj+fetCevYNrizC0LOwmFHyqJU7TDxVYneJIA==',s:[0x936be9138b,0x5575226344],u:'/cdn-cgi/challenge-platform/h/b'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/b/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script></body>
</html>
